Highpoint Rocket 1580/SSD7580 NVMe Problems

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

FireMedic949

New Member
Feb 2, 2019
3
1
3
Need some help with a server I'm building. I have an Asus P12R-M motherboard (in their RS300-E11-RS4 Barebone server) and a Highpoint Rocket 1580 (SSD7580) PCIe NVMe HBA card. I put everything together before I got the Rocket 1580. I have a pair of SATA SSDs for the OS (Server 2022 running Hyper-V) and plan on using the Rocket 1580 for an NVMe RAID 1 data array (non-bootable) for guest VMs. Everything worked fine and I installed Server 2022 on the SATA array. When I got the Rocket 1580 cards in, everything broke. Whenever the Rocket 1580 is installed, the board will not boot and hangs on Q-Code 15. Occasionally I'll get a beep code of 1 long/2 short (or it might be 2 short/1 long; can't remember and it's not giving the beep code currently). If I take the card out, it boots fine. I have three of the Rocket 1580 cards and all behave the same way.

BIOS was on 1201 and then I upgraded to the latest 1301 after I initially had problems. RAM tests good with MemTest. I have tried 1 through 4 sticks of ram in various DIMM slots. I have tried the PCIe x16 slot in Auto mode or forced x16 mode. I have tried the Rocket 1580 in the second x8 slot. I have also tried the three Rocket 1580 cards in two different desktop computers. One is a Lenovo and another is a Gigabyte H370N. On both of the computers, they will not boot and only show a black screen (unfortunately no POST/diagnostic codes like I have on the ASUS board). When I take the Rocket 1580 out, they boot fine. So 3 different Rocket 1580 cards on 3 different computers all refuse to boot.

Highpoint tech support has been no help. They just say that they haven't verified the Rocket 1580 with my motherboard (P12R-M) and that no one else has used it with that board and pretty much refuse to do anything else. They had no suggestions on BIOS/PCIe configuration. Thing is, they promote their cards as being drop in on just about anything. I've read their specs and compatibility reports and basically they just need PCIe x16 3.0 or 4.0 and a UEFI BIOS (to support booting from the cards which I'm not trying to do). They even have a positive compatibility report for a Gigabyte Z390 board which is in the same family as the H370 board I tried it with.

I have contacted ASUS tech support and they are escalating it. They said the Q-Code 15 is "NB Initialization before installed memory" and that it is a normal code although it shouldn't be hanging on it. They didn't know what the beep code was. The P12R-M manual doesn't list that particular beep code. Googling found a report for different ASUS board that it means that RAM was not detected.

It sounds like it's something RAM related when that card is plugged in. I feel like I'm missing something basic as this is supposed to be plug and play and yet it doesn't work with 3 different cards in 3 different computers. Any help would be much appreciated!
 

nexox

Active Member
May 3, 2023
436
162
43
Could be an SMBus conflict? This video suggests taping over a couple contacts on the PCIe connector, maybe worth a try: