Help! OmniOS Major Severity Error!

ZzBloopzZ

Member
Jan 7, 2013
91
13
8
Greetings,

The system is still resilvering after an entire week. Estimated time remaing is 701h36m!!! I cannot wait this long, I can hardly use the pool since performance is way too slow to even stream movies. Can't even successfully copy files from pool over network.

Pool status:


What are my options now? Is there a way to cancel resilvering process so I can pull out the the bad drive (c1t5000CCA37EC1F80Dd0) then start over? It seems that defective drive is slowing everything down to a crawl since it is near dead.
 

gea

Well-Known Member
Dec 31, 2010
2,514
852
113
DE
Don't worry, you have only a single disk failure,
you can remove the disk with the many hard errors.

I would unplug the disk, with a backplane just hot unplug the disk otherwise during a power off.
There is no other problem to be expected than a restart of the resilvering.
 

ZzBloopzZ

Member
Jan 7, 2013
91
13
8
Thank you gea!

I shut down the server with poweroff command. Unplugged defective drive. Powered back on and now resilvering is running much quicker!

11.6T scanned out of 19.8T at 869M/s, 2h44m to go
1.11T resilvered, 58.64% done

Woo Hoo!

Update: Resilver completed 2.5 hours later after taking out bad drive. Once complete, looks like it auto removed the bad drive from pool. Shut down, took out bad drive and replaced that slot with this resilvered one. Powered back on. Tested server and it has never been faster! Checked drive health, smartinfo and bonnie benchmark. Everything looks to be running great! I will scrub late tonight just in case. It was a good learning experience.
 
Last edited: