Enable Chelsio debug flag

Isaack

New Member
May 26, 2020
4
0
1
I'm running Pfsense 2.4.5 with a Chelsio T320 and it fails after a short period of time, sometimes days, other times hours. And I haven't been able to see any errors in the logs yet.
All I see that both of its ports loses network connection, sometimes with "No Carrier" as status other times ifconfig shows correct but the Arista switch still reports no connection.
A restart of Pfsense makes it work again.

But I've come across this flag: dev.cxgbc.0.enable_debug
Where do I set it? I tried /boot/loader.conf like this
dev.cxgbc.0.enable_debug="1"

But sysctl reports it as being disabled.
 

Isaack

New Member
May 26, 2020
4
0
1
I'm gonna go with a I350-T4 instead, seems to be better supported and suited for what I really need right now.
 

Isaack

New Member
May 26, 2020
4
0
1
I figured it out, the flag can be set under System Tunables under System -> Advanced in the pfSense UI.
You just need to a new setting with value 1