EMC (Seagate Constellation) 2 TB SAS drives are "blocked"

auroxin

New Member
Jun 19, 2022
8
1
3
I've got a bunch of EMC 2 TB SAS drives with PS0C firmware and an old 15 bay EMC VNX enclosure for them.

My problem is that the drives in the enclosure are not recognized as usable by my Dell H810 adapter -- they show up as "Blocked", and so I can't do anything with them.

For testing, I put a few 1 TB SATA drives into the enclosure -- they are recognized just fine and I can create a RAID array with them, so that shows that the enclosure, cabling, and the adapter are all good.

Questions:
Why would the SAS drives show up as "blocked"?
How can I remedy that without replacing the drives?
 

gregsachs

Active Member
Aug 14, 2018
489
156
43
Pretty sure your issue is 520b format on the drives;
https://www.reddit.com/r/simonheros/comments/izr5ml
 

auroxin

New Member
Jun 19, 2022
8
1
3
Thanks for your reply, but this is more than just a sector size difference. I hooked up one of the drives to a Perc 6/i with an appropriate cable -- the HA sees it, but also "blocked" in its setup menu. When I run "sg_scan" it does not show the 2 TB EMC drive, meaning that the Perc 6/i didn't pass the drive info to the OS, presumably because it sees the drive as "blocked".

I have some other functional SAS adapters (RocketRAID 26404, H710) but they either don't see the drive at all (RocketRAID), or in use (H710) and the 710 would most likely behave the same as the 810.
 

bonox

Member
Feb 23, 2021
65
15
8
my H810 displayed the same behaviour until i reflashed it to an HBA courtesy of @fodeesha

Pretty sure RAID controllers in general are very picky about non 512byte sectors. HBA's (proper ones, not a RAID card with some yumcha HBA mode=on) don't seem to care.

This is merely my experience with 4 STL3 shelves with ES.1 2TB drives.
 

auroxin

New Member
Jun 19, 2022
8
1
3
That may very well be, and I'll be getting another SAS adapter soon that supposed to have manufacturer supplied IT firmware. Hopefully, that will allow me to reformat the HDDs.

I plan to use HW Raid6 with my STL3, so I would rather leave the H810 alone.