Dell Xanadu C6100 XS23-SB Board Config Issues

Discussion in 'Processors and Motherboards' started by Jason Macer, Jan 7, 2020.

  1. Jason Macer

    Jason Macer New Member

    Joined:
    Jan 7, 2020
    Messages:
    10
    Likes Received:
    5
    I just discovered this site, and only thanks to my recently joining the Dell Poweredge-Tools mailing list.

    I have a 5 of these enclosures, each with 4 nodes, and I have generally *knock on wood* had very few problems with them. I have even been contemplating building a custom on/off/reset button feature as the board has the pins there to handle that, and even the LED's pins to show activity and power. My little environment has these guys, plus some r905, and 3 C6100 XS23-TY3 enclosures all running proxmox 5.2, and they really do the job just fine.

    A while back I purchased an enclosure with 3 nodes but no memory/processors/hard drives to use as spare parts. I powered the enclosure up and all of the boards posted and that's where I stopped. It unit was set aside until last weekend when a node in my environment failed and I had to replace it with one of these spare nodes. Everything went smoothly, and it didn't take me long to swap it out. Got everything back together and it worked like a champ, or so I thought.

    Like I said, everything works great except for one tiny, somewhat significant problem: NIC1 works NIC2 does not. In bios NIC1 shows up with the MAC address, but NIC2 shows no MAC address. Bad board, I thought so too. So I tried out a second board... Same issue. Then, a third... Same issue.

    So here is my question, what in the heck am I missing here. I cannot believe that all three of these boards have a bad NIC2. Is there additional settings inside the console access that might 'disable' the second NIC? I have gone through the traditional BIOS (BIOS Version 1.0.9 [Xanadu-S X7DWT BIOS]) and I cannot see where this might be hiding, except maybe the console.

    Has anyone else run into this issue?
     
    #1
  2. Jason Macer

    Jason Macer New Member

    Joined:
    Jan 7, 2020
    Messages:
    10
    Likes Received:
    5
    Good morning everyone.

    I honestly do not know if anyone has seen this thread or not; however, the culprit has been discovered and identified. I was looking all over the board and could not find, for the love of all that is on high, where there might be a jumper to disable NIC1 or NIC2. Here's the thing: I was looking around the interfaces when they were ... no where near them.

    As I said above, I joined a Dell PowerEdge mailing group and I struck up a back and forth with a guy over a Dell in their storage and embedded management group who had some experience with the ole' C6100 series. He found the board schematics and after a few messages we discovered that the schematics he had were for the 2nd generation XS23-TY3 boards, and not the XS23-SB boards.

    So, off I went to Supermicro where after spending almost 30 minutes on the phone with their tech support I was transferred to a guy who had been there for a while and remembered the boards. Needless to say he was able to get me the original Owner's Manual AND the last BIOS version update they released.

    I digress.

    I had been thinking that A.) there was a setting in console access that disabled the NICs, OR B.) there was jumper somewhere that disabled the NICs, but I didn't have the correct Owner's Manual before now. With manual in tow I started going through it page by page. Lo and behold wouldn't you know it there was a schematic on page 1-4, and on page 1-5 under the quick reference guide was a handy dandy Jumper description, and on lines 2 and 3 are JPL1 and JPL2 for GLAN1 and GLAN2 with them being enabled by default and "open", but they are "disabled" if jumpered.

    Granted I needed a freaking magnifying glass, but sure enough right there between the South Bridge chip and DIMM A was an white jumper disabling JPL2 / GLAN2 / NIC2.

    Now, I haven't gone to to my servers, and will not be able to until tomorrow, but that said I feel confident that the same jumper is in the same place.

    For edification purposes it was BIOS 1.2C and the actual file name is X7DWT0.B19, and though I ended up not needing to update the BIOS, I'm actually just curious and am considering flashing one of the spare boards I have JUST TO SEE if it works and if it MIGHT be worth pushing the update to all of the machines.

    So, if there is anyone out there who is also curious and would like the BIOS file, just shoot me a message and I'll get a copy of it over to you. Unfortunately I'm still going to have to find the AMI updating utility as Supermicro doesn't have access to it anymore.

    Hope everyone is having a good day!

    -Jason
     
    #2
    rnavarro likes this.
Similar Threads: Dell Xanadu
Forum Title Date
Processors and Motherboards Dell C6100 XANADU? Oct 16, 2013
Processors and Motherboards Dell C6100 XS23-TY3 2U 4-Node (8 CPU) one node BMC works other 3 not so much. Oct 23, 2019
Processors and Motherboards Anyone still using Dell C6100? Sep 2, 2019
Processors and Motherboards Dell r230, will 4x32GB ECC Modules work? Aug 14, 2019
Processors and Motherboards Dell C6100 Remote Management Controller Certificate Jun 7, 2019

Share This Page