Com port not opening when connecting via Terminal Services

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.


Well-Known Member
Mar 6, 2014
I experienced some issues while trying to flash a brocade switch, all of a sudden the com port was not working any more from a windows vm (had worked fine the eve before.

I solved this by moving the com connection over to a physical box (tnc).

Now i needed a Win VM again to flash (mellanox switch this time), so i dug deeper into this com issue. Tried the usual things (move to different host, reassign com port, make sure its still enabled etc). At some point i tried another Win VM, via web console window - and behold, it worked...

Fired up the other vm, connect via mstsc - nothing...hmm.
Logged on via web console ... it works ... hmmmmmm

Gist is - when trying to open via terminal client it does not work, when opened via web console it works, and I can re-use that session if i then use the current session via terminal client...

Anyone got any clue regarding why?