Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

lawrence1986

New Member
Sep 6, 2023
23
0
1
Well, that didnt work at all It installed and I can see it on putty but it wont fully boot i get alot of random debug errors for some reason i tryed to up date with the copy tftp flash and the manifest text both work i can see it on sh ver but will not load.
 

lawrence1986

New Member
Sep 6, 2023
23
0
1
i even went from 8095k and upgraded to the 8095m worked like a charm but for some reason why time it touchs 9.0 software its goes in to bipolar mode
 

SycoPath

Active Member
Oct 8, 2014
139
41
28
Been using an ICX6610 for a while I set up with the docs from Fohdeesha (huge thanks BTW), but recently trying to split my kids off onto a separate vlan and I can't seem to get it working. I was wondering if anyone had a minute to help. I've never set up vlans before, so this has been quite the learning experience for me.

Running pfSense virtualized with ESXi, Unifi AP's, and an ICX6610.
ISP--->AT&T Fiber Modem (hardware passthrough, 1GB intel NIC)-->Virtualized pfSense vmx0 -->Vmware vSwitch--> (ConnectX3 40GBE) ICX6610

Main network is 10.0.0.0/22 default vlan
Kids network planned to be 10.10.0.0/24 on vlan10
Unifi AP's are on 1/1/46 and 1/1/48 via 1GBE using POE
ESXi vSwitch is on 1/2/1 and 1/2/6 via ConnextX3 40GBE
pfSense connects to the vSwitch via vmx0
Right now, kids are all wireless, but I'll eventually be adding 1/1/23 and 1/1/24 to the kids vlan10 for desktops.
I've already set up a vlan10 network in Unifi, and a unique SSID.
pfSense already has a vlan10 set up on vmx0, and the interface assigned and enabled
pfSense WAN is igb1 via hardware passthrough to my AT&T fiber modem
I set up a DHCP server on pfSense for vlan10 for 10.10.0.50 to 10.10.0.200

I can't seem to get traffic passing through the ICX6610 switch, and I can't figure out what I'm doing wrong. I created a vlan10, tried adding the switch ports to it and putting them in dual mode, but then no traffic seems to pass, even from the untagged vlan. I know I need to set up 1/1/46, 1/1/48, 1/2/1 and 1/2/6 as trunks to pass all traffic, but I don't understand the command line syntax for it and I can't seem to get it right, or am I completely off base and misunderstanding the correct vlan topology?

I cleaned most of my experimentation and went back to a relatively clean show run for the ICX6610. Output below:
Code:
SSH@ICX6610-48P#show run
Current configuration:
!
ver 08.0.30uT7f3
!
stack unit 1
  module 1 icx6610-48p-poe-port-management-module
  module 2 icx6610-qsfp-10-port-160g-module
  module 3 icx6610-8-port-10g-dual-mode-module
stack disable
!
global-stp
!
!
!
vlan 1 name DEFAULT-VLAN by port
 router-interface ve 1
 spanning-tree
!
vlan 10 name KidsofChaos by port
 router-interface ve 10
 spanning-tree
!
!
!
!
!
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
jumbo
enable aaa console
hostname ICX6610-48P
ip dhcp-client disable
ip dns domain-list chaos.lan
ip dns server-address 10.0.1.20 10.0.1.21
ip route 0.0.0.0/0 10.0.0.1
!
no telnet server
username root password .....
!
!
clock summer-time
clock timezone us Eastern
!
!
ntp
 disable serve
 server 10.0.0.1 minpoll 10
!
!
web-management https
web-management session-timeout 600
!
!
router rip
!
!
!
!
!
!
!
interface ethernet 1/1/1
 inline power
!
interface ethernet 1/1/2
 inline power
!
interface ethernet 1/1/3
 inline power
!
interface ethernet 1/1/4
 inline power
!
interface ethernet 1/1/5
 inline power
!
interface ethernet 1/1/6
 inline power
!
interface ethernet 1/1/7
 inline power
!
interface ethernet 1/1/8
 inline power
!
interface ethernet 1/1/9
 inline power
!
interface ethernet 1/1/10
 inline power
!
interface ethernet 1/1/11
 inline power
!
interface ethernet 1/1/12
 inline power
!
interface ethernet 1/1/13
 inline power
!
interface ethernet 1/1/14
 inline power
!
interface ethernet 1/1/15
 inline power
!
interface ethernet 1/1/16
 inline power
!
interface ethernet 1/1/17
 inline power
!
interface ethernet 1/1/18
 inline power
!
interface ethernet 1/1/19
 inline power
!
interface ethernet 1/1/20
 inline power
!
interface ethernet 1/1/21
 inline power
!
interface ethernet 1/1/22
 inline power
!
interface ethernet 1/1/23
 inline power
!
interface ethernet 1/1/24
 inline power
!
interface ethernet 1/1/25
 inline power
!
interface ethernet 1/1/26
 inline power
!
interface ethernet 1/1/27
 inline power
!
interface ethernet 1/1/28
 inline power
!
interface ethernet 1/1/29
 inline power
!
interface ethernet 1/1/30
 inline power
!
interface ethernet 1/1/31
 inline power
!
interface ethernet 1/1/32
 inline power
!
interface ethernet 1/1/33
 inline power
!
interface ethernet 1/1/34
 inline power
!
interface ethernet 1/1/35
 inline power
!
interface ethernet 1/1/36
 inline power
!
interface ethernet 1/1/37
 inline power
!
interface ethernet 1/1/38
 inline power
!
interface ethernet 1/1/39
 inline power
!
interface ethernet 1/1/40
 inline power
!
interface ethernet 1/1/41
 inline power
!
interface ethernet 1/1/42
 inline power
!
interface ethernet 1/1/43
 inline power
!
interface ethernet 1/1/44
 inline power
!
interface ethernet 1/1/45
 inline power
!
interface ethernet 1/1/46
 inline power
!
interface ethernet 1/1/47
 inline power
!
interface ethernet 1/1/48
 inline power
!
interface ethernet 1/3/1
 speed-duplex 10G-full
!
interface ethernet 1/3/2
 speed-duplex 10G-full
!
interface ethernet 1/3/3
 speed-duplex 10G-full
!
interface ethernet 1/3/4
 speed-duplex 10G-full
!
interface ethernet 1/3/5
 speed-duplex 10G-full
!
interface ethernet 1/3/6
 speed-duplex 10G-full
!
interface ethernet 1/3/7
 speed-duplex 10G-full
!
interface ethernet 1/3/8
 speed-duplex 10G-full
!
interface ve 1
 ip address 10.0.0.2 255.255.252.0
!
interface ve 10
!
!
!
!
!
!
!
!
!
end
 

lawrence1986

New Member
Sep 6, 2023
23
0
1
this is what i did do i need to do anything its a 48 port non poe

enable
erase startup-config
copy disk0 system-manifest FI09010f_Manifest.txt primary switch
reload


enable
conf t
ip address xxx.xxx.x.x. 255.255.255.0
ip default-gateway xxx.xxx.x.x
web-management http
write mem
exit
reload

enable
copy flash flash secondary
 

LodeRunner

Active Member
Apr 27, 2019
546
228
43
Been using an ICX6610 for a while I set up with the docs from Fohdeesha (huge thanks BTW), but recently trying to split my kids off onto a separate vlan and I can't seem to get it working. I was wondering if anyone had a minute to help. I've never set up vlans before, so this has been quite the learning experience for me.

Running pfSense virtualized with ESXi, Unifi AP's, and an ICX6610.
ISP--->AT&T Fiber Modem (hardware passthrough, 1GB intel NIC)-->Virtualized pfSense vmx0 -->Vmware vSwitch--> (ConnectX3 40GBE) ICX6610

Main network is 10.0.0.0/22 default vlan
Kids network planned to be 10.10.0.0/24 on vlan10
Unifi AP's are on 1/1/46 and 1/1/48 via 1GBE using POE
ESXi vSwitch is on 1/2/1 and 1/2/6 via ConnextX3 40GBE
pfSense connects to the vSwitch via vmx0
Right now, kids are all wireless, but I'll eventually be adding 1/1/23 and 1/1/24 to the kids vlan10 for desktops.
I've already set up a vlan10 network in Unifi, and a unique SSID.
pfSense already has a vlan10 set up on vmx0, and the interface assigned and enabled
pfSense WAN is igb1 via hardware passthrough to my AT&T fiber modem
I set up a DHCP server on pfSense for vlan10 for 10.10.0.50 to 10.10.0.200

I can't seem to get traffic passing through the ICX6610 switch, and I can't figure out what I'm doing wrong. I created a vlan10, tried adding the switch ports to it and putting them in dual mode, but then no traffic seems to pass, even from the untagged vlan. I know I need to set up 1/1/46, 1/1/48, 1/2/1 and 1/2/6 as trunks to pass all traffic, but I don't understand the command line syntax for it and I can't seem to get it right, or am I completely off base and misunderstanding the correct vlan topology?

I cleaned most of my experimentation and went back to a relatively clean show run for the ICX6610. Output below:
Code:
SSH@ICX6610-48P#show run
Current configuration:
!
ver 08.0.30uT7f3
!
stack unit 1
  module 1 icx6610-48p-poe-port-management-module
  module 2 icx6610-qsfp-10-port-160g-module
  module 3 icx6610-8-port-10g-dual-mode-module
stack disable
!
global-stp
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
spanning-tree
!
vlan 10 name KidsofChaos by port
router-interface ve 10
spanning-tree
!
!
!
!
!
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
jumbo
enable aaa console
hostname ICX6610-48P
ip dhcp-client disable
ip dns domain-list chaos.lan
ip dns server-address 10.0.1.20 10.0.1.21
ip route 0.0.0.0/0 10.0.0.1
!
no telnet server
username root password .....
!
!
clock summer-time
clock timezone us Eastern
!
!
ntp
disable serve
server 10.0.0.1 minpoll 10
!
!
web-management https
web-management session-timeout 600
!
!
router rip
!
!
!
!
!
!
!
interface ethernet 1/1/1
inline power
!
interface ethernet 1/1/2
inline power
!
interface ethernet 1/1/3
inline power
!
interface ethernet 1/1/4
inline power
!
interface ethernet 1/1/5
inline power
!
interface ethernet 1/1/6
inline power
!
interface ethernet 1/1/7
inline power
!
interface ethernet 1/1/8
inline power
!
interface ethernet 1/1/9
inline power
!
interface ethernet 1/1/10
inline power
!
interface ethernet 1/1/11
inline power
!
interface ethernet 1/1/12
inline power
!
interface ethernet 1/1/13
inline power
!
interface ethernet 1/1/14
inline power
!
interface ethernet 1/1/15
inline power
!
interface ethernet 1/1/16
inline power
!
interface ethernet 1/1/17
inline power
!
interface ethernet 1/1/18
inline power
!
interface ethernet 1/1/19
inline power
!
interface ethernet 1/1/20
inline power
!
interface ethernet 1/1/21
inline power
!
interface ethernet 1/1/22
inline power
!
interface ethernet 1/1/23
inline power
!
interface ethernet 1/1/24
inline power
!
interface ethernet 1/1/25
inline power
!
interface ethernet 1/1/26
inline power
!
interface ethernet 1/1/27
inline power
!
interface ethernet 1/1/28
inline power
!
interface ethernet 1/1/29
inline power
!
interface ethernet 1/1/30
inline power
!
interface ethernet 1/1/31
inline power
!
interface ethernet 1/1/32
inline power
!
interface ethernet 1/1/33
inline power
!
interface ethernet 1/1/34
inline power
!
interface ethernet 1/1/35
inline power
!
interface ethernet 1/1/36
inline power
!
interface ethernet 1/1/37
inline power
!
interface ethernet 1/1/38
inline power
!
interface ethernet 1/1/39
inline power
!
interface ethernet 1/1/40
inline power
!
interface ethernet 1/1/41
inline power
!
interface ethernet 1/1/42
inline power
!
interface ethernet 1/1/43
inline power
!
interface ethernet 1/1/44
inline power
!
interface ethernet 1/1/45
inline power
!
interface ethernet 1/1/46
inline power
!
interface ethernet 1/1/47
inline power
!
interface ethernet 1/1/48
inline power
!
interface ethernet 1/3/1
speed-duplex 10G-full
!
interface ethernet 1/3/2
speed-duplex 10G-full
!
interface ethernet 1/3/3
speed-duplex 10G-full
!
interface ethernet 1/3/4
speed-duplex 10G-full
!
interface ethernet 1/3/5
speed-duplex 10G-full
!
interface ethernet 1/3/6
speed-duplex 10G-full
!
interface ethernet 1/3/7
speed-duplex 10G-full
!
interface ethernet 1/3/8
speed-duplex 10G-full
!
interface ve 1
ip address 10.0.0.2 255.255.252.0
!
interface ve 10
!
!
!
!
!
!
!
!
!
end
Looking at what you pasted, I don't see that you've added any ports to the VLAN as either tagged or untagged. I only have 7k series units, so my syntax is slightly different for trunking, but for a pure trunk port where you have may not need a default/native/untagged VLAN, the command should be similar to:
Code:
SSH@office-sw(config-vlan-4)#tag e 1/3/1
Issued inside the VLAN context.

Edge ports to workstations would be untagged, like:
Code:
SSH@office-sw(config-vlan-4)#untag e 1/1/1
If you're coming from any Cisco experience, ICX does it in reverse. Where you go into a port and add VLANs to the port(Cisco style), ICX does what HPE switches do: you go to a VLAN and add the ports to the VLAN.
 

NablaSquaredG

Destroyer of Mellanox switches
Aug 17, 2020
1,432
877
113
What PoE hardware did they use the 7250 series?
This is the second 7250 I got with blown PoE hardware now... Never seen this on any other switch
 

SycoPath

Active Member
Oct 8, 2014
139
41
28
Looking at what you pasted, I don't see that you've added any ports to the VLAN as either tagged or untagged. I only have 7k series units, so my syntax is slightly different for trunking, but for a pure trunk port where you have may not need a default/native/untagged VLAN, the command should be similar to:
Code:
SSH@office-sw(config-vlan-4)#tag e 1/3/1
Issued inside the VLAN context.

Edge ports to workstations would be untagged, like:
Code:
SSH@office-sw(config-vlan-4)#untag e 1/1/1
I'm still missing it I think, sorry. Adding switch ports to a vlan tells the switch which vlan that port should be, but you also need to issue the tag e port# as well so tagged/untagged traffic will flow? This might be what I was missing.

For example for my config, I have two workstations that should be vlan 10, 1/1/23 and 1/1/24. Everything else should be untagged on the default vlan1, except trunk ports. Trunk ports are 1/3/1 and 1/3/6 for the connection from esxi to the icx6610, and both of these should be dual mode, correct? Same with 1/1/46 and 1/1/48. These come from the unifi AP's and will be carrying both vlan10 and vlan1 traffic, so they need to be dual mode and tagged as well, correct?

I need tagged and untagged to flow on trunk ports, and I'm not understanding how to do this.

Does this look correct?

Vlan 1

Code:
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/1/1 to 1/1/22
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/1/25 to 1/1/45
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/1/46 to 1/1/48
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/3/1 
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/3/6
Vlan 10

Code:
ICX6610-48P(config-vlan-10)# Untagged eth 1/1/24 to 1/1/25
ICX6610-48P(config-vlan-10)# Tagged eth 1/1/46 to 1/1/48
ICX6610-48P(config-vlan-10)# Tagged eth 1/3/1 
ICX6610-48P(config-vlan-10)# Tagged eth 1/3/6
Dual mode for trunk ports

Code:
SSH@ICX6610-48P(config)# int eth 1/1/46
SSH@ICX6610-48P(config-if-e10000-1/1/46)# dual-mode
SSH@ICX6610-48P(config)# int eth 1/1/47
SSH@ICX6610-48P(config-if-e10000-1/1/47)# dual-mode
SSH@ICX6610-48P(config)# int eth 1/1/48
SSH@ICX6610-48P(config-if-e10000-1/1/48)# dual-mode
SSH@ICX6610-48P(config)# int eth 1/3/1
SSH@ICX6610-48P(config-if-e10000-1/3/1)# dual-mode
SSH@ICX6610-48P(config)# int eth 1/3/6
SSH@ICX6610-48P(config-if-e10000-1/3/6)# dual-mode
 

Ralph_IT

I'm called Ralph
Apr 12, 2021
189
103
43
/home
Hi,
I bought an 7250-48P but I cannot see the console nor I am able to find a way to enter its configuration or http page.
I'm using this mini-usb to RS232 cable (don't know if it is valid) but after opening the COM port with putty, all I see is a black screen. No messages, no boot, no login...
I think the switch does boot up and loads the OS, as the fans begin at full speed and a couple of minutes later they rev down.

Any ideas to where to go from here?
 

LodeRunner

Active Member
Apr 27, 2019
546
228
43
Thanks for the quick reply.
I've searched for the pinout but it seems it's nowhere to be found.
Found a DIY tuto on Reddit which implies shredding a micro usb and a Cisco cable.
Yes, that's pretty much it. buy the official Ruckus cable or hack one together. If a previous owner plugged in a standard USB cable expecting a USB to serial UART on the far end, then they most likely burned it out completely since they would have hit the serial port with USB line voltage.

Maybe this is the Reddit post you found: Reddit post

I don't know if that was the post I followed, but I chopped up a USB cable and attached it to a keystone so I didn't have to mangle my perfectly good Cisco cable. I have since bought a proper Ruckus cable.
 
  • Like
Reactions: Ralph_IT

Ralph_IT

I'm called Ralph
Apr 12, 2021
189
103
43
/home
Yes, that's pretty much it. buy the official Ruckus cable or hack one together. If a previous owner plugged in a standard USB cable expecting a USB to serial UART on the far end, then they most likely burned it out completely since they would have hit the serial port with USB line voltage.

Maybe this is the Reddit post you found: Reddit post

I don't know if that was the post I followed, but I chopped up a USB cable and attached it to a keystone so I didn't have to mangle my perfectly good Cisco cable. I have since bought a proper Ruckus cable.
That's one of the 2 post on Reddit that I found (Here's the other).
What are the chances of configuring a switch with a burnt usb serial port?

The official cable/adapter combos are available if you look for them; some of us have spares and are willing to sell them too, if that's something you want to consider.
I wouldn't mind buying one official cable if I can make the switch work first.
 

bwahaha

Member
Jun 9, 2023
93
65
18
  • Like
Reactions: Ralph_IT

fohdeesha

Kaini Industries
Nov 20, 2016
2,787
3,167
113
33
fohdeesha.com
That's one of the 2 post on Reddit that I found (Here's the other).
What are the chances of configuring a switch with a burnt usb serial port?


I wouldn't mind buying one official cable if I can make the switch work first.
I would bet $50 the console port is fine, tons of people just in this thread have accidentally plugged regular USB ports into them, they can handle it fine. your issue is probably your usb to serial adapter, use it with another serial device to verify it actually works, or buy an ftdi model off amazon. also official console cables for these are only like 20 bucks to take the guesswork out of wiring Brocade ICX7250, ICX7450 ICX7750 DB9 Female to USB Mini Serial Console Cable 6FT | eBay
 
  • Like
Reactions: Ralph_IT

SycoPath

Active Member
Oct 8, 2014
139
41
28
I'm still missing it I think, sorry. Adding switch ports to a vlan tells the switch which vlan that port should be, but you also need to issue the tag e port# as well so tagged/untagged traffic will flow? This might be what I was missing.

For example for my config, I have two workstations that should be vlan 10, 1/1/23 and 1/1/24. Everything else should be untagged on the default vlan1, except trunk ports. Trunk ports are 1/3/1 and 1/3/6 for the connection from esxi to the icx6610, and both of these should be dual mode, correct? Same with 1/1/46 and 1/1/48. These come from the unifi AP's and will be carrying both vlan10 and vlan1 traffic, so they need to be dual mode and tagged as well, correct?

I need tagged and untagged to flow on trunk ports, and I'm not understanding how to do this.

Does this look correct?

Vlan 1

Code:
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/1/1 to 1/1/22
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/1/25 to 1/1/45
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/1/46 to 1/1/48
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/3/1
SSH@ICX6610-48P(config-vlan-1)# Untagged eth 1/3/6
Vlan 10

Code:
ICX6610-48P(config-vlan-10)# Untagged eth 1/1/24 to 1/1/25
ICX6610-48P(config-vlan-10)# Tagged eth 1/1/46 to 1/1/48
ICX6610-48P(config-vlan-10)# Tagged eth 1/3/1
ICX6610-48P(config-vlan-10)# Tagged eth 1/3/6
Dual mode for trunk ports

Code:
SSH@ICX6610-48P(config)# int eth 1/1/46
SSH@ICX6610-48P(config-if-e10000-1/1/46)# dual-mode
SSH@ICX6610-48P(config)# int eth 1/1/47
SSH@ICX6610-48P(config-if-e10000-1/1/47)# dual-mode
SSH@ICX6610-48P(config)# int eth 1/1/48
SSH@ICX6610-48P(config-if-e10000-1/1/48)# dual-mode
SSH@ICX6610-48P(config)# int eth 1/3/1
SSH@ICX6610-48P(config-if-e10000-1/3/1)# dual-mode
SSH@ICX6610-48P(config)# int eth 1/3/6
SSH@ICX6610-48P(config-if-e10000-1/3/6)# dual-mode
Does anyone get a moment to look this over and make sure this will work before I send myself down a 2-3 hour rabbit hole again?
 

Ralph_IT

I'm called Ralph
Apr 12, 2021
189
103
43
/home
how are you with component repairs? Most likely, it'll have popped the uart chip. They may have thought ahead and put some sacrificial components in the path that can be swapped out.

It also looks like it may be a daughter board.
I would bet $50 the console port is fine, tons of people just in this thread have accidentally plugged regular USB ports into them, they can handle it fine. your issue is probably your usb to serial adapter, use it with another serial device to verify it actually works, or buy an ftdi model off amazon. also official console cables for these are only like 20 bucks to take the guesswork out of wiring Brocade ICX7250, ICX7450 ICX7750 DB9 Female to USB Mini Serial Console Cable 6FT | eBay
Luckyly for me, @fohdeesha was right and culprit was the mini USB adapter I was using, because I suck at manual skills requiring precision.
I did a guetto mini usb to serial adapter following the reddit guide and it worked, but needed to redo the wiring more than 10 times.

I'm following the guide right now to have the latest firmware flashed.
Time to check if all ports work normally, POE included.

Definitely I want a proper console cable, so will post a WTB on the forum soon.
 

Craig Curtin

Member
Jun 18, 2017
103
20
18
59
Hey Guys,

I have a couple of 6610s here - one is my testing and messing around one and the other in production.

Currently i am using two of the rear ports at 40Gb/s into Mellanox cards in my ESXi cluster.

I could really use a 3rd one though for my final host

At the moment i am using the 2 x extra ports (stacking) at the back with a fanout 4x10Gb cable to other hosts

Is it possible to turn stacking on for just one of the ports on the rear so i could stack a 2nd 6610 and then use its 2 x 40Gb ports to connect my hosts and use one fanout on each of the switches to connect other clients ?

So it would look like

2 x 40GB on the first switch to ESXI hosts
1 x Fanout from stacking port on first switch to 10GB clients
1 x stacking port on first switch at 40Gb to 2nd switch

1 x 40GB port on 2nd switch to ESXi host ?

So the basic question i guess is once the stacking is turned on - are both ports put into stacking mode ?

Do i just use a stadnard QSFP cable to stack both switches ?

Craig
 

MrGuvernment

Member
Nov 16, 2020
42
8
8
  • Like
Reactions: gseeley