Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

zunder1990

Active Member
Nov 15, 2012
209
71
28
My ICX 6450 is shutting down once a week. I have to disconnect it from the power and leave it for several hours before it will turn on again. Assumed it might be heat related, but the last time it shutdown was a cool day, and the room was well ventilated. Has happend three times now and seems to be happening about a week apart.

Any ideas/tips on how to try and investigate the problem?
What does the logs say, also get a console cable and see if there was any console messages.
 

autumnwalker

New Member
Nov 4, 2019
3
2
3
At the very least their documentation should be updated to state the command only works on the FCX (I've ran into a couple other commands like this, that exist in the base firmware but only become active when booted on an FCX, namely "ip ssh key-exchange-method dh-group14-sha1"
Was there ever any update on this perticular command? I'd like to enable group14 ... but as stated, the command isn't available on my ICX.
 

msg7086

Active Member
May 2, 2017
423
148
43
36
Hey, I just got some of these but they seem to have 4 leads (red, yellow, black, blue). Any suggestion on how to wire them to ICX6450-48P?

Thanks!
UPDATE: After putting them in, the unit overheated and lost response in a few minutes.
 

ManoftheSea

Member
Apr 18, 2023
39
16
8
Thanks for this thread. I got an ICX6450 based on it. And now, the configuration.
Would fohdeesha like any extra content for the guide, such as "VLANs", "ACLs", or "IPv6 configuration" (when/if I learn these things)?
At the moment, I think the router should be able to route using nothing more than link-local addresses, but I can't figure out how to configure a ve to route to a VLAN without having an address within the prefix. I'm also faking Prefix Delegation by setting it up statically.
 

ManoftheSea

Member
Apr 18, 2023
39
16
8
I understand that's what I want to do. However, where the "ip" command will accept an interface or ve as "next-hop", the ipv6 command requires a gateway address, which I understand to be the destination for this hop. As far as I understand the documentation, I should be able to run the command within the (config) level:
ipv6 route 2001:db8::/64 ve 3
But the interface tells me "gateway address is required".
ip ve as hop Configuring a virtual interface as next hop
ipv6 route Commscope Technical Content Portal
 

ManoftheSea

Member
Apr 18, 2023
39
16
8
Hmm, it gets worse. The router advertisement will announce the interface's global-scope (including ULA) ipv6 addresses and prefixes (unless suppressed, which it can do per address). However, it also doesn't look like there's a way to configure static routes in RAs. It's either default or nothing.
 

CHANABRA

Member
Dec 26, 2021
31
6
8
Hey i got a ICX 7250-24P offer accepted for 225 so I thought I should take it. it is not PoE. but it only has a 12v mini psu inside and 1 40x28 fan.

it seems I could add 3 less loud 40x20ish fans on the air intake side, and then either remove the loud fan or drill with 40mm holesaw (it has hardware to mount 3 exhaust fans but only one air hole) ...

I was wondering, I do need to have a security cam setup, but I can achieve the same thing as having this ICX7250 POE, by simply getting say
CSS610-8P-2S+IN thats a 8 port 1gb poe with 2 SFP+ , so I could then isolate that 10gb port on the 7250 and achieve the same thing right?

anyone have any experience modding this one for silence? i believe since there is only one fan it wont be hard... i was thinking about adding 60mmx60mmx10mm fans directly above the chips that get hot, so probably 3 inside there, remove the exhaust noisy fan, and put 3 quieter intake fans which combined CFM is greater than the previous 1 exhaust fan... that way I can keep the original case...
lmk how this sounds thanks STH
 

kpfleming

Active Member
Dec 28, 2021
389
205
43
Pelham NY USA
ICX 7250-24P offer accepted for 225 so I thought I should take it. it is not PoE
If it's not PoE, it's a 7250-24, not a 7250-24P :)

so I could then isolate that 10gb port on the 7250 and achieve the same thing right
You didn't describe what you meant by 'the same thing'. Yes, you can link the CSS610 to the 7250 via SFP+ ports (using a DAC or AOC) and if the 7250 is primarily operating in layer 2 mode then you've essentially added 8 1GbE PoE ports to the overall network.
 

Kahooli

Member
Dec 3, 2022
41
26
18
Well darn, looks like port 1/2/7 on my 6610 is damaged or misconfigured in some way.
I was using a breakout dac to my mikrotik crs312 sfp ports and 1/2/2-1/2/5 work just fine for LAG. but configuring the other breakout port the same way and putting the breakout into it - only 3 will show up as active.
I wonder If it's worth it to take apart and see if it's a component or solder issue that could be easily repairs - or a damaged PHY port. Probably not yet, since I dont have that many 40g devices yet.
 

Blue)(Fusion

Active Member
Mar 1, 2017
150
56
28
Chicago
I understand that's what I want to do. However, where the "ip" command will accept an interface or ve as "next-hop", the ipv6 command requires a gateway address, which I understand to be the destination for this hop. As far as I understand the documentation, I should be able to run the command within the (config) level:
ipv6 route 2001:db8::/64 ve 3
But the interface tells me "gateway address is required".
ip ve as hop Configuring a virtual interface as next hop
ipv6 route Commscope Technical Content Portal
This....
I found the layer 3 IPv6 support in the ICX very limiting

BUT

All hope is not lost. I've been trying to maximize my IPv6 use as of late and all but IoT gear that simply completely lacks IPv6 support are running IPv6 using my ICX 6610 as my core L3 router.

Some caveats...

As you've found out, the ICX routing firmware does not handle SLAAC or other EUI64 automatic addresses on it's interfaces*. If you have an ISP that occasionally changes your IPv6 prefix, you have to reconfigure each interface every time it changes. A PITA, but with Spectrum so far my IPv6 /56 only changes if I change my internet-facing OPNSense MAC/install or the modem is offline for extended periods (a day or more).

(* The switching-only firmware works just fine with IPv6 SLAAC on it's management interface.)

To help the situation of changing ISP-assigned IPv6 prefixes, set the ICX to broadcast the prefix with a very low valid time.
Code:
int ve 1234
ipv6 address 2601:3726:ab25:329a::1/64
ipv6 nd prefix-advertisement 2601:3726:ab25:329a::/64 1800 600 onlink autoconfig
As far as your routing situation, it needs to know where to send the packets with either a router advertisement or a static assigned gateway. Can't just send it out of an interface. AFAIK, other switch firmware is similar.

So your choices are (less RIP/OSPF/BGP):
Code:
ipv6 route 2001:db8::/64 ve 3 fe80::1 (link-local address and specific interface the link-local address is attached)
ipv6 route 2001:db8::/64 2001:1234::1 (a GUA or ULA address that is on an attached and routable subnet)
Or no static route and instead rely on a router advertisement that contains the desired subnet route.
 
  • Like
Reactions: ManoftheSea

pinkypie

New Member
Dec 2, 2021
20
3
3
Hey guys, I need some help figuring out how to troubleshoot a problem. I have a brocade switch that I setup a VLAN to control around 12 cameras. The VLANs are set up as 192.168.3.x.

The problem is, I needed to reset a camera and I reset the camera to factory defaults, the IP defaults to 192.168.1.108.

I am unable to connect to this camera now to set it up. I set the system up several years ago and I forgot what I did then to add cameras to the network and reassign the IP addresses.

I thought I set up one of the ports on the brocade to be able to talk to all the other ports but I can't remember what I did.

What is the best way to access 192.168.1.108? Not sure what to google to try and figure this out. I don't know what port this particular camera is connected to.

Code:
vlan 1 by port
untagged ethe 1/1/1
router-interface ve 1
!
vlan 2 by port
!
vlan 3 by port
untagged ethe 1/1/2 to 1/1/24
router-interface ve 3
!
vlan 999 name DEFAULT-VLAN by port

!
interface ve 1
ip address 192.168.1.250 255.255.255.0
!
interface ve 3
ip access-group 100 in
ip address 192.168.3.1 255.255.255.0
 
Last edited:

kpfleming

Active Member
Dec 28, 2021
389
205
43
Pelham NY USA
You didn't specify, but if the cameras are attached to vlan 3 then you can't reach one that is using address 192.168.1.108 since you have that subnet on vlan 1.

You can temporarily move that camera's port into VLAN 1, configure the camera, then move it back, but if you don't know the port number that will be challenging.
 

sic0048

Active Member
Dec 24, 2018
119
99
28
Well darn, looks like port 1/2/7 on my 6610 is damaged or misconfigured in some way.
I was using a breakout dac to my mikrotik crs312 sfp ports and 1/2/2-1/2/5 work just fine for LAG. but configuring the other breakout port the same way and putting the breakout into it - only 3 will show up as active.
I wonder If it's worth it to take apart and see if it's a component or solder issue that could be easily repairs - or a damaged PHY port. Probably not yet, since I dont have that many 40g devices yet.
Does the unit have stacking turned on? It's possible that QSFP port is currently setup for linking.
 

CHANABRA

Member
Dec 26, 2021
31
6
8
well it was labeled as one, so i got a partial refund thank you... still in market for a poe version...
i meant -- this is a L3 switch right, so I could theoretically have another managed switch with PoE even 2.5gb poe or higher, and a 10gb uplink to this switch, and I could put the L3 magic on that port and thus get a similar outcome to having a the poe version?

also, what is the best or highest firmware 7250 models are recommended to be on ?

last question --- is the 7250 a switch that has issues as a DHCP server?? that was one of the reasons among many others I went this direction. if it does have issues, what is the best solution for a dhcp server so I can setup the 7250 with dhcp relay or whatever?

thanks