Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

rocketpanda40

Member
Dec 12, 2019
39
24
8
forgive my newbie question, but how exactly do you do that?
Where on the 6xxx you have to do this:
Code:
vlan 69
tag eth 1/1/12

vlan 80t
tag eth 1/1/12

int eth 1/1/12
dual-mode 80
On the 7xxx, all you have to do is:
Code:
vlan 69
tag eth 1/1/12

vlan 80
untag eth 1/1/12
 

epicurean

Active Member
Sep 29, 2014
744
64
28
Please correct me if I am wrong
so if its port 1 on the 7150 that is connected to the 6450, these would be the commands I need to input to allow vlan 80 and vlan1 traffic to pass on to 7150?

vlan 80
tag ethe 1/1/1

and if want vlan 80 only to port 12 of the 7150?

vlan 80
untag ethe 1/1/12
 
Last edited:

kpfleming

Active Member
Dec 28, 2021
227
105
43
Pelham NY USA
Please correct me if I am wrong
so if its port 1 on the 7150 that is connected to the 6450, these would be the commands I need to input to allow vlan 80 and vlan1 traffic to pass on to 7150?

vlan 80
tag ethe 1/1/1

and if want vlan 80 only to port 12 of the 7150?

vlan 80
untag ethe 1/1/12
Yes. All of this is well documented in the Ruckus manuals, by the way :)
 

epicurean

Active Member
Sep 29, 2014
744
64
28
Yes. All of this is well documented in the Ruckus manuals, by the way :)
Hmm..didnt seem to work. my ip camera on vlan 80 cannot be accessed. I must be doing something wrong. this is the 7150 with show vlan


PORT-VLAN 1, Name DEFAULT-VLAN, Priority level0, Off
Untagged Ports: (U1/M1) 1 2 3 4 5 6 7 8 9 10 11
Untagged Ports: (U1/M2) 1 2
Untagged Ports: (U1/M3) 1 2
Tagged Ports: None
Mac-Vlan Ports: None
Monitoring: Disabled

PORT-VLAN 80, Name [None], Priority level0, Off
Untagged Ports: (U1/M1) 12
Tagged Ports: (U1/M1) 1
Mac-Vlan Ports: None
Monitoring: Disabled
 

LodeRunner

Active Member
Apr 27, 2019
455
199
43
Hmm..didnt seem to work. my ip camera on vlan 80 cannot be accessed. I must be doing something wrong. this is the 7150 with show vlan


PORT-VLAN 1, Name DEFAULT-VLAN, Priority level0, Off
Untagged Ports: (U1/M1) 1 2 3 4 5 6 7 8 9 10 11
Untagged Ports: (U1/M2) 1 2
Untagged Ports: (U1/M3) 1 2
Tagged Ports: None
Mac-Vlan Ports: None
Monitoring: Disabled

PORT-VLAN 80, Name [None], Priority level0, Off
Untagged Ports: (U1/M1) 12
Tagged Ports: (U1/M1) 1
Mac-Vlan Ports: None
Monitoring: Disabled
Post 'sh run' from both switches. You can wrap them in CODE and SPOILER tags to keep formatting and also not flood the page. The '...' drop down next to the Emoji in the editor can help you with that.
 

epicurean

Active Member
Sep 29, 2014
744
64
28
Post 'sh run' from both switches. You can wrap them in CODE and SPOILER tags to keep formatting and also not flood the page. The '...' drop down next to the Emoji in the editor can help you with that.
SSH@ICX6450-48P Router(config)#sh run
Current configuration:
!
ver 08.0.30tT313
!
stack unit 1
module 1 icx6450-48p-poe-port-management-module
module 2 icx6450-sfp-plus-4port-40g-module
!
global-stp
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
vlan 30 name guests by port
tagged ethe 1/1/25 to 1/1/27 ethe 1/1/47 to 1/1/48
!
vlan 60 name IOT by port
tagged ethe 1/1/25 to 1/1/27 ethe 1/1/38 to 1/1/39 ethe 1/1/46 to 1/1/48
!
vlan 80 name CCTV by port
tagged ethe 1/1/35 ethe 1/1/47 to 1/1/48
untagged ethe 1/1/1 to 1/1/16 ethe 1/1/37
!
!
!
!
!
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
enable telnet authentication
ip dns server-address 192.168.0.1
ip route 0.0.0.0/0 192.168.0.1
!
username root password .....
snmp-server location Hillcrest
!
!
clock timezone gmt GMT+08
!
!
ntp
disable serve
server 216.239.35.0
server 216.239.35.4
!
!
!
!
!
interface ethernet 1/1/1
inline power
!
interface ethernet 1/1/2
inline power
!
interface ethernet 1/1/3
inline power
!
interface ethernet 1/1/4
inline power
!
interface ethernet 1/1/5
inline power
!
interface ethernet 1/1/6
inline power
!
interface ethernet 1/1/7
inline power
!
interface ethernet 1/1/8
inline power
!
interface ethernet 1/1/9
inline power
!
interface ethernet 1/1/10
inline power
!
interface ethernet 1/1/11
inline power
!
interface ethernet 1/1/12
inline power
!
interface ethernet 1/1/13
inline power
!
interface ethernet 1/1/14
inline power
!
interface ethernet 1/1/15
inline power
!
interface ethernet 1/1/16
inline power
!
interface ethernet 1/1/17
inline power
!
interface ethernet 1/1/18
inline power
!
interface ethernet 1/1/19
inline power
!
interface ethernet 1/1/20
inline power
!
interface ethernet 1/1/21
inline power
!
interface ethernet 1/1/22
inline power
!
interface ethernet 1/1/23
inline power
!
interface ethernet 1/1/24
inline power
!
interface ethernet 1/1/25
dual-mode
inline power
!
interface ethernet 1/1/26
dual-mode
inline power
!
interface ethernet 1/1/27
dual-mode
inline power
!
interface ethernet 1/1/28
inline power
!
interface ethernet 1/1/29
inline power
!
interface ethernet 1/1/30
inline power
!
interface ethernet 1/1/31
inline power
!
interface ethernet 1/1/32
inline power
!
interface ethernet 1/1/33
inline power
!
interface ethernet 1/1/34
inline power
!
interface ethernet 1/1/35
dual-mode
inline power
!
interface ethernet 1/1/36
inline power
!
interface ethernet 1/1/37
inline power
!
interface ethernet 1/1/38
dual-mode
inline power
!
interface ethernet 1/1/39
dual-mode
!
interface ethernet 1/1/40
inline power
!
interface ethernet 1/1/41
inline power
!
interface ethernet 1/1/42
inline power
!
interface ethernet 1/1/46
dual-mode
inline power
!
interface ethernet 1/1/47
dual-mode
!
interface ethernet 1/1/48
dual-mode
!
interface ve 1
ip address 192.168.0.18 255.255.255.0
!
!
!
!
!
!
!
!
!
end

SSH@icx7150B#sh run
Current configuration:
!
ver 08.0.92eT213
!
stack unit 1
module 1 icx7150-c12-poe-port-management-module
module 2 icx7150-2-copper-port-2g-module
module 3 icx7150-2-sfp-plus-port-20g-module
stack-port 1/3/1
stack-port 1/3/2
!
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
!
vlan 80 by port
tagged ethe 1/1/1
untagged ethe 1/1/12
!
!
!
!
!
!
!
!
!
!
!
!
!
!
optical-monitor
optical-monitor non-ruckus-optic-enable
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
hostname icx7150B
ip dhcp-client disable
ip dns server-address 192.168.0.1
ip route 0.0.0.0/0 192.168.0.1
!
username root password .....
!
!
snmp-server community ..... ro
!
!
clock timezone gmt GMT+08
!
!
ntp
disable serve
server 216.239.35.0
server 216.239.35.4
!
!
!
!
manager registrar
!
!
!
!
!
!
!
!
!
interface ethernet 1/3/1
no optical-monitor
!
interface ve 1
ip address 192.168.0.30 255.255.255.0
!
!
!
!
!
no lldp run
!
!
!
!
!
!
!
end

Port 1/1/35 of the 6450 connects to Port 1/1/1 of the 7150
 

kpfleming

Active Member
Dec 28, 2021
227
105
43
Pelham NY USA
Those look correct. When you say the device on 1/1/12 of the 7150 cannot be accessed, how are you trying to access it (from which port on which switch)?
 

madmatt71

New Member
Sep 18, 2022
10
7
3
I only had trouble doing the tftp uefi firmware upgrade if using a tftp server not directly connected to the switch .... the transfer would stall and then timeout after 50 of the 60MB of the firmware were transferred
Replying to myself here for my long term memory and maybe to avoid the same 'issue' for other users ....
Just spent a couple hours troubleshooting what I thought was an issue with my LAGs over the 10GB links ... turned out I 'forgot' to enable Jumbo frames on the Brocade, so ping was working, connectivity between non jumbo-enabled hosts and everything else was working (included VMs running on top of kvm on jumbo-enabled servers) but tcp connectivity between said servers was sketchy/timing out (ICMP was working and that should have told me what the cause was from the beginning)...

Enabled jumbo frames reloaded the switch and ... everything working as it should ...

Long story short, tftp transfers were timing out because of the tftp servers being on one of the jumbo-enabled hosts (truenas) ....
 

Vesalius

Active Member
Nov 25, 2019
224
160
43
Replying to myself here for my long term memory and maybe to avoid the same 'issue' for other users ....
Just spent a couple hours troubleshooting what I thought was an issue with my LAGs over the 10GB links ... turned out I 'forgot' to enable Jumbo frames on the Brocade, so ping was working, connectivity between non jumbo-enabled hosts and everything else was working (included VMs running on top of kvm on jumbo-enabled servers) but tcp connectivity between said servers was sketchy/timing out (ICMP was working and that should have told me what the cause was from the beginning)...

Enabled jumbo frames reloaded the switch and ... everything working as it should ...

Long story short, tftp transfers were timing out because of the tftp servers being on one of the jumbo-enabled hosts (truenas) ....
 
  • Like
Reactions: madmatt71

nextrack68

New Member
Jul 26, 2022
5
0
1
  • Comair Rotron "Gryphon" GDA4028-12BB - discontinued, alas
    If you can find these? BUY THESE. 40x40x28mm, but 11CFM, 0.34in H2O, 8800RPM, but just 31.4dBA! I am still mad they discontinued them. No, I am not selling any of my spares.
I was able to find three of these on Ebay to swap into my 6540P. However, I am going to have to buy some connectors as they came with bare wires.

I've looked on Amazon but cannot seem to find exactly what I need. Are they 3 pin JST connectors? 2.0 or 2.54mm? Any help to get the right connector and crimper would be much appreciated.
 

epicurean

Active Member
Sep 29, 2014
744
64
28
Those look correct. When you say the device on 1/1/12 of the 7150 cannot be accessed, how are you trying to access it (from which port on which switch)?
When I plug in a ip cam onto 1/1/12 on the 7150 , i cannot get to the web UI , and the light on the switch port is orange (not yellow on the other switch ports). I plug the same IP cam into a port in the 6450 ( which is untagged to vlan 80) , it works as it should.
 

itronin

Well-Known Member
Nov 24, 2018
977
622
93
Denver, Colorado
When I plug in a ip cam onto 1/1/12 on the 7150 , i cannot get to the web UI , and the light on the switch port is orange (not yellow on the other switch ports). I plug the same IP cam into a port in the 6450 ( which is untagged to vlan 80) , it works as it should.
Maybe I'm missing something but don't you have to enable inline power on 1/1/12 in the 7150?

here's your config portion for the 6450 above
Code:
!
interface ethernet 1/1/12
inline power
!
you have nothing specified in the 7150 for any of your ports.

If you are using the gui on the 7150 I believe there is a tickbox to turn on power for a port. that should be reflected in the config (or running) after you do it in the gui.

edit - I'm making an assumption that your IP cam is drawing power from the switch...
edit - second assumption when you say "I cannot get to the web UI" - I am going with web ui of the cam...
 
Last edited:
  • Like
Reactions: Vesalius

epicurean

Active Member
Sep 29, 2014
744
64
28
Maybe I'm missing something but don't you have to enable inline power on 1/1/12 in the 7150?

here's your config portion for the 6450 above
Code:
!
interface ethernet 1/1/12
inline power
!
you have nothing specified in the 7150 for any of your ports.

If you are using the gui on the 7150 I believe there is a tickbox to turn on power for a port. that should be reflected in the config (or running) after you do it in the gui.

edit - I'm making an assumption that your IP cam is drawing power from the switch...
edit - second assumption when you say "I cannot get to the web UI" - I am going with web ui of the cam...
I definately enabled inline power for the ports.
Its weird now, as I cannot use ssh to get into the switch. Something funky going on I think
 

kpfleming

Active Member
Dec 28, 2021
227
105
43
Pelham NY USA
As part of your next testing, I suggest adding a VE on the 7150 for VLAN 80, and using that to test connectivity. That way you can confirm the operation of the VLAN trunking and other lower-level stuff without being subject to any issues with the IP camera or other devices you plug into the 7150.
 

NablaSquaredG

Well-Known Member
Aug 17, 2020
696
311
63
Does anyone have pictures from inside a 6430-24?

I thought about the possibility of crossflashing a 6430 to 6450, but then I realised that there is probably a hardware difference between 6430 and 6450 (from my naive point of view, it wouldn't have made sense for Brocade to sell a 6430 that cannot be upgraded to L3 even if you pay for the license. So there must be some hardware difference that made the 6430 cheaper, but takes away the ability to do L3)
 

jasonwc

Member
Dec 31, 2018
49
18
8
yeah that will all work
I just wanted to confirm that the transceiver, MPO breakout cable, and OM3 couplers all worked as expected. The Finisar 40G-SR4 optic is a particularly good deal at $8 with shipping included.

I now can utilize all 16 10G ports as well as the 40G ports.
 
Last edited:

Mushishi

New Member
Apr 26, 2016
14
6
3
43
Turku, Finland
Looking into getting an Brocade ICX-6450-48p with POE and was wondering if this is the right cable to use to connect it to the PC so I can reset everything and give it a fresh OS and license?

CableCreation USB C to RJ45 Console Cable 6 Feet USB Serial Adapter Compatible with Router, Cisco, NETGEAR, Linksys, Windows, macOS, Linux, Black https://www.amazon.com/dp/B0875WL9Y5?psc=1&ref_=cm_sw_r_apann_ct_WZSMZ6KNBSJJ9FEHX0Z0
I don't know that cable, but i know the USB-A version of this cable: https://www.amazon.com/dp/B0774JV2QQ/ref=sspa_dk_detail_0?pd_rd_i=B0774JV2QQ&pd_rd_w=Exf5F&th=1 works with my 6450.
 

epicurean

Active Member
Sep 29, 2014
744
64
28
As part of your next testing, I suggest adding a VE on the 7150 for VLAN 80, and using that to test connectivity. That way you can confirm the operation of the VLAN trunking and other lower-level stuff without being subject to any issues with the IP camera or other devices you plug into the 7150.
Sorry newbie again, but how do I add a VE on the 7150?