Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

rootwyrm

Member
Mar 25, 2017
74
93
18
www.rootwyrm.com
So, one of my 6450's is behaving ODDLY. Let me show you:

Code:
Fan speed switching temperature thresholds:
                Speed 1: NM<----->65       deg-C
                Speed 2:       56<-----> 79 deg-C (shutdown)

Sensor B Temperature Readings:
        Current temperature : 57.5 deg-C
Sensor A Temperature Readings:
        Current temperature : 46.5 deg-C
        Warning level.......: 69.0 deg-C
        Shutdown level......: 79.0 deg-C

SSH@6450-2d#dm fan-speed
All fans in High speed (0xff)
"Then your fans should be in high speed." Yes, except check the A/B differential. It's 11C lower. And I'm measuring the air at the exhaust side at 34C, so there's no way it's 58C. B isn't changing even when deliberately fed hot or cold air, but A is updating. Anyone ever seen this before?
 

andreathing

New Member
May 5, 2020
23
11
3

fortunamatada

New Member
Aug 23, 2019
5
1
1
First, thanks to fohdeesha for the work on these units!

Have an issue that I am slamming my head against the wall trying to figure out: an icx 7250 in router mode with everything working as expected except for one vlan on which NONE of the hosts can talk to one another. They can talk outside of the VLAN, they can reach the internet, hosts on other vlans can talk to the hosts inside of this vlan. All of the devices are untagged. No vlan tagging is configured on any of the hosts. All ports are forwarding. Devices in other vlans (i.e vlan 100) have no problem communicating with each other. Disabled all firewalls to make sure this was not an issue. No ACLs enabled yet.

Code:
Current configuration:
!
ver 08.0.95caT213
!
stack unit 1
  module 1 icx7250-24p-poe-port-management-module
  module 2 icx7250-sfp-plus-8port-80g-module
  stack-port 1/2/1
stack disable
!
global-stp
!
default-vlan-id 1001
!
vlan 31 by port
 tagged ethe 1/2/8
 router-interface ve 31
 spanning-tree
!
vlan 95 by port
 untagged ethe 1/1/5 to 1/1/8                                     
 router-interface ve 95
 spanning-tree 802-1w
!
vlan 100 by port
 tagged ethe 1/2/1 to 1/2/2 ethe 1/2/4 to 1/2/5 ethe 1/2/7
 untagged ethe 1/2/3
 router-interface ve 100
 spanning-tree 802-1w
!
vlan 250 by port
 untagged ethe 1/1/1 ethe 1/1/3 ethe 1/1/17 to 1/1/24
 router-interface ve 250
 spanning-tree 802-1w
 loop-detection
!
vlan 1001 name DEFAULT-VLAN by port
 router-interface ve 1001
!
system-max ip-route-default-vrf 9000
system-max ip-route-vrf 128
!
aaa authentication web-server default local
aaa authentication enable default local
aaa authentication login default local
enable telnet authentication
enable aaa console
hostname unimatrix001
ip dhcp-client disable
ip dns server-address 192.168.100.2
ip route 0.0.0.0/0 172.21.31.1
!
no telnet server
route-only
!
clock summer-time
!
!
ntp
 server 172.21.31.1
!
!
web-management https
web-management enable vlan 250
!
manager disable
!
manager port-list 987
!
interface ve 31
 ip address 172.21.31.2 255.255.255.252
!
interface ve 95
 ip address 192.168.95.1 255.255.255.0
 ip helper-address 1 192.168.100.2
!
interface ve 100
 ip address 192.168.100.1 255.255.255.0
 ip helper-address 1 192.168.100.2
!
interface ve 250
 ip address 192.168.250.1 255.255.255.0 dynamic
 ip helper-address 1 192.168.100.2
!
interface ve 1001                                                 
 ip address 192.168.148.1 255.255.255.0
 ip helper-address 1 192.168.100.2
!

end

Code:
Total PORT-VLAN entries: 5
Maximum PORT-VLAN entries: 1024

Legend: [Stk=Stack-Id, S=Slot]

PORT-VLAN 31, Name [None], Priority level0, On
 Untagged Ports: None
   Tagged Ports: (U1/M2)   8 
 Mac-Vlan Ports: None
     Monitoring: Disabled

PORT-VLAN 95, Name [None], Priority level0, On
 Untagged Ports: (U1/M1)   5   6   7   8 
   Tagged Ports: None
 Mac-Vlan Ports: None
     Monitoring: Disabled

PORT-VLAN 100, Name [None], Priority level0, On
 Untagged Ports: (U1/M2)   3 
   Tagged Ports: (U1/M2)   1   2   4   5   7 
 Mac-Vlan Ports: None
     Monitoring: Disabled

PORT-VLAN 250, Name [None], Priority level0, On                   
 Untagged Ports: (U1/M1)   1   3  17  18  19  20  21  22  23  24 
   Tagged Ports: None
 Mac-Vlan Ports: None
     Monitoring: Disabled

PORT-VLAN 1001, Name DEFAULT-VLAN, Priority level0, Off
 Untagged Ports: (U1/M1)   2   4   9  10  11  12  13  14  15  16 
 Untagged Ports: (U1/M2)   1   2   4   5   6   7   8 
   Tagged Ports: None
 Mac-Vlan Ports: None
     Monitoring: Disabled

Code:
Total number of IP routes: 6
Type Codes - B:BGP D:Connected O:OSPF R:RIP S:Static; Cost - Dist/Metric
BGP  Codes - i:iBGP e:eBGP
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2
STATIC Codes - v:Inter-VRF
        Destination        Gateway         Port          Cost          Type Uptime
1       0.0.0.0/0          172.21.31.1     ve 31         1/1           S    2h13m 
2       172.21.31.0/30     DIRECT          ve 31         0/0           D    2h13m 
3       192.168.95.0/24    DIRECT          ve 95         0/0           D    1h40m 
4       192.168.100.0/24   DIRECT          ve 100        0/0           D    2h14m 
5       192.168.148.0/24   DIRECT          ve 1001       0/0           D    2h14m 
6       192.168.250.0/24   DIRECT          ve 250        0/0           D    2h14m

Code:
--- VLAN 250 [ STP Instance owned by VLAN 250 ] ----------------------------

Bridge IEEE 802.1W Parameters:

Bridge           Bridge Bridge Bridge Force    tx   
Identifier       MaxAge Hello  FwdDly Version  Hold 
hex              sec    sec    sec             cnt  
800078a6e127d110 20     2      15     Default  3    

RootBridge       RootPath  DesignatedBri-   Root      Max Fwd Hel 
Identifier       Cost      dge Identifier   Port      Age Dly lo  
hex                        hex                        sec sec sec 
800078a6e127d110 0         800078a6e127d110 Root      20  15  2   

Port IEEE 802.1W Parameters:

          <--- Config Params --><-------------- Current state -----------------> 
Port      Pri PortPath P2P Edge Role       State       Designa-  Designated       
Num           Cost     Mac Port                        ted cost  bridge           
1/1/1     128 20000    F   F    DESIGNATED FORWARDING  0         800078a6e127d110 
1/1/3     128 0        F   F    DISABLED   DISABLED    0         0000000000000000 
1/1/17    128 20000    F   F    DESIGNATED FORWARDING  0         800078a6e127d110 
1/1/18    128 20000    F   F    DESIGNATED FORWARDING  0         800078a6e127d110 
1/1/19    128 0        F   F    DISABLED   DISABLED    0         0000000000000000 
1/1/20    128 0        F   F    DISABLED   DISABLED    0         0000000000000000 
1/1/21    128 0        F   F    DISABLED   DISABLED    0         0000000000000000 
1/1/22    128 20000    F   F    DESIGNATED FORWARDING  0         800078a6e127d110 
1/1/23    128 20000    F   F    DESIGNATED FORWARDING  0         800078a6e127d110 
1/1/24    128 20000    F   F    DESIGNATED FORWARDING  0         800078a6e127d1

VRFs have not been enabled.
I know this has to be some absolutely simple oversight. Does anyone have a clue what I messed up?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,721
3,055
113
33
fohdeesha.com
It is in layer 3 mode. That is how it is supposed to be. Hence the VEs for each vlan.

n....no lol. route-only does exactly the behavior you're complaining about, it completely disables layer2 switching, so hosts in the same l2/vlan are not going to talk to each other. did u see that command in my guide? hell nah didn't think so fam QED please do the needful and remove
 
  • Like
Reactions: Jason Antes

fortunamatada

New Member
Aug 23, 2019
5
1
1
n....no lol. route-only does exactly the behavior you're complaining about, it completely disables layer2 switching, so hosts in the same l2/vlan are not going to talk to each other. did u see that command in my guide? hell nah didn't think so fam QED please do the needful and remove
oh so sorry i misinterpreted " Enabling or disabling Layer 2 switching is not supported on virtual interfaces. "
 
  • Like
Reactions: fohdeesha

NablaSquaredG

Layer 1 Magician
Aug 17, 2020
1,291
781
113
Eh - Stupid question:

Is there any hardware difference between front-to-back and rear-to-front airflow ICX6610s?

i.e. can I just open the fan modules and PSUs and turn the fans around?

I've got a Ports-to-PSU one here and I'd like to make it a PSU-to-Ports one. Does anyone have a PSU-to-Ports one and would mind sharing some pictures of the fan tray?
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,721
3,055
113
33
fohdeesha.com
Eh - Stupid question:

Is there any hardware difference between front-to-back and rear-to-front airflow ICX6610s?

i.e. can I just open the fan modules and PSUs and turn the fans around?

I've got a Ports-to-PSU one here and I'd like to make it a PSU-to-Ports one. Does anyone have a PSU-to-Ports one and would mind sharing some pictures of the fan tray?
Same hardware
 

kapone

Well-Known Member
May 23, 2015
1,095
641
113
Eh - Stupid question:

Is there any hardware difference between front-to-back and rear-to-front airflow ICX6610s?

i.e. can I just open the fan modules and PSUs and turn the fans around?

I've got a Ports-to-PSU one here and I'd like to make it a PSU-to-Ports one. Does anyone have a PSU-to-Ports one and would mind sharing some pictures of the fan tray?
The fan trays are seriously difficult to take apart and turn the fans around and so are the PSU fans. Ask me how I know.... :)
 

nerdalertdk

Fleet Admiral
Mar 9, 2017
228
118
43
::1
Hello Everyone,
I have the ICX 7250-48p switch and I am looking for a 4 post 1U rail kit that will work. The ruckus part number is XBR-R000295. Has anyone found a reasonably priced alternatives to that kit other than a shelf? The cost of the ruckus part is more than I paid for the switch. Thank you for your help.
edgeswitch ears works great
My 7150-48zp hangs fine in just the front ones
 
  • Like
Reactions: fohdeesha

kapone

Well-Known Member
May 23, 2015
1,095
641
113
Solder Gun? :oops: I was planning to just physically turn the fans around
The fan trays use a custom connector with the wires (from the fans) connected straight to it. The length of those wires is just right. i.e. if you flip the fan, the wire is too short. You'll have to take apart the tray, including the connector and fans (which use rubber screws that are really hard to take out and even harder to put back in), cut the wires, splice in just a bit more extra wire, to flip them around.

Small hands and a solder gun... :)
 

klui

Well-Known Member
Feb 3, 2019
805
439
63
Is there any hardware difference between front-to-back and rear-to-front airflow ICX6610s?

i.e. can I just open the fan modules and PSUs and turn the fans around?

I've got a Ports-to-PSU one here and I'd like to make it a PSU-to-Ports one. Does anyone have a PSU-to-Ports one and would mind sharing some pictures of the fan tray?
After reading @kapone's reply this piqued my interest. If I read your request correctly, you want to convert an (E)xhaust fan to an (I)ntake one.

If that is the case, then you should be able to do it without the surgery @kapone mentioned. Take a look at the pictures I just snapped of my exhaust fans and you should understand why.

The tricky part would be reinstalling the plastic pins on the bottom but possible using some long tweezers. Taking them out is easy. Just be aware the locking tabs would have splayed out after being in the lock position for so long. Reinstall them from the rear towards the front and you should have enough clearance. You should also have enough slack for PSU fans because the fans are in the same orientation.

I've read on this thread Intake switches are louder than Exhaust, but unsure if that's related to the PSU or combination of PSU/fan.
IMG_3219.JPGIMG_3220.JPG
 

mantis454

New Member
Feb 18, 2017
7
1
3
40
Anyone else have higher that expected power use?

I have just acquired a ICX6450-24p and the idle power usage with nothing connected is about 60W (at 240V). With 1 x 10G and 6 x 1G (and supplying about 25W of POE) the power usage increases to about 85 - 89 W which is expected. However this still seems higher than others. The PSU does make a slight high pitch whine, maybe it has started to fail?
 

rootpeer

Member
Oct 19, 2019
73
13
8
Hi everyone, I have some questions about stacking.

I have an ICX6450 as my main switch. I recently bought an ICX6610 to put in my "server closet" as a secondary but 40Gb capable switch.

I want to use the ICX6450 as the master/uplink switch and have all its settings propagate to the ICX6610.

Is that something that can be done? Or does the 6610 have to be the "core" switch? Or am I misunderstanding something?

Can you give me an idea of what I have to do to configure the stack?
 

infoMatt

Active Member
Apr 16, 2019
222
100
43
I have just acquired a ICX6450-24p and the idle power usage with nothing connected is about 60W (at 240V).
That's strange, unless your meter is measuring the apparent power... at low load I've seen that the PSU has a slightly poor power factor; mine draws around 30-35W of real power (ie. the one that the power company bills the user for, at least for domestic usage here in Italy) at idle w/o anything connected.
I was expecting a lower consumption (the 25ish W written on the technical datasheet) but oh well.

The PSU does make a slight high pitch whine, maybe it has started to fail?
It might or not, a coil whine is not a real failure sign by itself (could very possibly be the silicone glue that has dried up and it's less dampening). On mine however the high pitch sound came from the fans, not the PSU...