Drag to reposition cover

Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

fohdeesha

Kaini Industries
Nov 20, 2016
2,735
3,093
113
33
fohdeesha.com
So turns out the ICX7150 24 and 48 port models (non-poe) are fanless, so they have no cutouts for fans or side intakes. other than that the cases are identical. my guess is the previous owner had a few ICX7150s apart, and when putting them back together accidentally swapped case covers. that or someone at the factory really screwed up.

you'll want to cut some fan holes and holes for intake - or just make the seller fix it
 
Last edited:
  • Like
Reactions: tommybackeast

am45931472

Member
Feb 26, 2019
87
17
8
Thanks for the Suggestion. I'll be fixing this myself instead of dealing with the seller. Recently had to cut some holes for venting into an itx aluminum case so I think I know how i'll do this. on my 7150-24p the intake holes are near the PS so i'll make some there.

Also the 7150-24p I have are slightly shorter front to back when compared to the 48p version, aprox. 11 inches deep vs 14. Also the 48p PS is noticeably larger. makes sense.
 
  • Like
Reactions: fohdeesha

kjo81

New Member
Nov 17, 2019
2
1
3
France
Hello there,

I've had a chance to acquire a Brocade 6450-48 and the EPS 1500 for a bargain (40€ shipping included... Yeah, a french file-sharing company is dumping some stuff). I'm really happy, it's my first entreprise grade switch, and there are two SFP included (1G, no idea what model). Maybe I'll use it as L3 later, but for now my Ubiquiti ERLite 3 is okay for that (and my ISP, Orange, needs unusual setup...).

I updated it to 08.0.30tT311 without difficulties (it was 07 something). The stock fan was a scream, so I replaced it by a Noctua A4X20 FLX, at its lowest speed (3700 rpm). The switch is litteraly silent, it's impressive. I have the "fan failed" error, but I don't mind.

Temperature is okay, sensor B 48°, sensor A is 60°.
Talking about sensors, I have a question : what corresponds sensor A and sensor B ?
Do I have to worry about the sensor A, as it displays warning and shutdown levels, but not sensor B ?

Thank you !

PS : crazy forum here, my IP is banned since I failed my registration a few days ago, no answer from contact form, I have to use a VPN... :(
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,735
3,093
113
33
fohdeesha.com
I can't remember exactly but A and B are board sensors somewhere on the main board in different areas, nothing to worry about with the warning and shutdown temps, as long as the current temperature is not approaching them. If it gets anywhere close, it'll kick your noctua into full speed (and, ironically, your fan failed message will go away because it would then be at a high enough RPM)

as for the contact form, that only goes to the site owner @Patrick who is pretty much on a plane / travelling 24/7. I would give him a little time to reply
 
  • Like
Reactions: tommybackeast

kjo81

New Member
Nov 17, 2019
2
1
3
France
Thank you @fohdeesha for the answer !
I think I'll change the Noctua cable (it's with special cables that come with the Noctua that I lowered the speed) to get a little bit higher speed, because with this temperature in winter, I'm a bit worried of what they will be in summer ahah.
 
  • Like
Reactions: fohdeesha

Revoman

New Member
May 23, 2019
7
1
3
Having some issues with my ICX6610-24F. My bad for ordering the 24F, not realizing its all SFP. Instead of buying another I went ahead and ordered some SFP->RJ45 transceivers from ebay. Seemed to be a good deal for $6.50 each. However, I have inserted them into my Brocade, they show up and show supported, however they show "down" even though I have an active cable plugged into them. Any suggestions?
BTW, I have a single SFP->RJ45 1G device from another vendor in 1/1/1 that is working great.


```
SSH@icx6610(config)#show media validation

Port Supported Vendor Type
----------------------------------------------------------------------
1/1/1 Yes OEM Type : 1G M-TX(SFP)
1/1/3 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/4 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/5 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/6 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/7 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/8 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/9 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/10 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/11 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/12 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/23 Yes Methode Elec. Type : 1G M-TX(SFP)
1/1/24 Yes Methode Elec. Type : 1G M-TX(SFP)
1/2/1 Yes BROCADE 40G QSFP Module
1/2/2 Yes CISCO-LEONI 40G QSFP Module
1/2/3 Yes CISCO-LEONI 40G QSFP Module
1/2/4 Yes CISCO-LEONI 40G QSFP Module
1/2/5 Yes CISCO-LEONI 40G QSFP Module
1/3/1 Yes QSFPTEK Type : 10GE SR 300m (SFP +)
SSH@icx6610(config)#
SSH@icx6610(config)#show media
ethernet port number
stack stack number
validation media validation
SSH@icx6610(config)#show media eth
ethernet port number
SSH@icx6610(config)#show media ethernet 1/1/1
Port 1/1/1: Type : 1G M-TX(SFP)
Vendor: OEM Version:
Part# : SFP-GE-T Serial#: CSGETJ10925
SSH@icx6610(config)#show media ethernet 1/1/24
Port 1/1/24: Type : 1G M-TX(SFP)
Vendor: Methode Elec. Version: -
Part# : SP7041-SCI Serial#: 3US2370353
```
and
```
SSH@icx6610(config)#show interfaces ethernet 1/1/1
GigabitEthernet1/1/1 is up, line protocol is up
Port up for 31 minute(s) 55 second(s)
Hardware is GigabitEthernet, address is cc4e.243e.7854 (bia cc4e.243e.7854)
Configured speed auto, actual 1Gbit, configured duplex fdx, actual fdx
Configured mdi mode AUTO, actual MDIX
Member of 5 L2 VLANs, port is dual mode in Vlan 1, port state is FORWARDING
BPDU guard is Disabled, ROOT protect is Disabled, Designated protect is Disabled
Link Error Dampening is Disabled
STP configured to ON, priority is level0, mac-learning is enabled
Openflow is Disabled, Openflow Hybrid mode is Disabled, Flow Control is config enabled, oper enabled, negotiation disabled
Mirror disabled, Monitor disabled
Mac-notification is disabled
Not member of any active trunks
Not member of any configured trunks
Port name is pfsense
Inter-Packet Gap (IPG) is 96 bit times
MTU 10200 bytes, encapsulation ethernet
300 second input rate: 285624 bits/sec, 99 packets/sec, 0.02% utilization
300 second output rate: 173840 bits/sec, 104 packets/sec, 0.01% utilization
218591 packets input, 123713725 bytes, 0 no buffer
Received 6143 broadcasts, 1511 multicasts, 210937 unicasts
2 input errors, 0 CRC, 0 frame, 0 ignored
0 runts, 0 giants
204342 packets output, 44622056 bytes, 0 underruns
Transmitted 18386 broadcasts, 19064 multicasts, 166892 unicasts
0 output errors, 0 collisions
Relay Agent Information option: Disabled

Egress queues:
Queue counters Queued packets Dropped Packets
0 199941 0
1 0 0
2 0 0
3 0 0
4 0 0
5 140 0
6 0 0
7 4261 0
SSH@icx6610(config)#show interfaces ethernet 1/1/24
GigabitEthernet1/1/24 is down, line protocol is down
Port down for 33 minute(s) 56 second(s)
Hardware is GigabitEthernet, address is cc4e.243e.7854 (bia cc4e.243e.786b)
Configured speed auto, actual unknown, configured duplex fdx, actual unknown
Configured mdi mode AUTO, actual unknown
Member of L2 VLAN ID 1, port is untagged, port state is BLOCKING
BPDU guard is Disabled, ROOT protect is Disabled, Designated protect is Disabled
Link Error Dampening is Disabled
STP configured to ON, priority is level0, mac-learning is enabled
Openflow is Disabled, Openflow Hybrid mode is Disabled, Flow Control is config enabled, oper disabled, negotiation disabled
Mirror disabled, Monitor disabled
Mac-notification is disabled
Not member of any active trunks
Not member of any configured trunks
Port name is Unifi AC-PRO
Inter-Packet Gap (IPG) is 96 bit times
MTU 10200 bytes, encapsulation ethernet
300 second input rate: 0 bits/sec, 0 packets/sec, 0.00% utilization
300 second output rate: 0 bits/sec, 0 packets/sec, 0.00% utilization
4 packets input, 1126 bytes, 0 no buffer
Received 3 broadcasts, 1 multicasts, 0 unicasts
0 input errors, 0 CRC, 0 frame, 0 ignored
0 runts, 0 giants
0 packets output, 0 bytes, 0 underruns
Transmitted 0 broadcasts, 0 multicasts, 0 unicasts
0 output errors, 0 collisions
Relay Agent Information option: Disabled

Egress queues:
Queue counters Queued packets Dropped Packets
0 0 0
1 0 0
2 0 0
3 0 0
4 0 0
5 0 0
6 0 0
7 0 0
```
 

fohdeesha

Kaini Industries
Nov 20, 2016
2,735
3,093
113
33
fohdeesha.com
no clue, I'm guessing it just really doesn't like that vendor/module if you have another one in port 1 that's working fine. could just be autonegotiation it's failing at, try setting it to a gig manually (at the port level, "speed" and press tab a few times)
 
Last edited:

fohdeesha

Kaini Industries
Nov 20, 2016
2,735
3,093
113
33
fohdeesha.com
going through some hidden commands, after 30 seconds of testing these seem to set the case fan speed on the 6450, but don't do anything on the 6610. haven't tested on the icx7xxx but I have a feeling they'll behave like the 6450

dd set_pwrfan_high
dd set_pwrfan_low
 
Last edited:

Smbaker

New Member
Oct 9, 2019
23
17
3
going through some hidden commands, after 30 seconds of testing these seem to set the case fan speed on the 6450, but don't do anything on the 6610. haven't texted on the icx7xxx but I have a feeling they'll behave like the 6450

dd set_pwrfan_high
dd set_pwrfan_low
If you ever come across a way to program the PWM values to something other than the preset "low" and "high", that would be handy to know. I'd love for my low speed to be a little faster. Not much... just a little.
 
  • Like
Reactions: juey and fohdeesha

Tom G

New Member
Nov 19, 2019
3
2
3
Thanks for this awesome thread - someone on Reddit suggested an ICX switch to me and some Googling brought me to this thread which persuaded me. Just acquired a 48 port unit on eBay UK - although supply is quite sparse compared to eBay.com!

Will be reading through the earlier posts for config tips when it arrives.
 

SuperServer

New Member
Feb 1, 2019
15
1
3
I recently purchased an extra ICX6610-48 POE switch that i do not need i have updated firmware and poe software to confirm its working order. Licenses have not been done. If anyone is interested feel free to PM me to purchase.
 

Skifree

New Member
Jan 24, 2019
5
2
3
I think the older revisions of S+RJ10 will appear this way in all ICX switches.

Revision 2 and newer S+RJ10 (you can identify by a /r2 at the end of the serial number) will show some basic info in the "show media" output.
I’ve 2 x Mikrotik S+RJ10 SFP+ modules that my ICX6450-24P doesn’t identify and the slots just shows ”EMPTY”. My modules have sn: AFxxxxxxxxx/928/r2. They work but I can’t see any information at all. The modules have ”r2” at the end of the serial number but I don’t know which r2 version. How can I see that since the switch doesn’t give any information regarding the module? Can someone confirm what the latest revision of the S+RJ10 is? I’ve read that it should be r3 but I haven’t seen any r3, and when I’ve contacted different retailers the latest revision I’ve found is r2.
 

Eru0194

New Member
Jun 13, 2019
11
2
3
I’ve 2 x Mikrotik S+RJ10 SFP+ modules that my ICX6450-24P doesn’t identify and the slots just shows ”EMPTY”.
Yeah sorry, I was wrong about that. In an ICX7250 (probably works for other 7xxx switches) I was able to see some very basic information about rev. 2 S+RJ10.

Now I'm using a rev. 2 S+RJ10 in an ICX6610 but it just shows "EMPTY" like yours.
 

maes

Active Member
Nov 11, 2018
103
69
28
If you ever come across a way to program the PWM values to something other than the preset "low" and "high", that would be handy to know. I'd love for my low speed to be a little faster. Not much... just a little.
Not sure if that's possible at all on the 6450; they're 3-pin fans, so they're controlled by directly varying the supply voltage. There's no PWM pin.
 

D_Net

New Member
Nov 5, 2019
2
3
3
New York City
Stumbled upon this amazing thread a couple of weeks ago while researching 10Gb switches. Had previously narrowed the field down to Arista 7124SX or LB6M, when I found this treasure trove. What an amazing thread! Read the first 60 pages, and am slowing making it through the remaining 60+.

Thank you to the whole community here, but especially to fohdeesha. The wealth of information, the level of detail, the meticulous instructions the quantity of energy he has spent on this-- truly amazing! A huge thank you!

As a result, I will soon be a new owner of a ICX6610-48p. I could not resist, and pulled the trigger -- it should be arriving soon. Can't wait!
 

Jason Spangler

New Member
Nov 17, 2019
3
3
3
Austin, TX
Thanks @fohdeesha and others for all the great info here! I picked myself up an ICX6450-48P and have it running.

Does anyone know how to get the ICX6450-48P to obtain IPv6 ULA and Global addresses from an upstream router or dhcpv6 server?

I have a switch port using ipv4 dhcp and it gets the ipv4 address assignments from my dhcp server, etc so I can ssh to the switch. I've also enabled ipv6 on the port and it assigns a LLA to which I can ssh (example: ssh -6 root@fe80::6e6c:f1ef:aed2:800%internal1), but I can't find configuration options to direct the switch to also obtain an ipv6 ULA or Global address (which do work for all other ipv6 devices on my network) for that port.
 
  • Like
Reactions: Wolfstar