Brocade ICX Series (cheap & powerful 10gbE/40gbE switching)

fohdeesha

Kaini Industries
Nov 20, 2016
1,945
1,777
113
29
fohdeesha.com
that's expected, "show media" doesn't pull any info about the link, it just tries to read the vendor EEPROM of the optic for info like model and serial number, and the EEPROM layout of the 10gbase-t transceiver probably confuses it
 

Eru0194

New Member
Jun 13, 2019
10
2
3
I finally put my ICX 6610-48 to "production" with four Mikrotik 10G RJ45 transceivers. When connected to Intel X550 link goes up, seems to work - the port shows as 1/3/1 - Up - Forward Full 10G When I type show media in the console of the switch, it does show the ports 1/3/1 to as EMPTY. Is it expected to do it this way, or do I have to set something?
I think the older revisions of S+RJ10 will appear this way in all ICX switches.

Revision 2 and newer S+RJ10 (you can identify by a /r2 at the end of the serial number) will show some basic info in the "show media" output.
 
  • Like
Reactions: fohdeesha

umass1966

New Member
Nov 2, 2019
6
1
3
Just joined the forums at STH. Based on the advise in this thread which i found extremely useful i took the first step in enterprise grade equipment by getting a Brocade ICX7150-C12P
 
  • Like
Reactions: fohdeesha

tommybackeast

Active Member
Jun 10, 2018
251
82
28
Help with setting up a new Brocade 7250-48p which is factory new in the box.

Using official Brocade supplied cable with the micro-usb plugged into switch; and Serial end attached to very old Win7 Thinkpad's serial port. Putty is running, smash the 'b' key every second, plug in power cord; and per fohdeesha's instructions am expecting to see "ICX7250-Boot" but it boots into the OS. (Note: per fohdeesha instructions, I have a CAT6 plugged into Switch Port 20 with other end going into Asus-Merlin router). Putty connection established via Serial connection.

I do believe this switch is new, old stock and never used before.

I tried 3 times; (smashing the b key within Putty) but each time it boots to OS and I never see the "ICX7250-Boot" prompt.

Question: should tftpd be running doing this -or- does one launch tftpd after seeing the "ICX7250-Boot" prompt?

Any thoughts to what I am doing wrong? (note: network noob) & thanks for reading
 

groove

Member
Sep 21, 2011
80
26
18
Help with setting up a new Brocade 7250-48p which is factory new in the box.

Using official Brocade supplied cable with the micro-usb plugged into switch; and Serial end attached to very old Win7 Thinkpad's serial port. Putty is running, smash the 'b' key every second, plug in power cord; and per fohdeesha's instructions am expecting to see "ICX7250-Boot" but it boots into the OS. (Note: per fohdeesha instructions, I have a CAT6 plugged into Switch Port 20 with other end going into Asus-Merlin router). Putty connection established via Serial connection.

I do believe this switch is new, old stock and never used before.

I tried 3 times; (smashing the b key within Putty) but each time it boots to OS and I never see the "ICX7250-Boot" prompt.

Question: should tftpd be running doing this -or- does one launch tftpd after seeing the "ICX7250-Boot" prompt?

Any thoughts to what I am doing wrong? (note: network noob) & thanks for reading
what seemed to work for me was to keep the b key pressed - don’t tap it. Just press it as soon as you plug it the power cord (within a split second) and keep it pressed. That worked on a ICX-6610.
 

tommybackeast

Active Member
Jun 10, 2018
251
82
28
2019.11.03 2208pm Switch with Show IP and show license.png 2019.11.03 2157pm Switch with Show Version.png
Once it fully boots can you type stuff and have it show up? (Like try running "show version")
Here is screen grab showing "show version" command

Serial number has been redacted.

I did not enter any other commands without additional smart-people comments :)

Thank you.

PS: typing "?" gives 5 lines : enable - ping - show - stop-traceroute - traceroute

PPS: I see on your instructions the next normal step is "factory set-fault" since this is supposed to be coming from ICX7250-BOOT menu and I have "ICX7250-48P-Switch78a6" I have -NOT- done this step as I await your kind guidance. I am a big believer in "ask before doing something, not after"
 
Last edited:

tommybackeast

Active Member
Jun 10, 2018
251
82
28
what seemed to work for me was to keep the b key pressed - don’t tap it. Just press it as soon as you plug it the power cord (within a split second) and keep it pressed. That worked on a ICX-6610.
white holding down the "b" key steady, did you have tftpd running ?
 

groove

Member
Sep 21, 2011
80
26
18
You have to run tftpd on a different host - yes I did have it running on another vm I had running within my network.
 

DRAGONKZ

Member
Apr 9, 2018
71
9
8
37
What model/config of a 7000 series gives the most amount of 10Gb ports and still supports PoE?

(A 7450 with 3 x 4 port 10Gb modules?)
 

fohdeesha

Kaini Industries
Nov 20, 2016
1,945
1,777
113
29
fohdeesha.com
white holding down the "b" key steady, did you have tftpd running ?

it doesn't matter if you have tftpd running - the good news is since you can send the switch commands after it boots, your switch, serial cable etc are fine, so you're probably just not getting the timing right. as others have said try holding down the b key in putty, then plugging in power to the switch. It should drop into the boot menu eventually
 
  • Like
Reactions: tommybackeast

tommybackeast

Active Member
Jun 10, 2018
251
82
28
it doesn't matter if you have tftpd running - the good news is since you can send the switch commands after it boots, your switch, serial cable etc are fine, so you're probably just not getting the timing right. as others have said try holding down the b key in putty, then plugging in power to the switch. It should drop into the boot menu eventually
Most odd : using new-in-box official Brocade microUSB-to-Serial cable connected to old Thinkpad's serial port; pressing and/or holding the 'b' key failed 5 or 6 times. Even though from what you saw in 'show version' the cable is working fine; and I could type commands.

I then switched the Serial cable from the Thinkpad to an old 1U SuperMicro's serial port; and 'b' press worked instantly.

Question : in the INITIAL CONFIG & UPDATE section of your instructions you write :


Now we need to assign that virtual interface an address. Choose an IP that is unused in your subnet, and out of your DHCP server range (ping it first to be sure it's unused):

interface ve 1
ip address 192.168.1.55/24
exit
write mem
______________________________

I am confused by your statement of out of your DHCP server range. I'm sadly still a network noob and only using 192.168.1.0/24; but looking at my router I have confirmed 192.168.1.20 is not used; so can I use that IP in the above use case or must I use something like 192.0.10.0 ?
 

tommybackeast

Active Member
Jun 10, 2018
251
82
28
You have to run tftpd on a different host - yes I did have it running on another vm I had running within my network.
very odd problem, serial cable in Thinkpad's serial port pounding/holding the 'b' key failed; switching to old SuperMicro and using its serial port 'b' key press-and-hold worked instantly.
 
  • Like
Reactions: groove

infoMatt

Active Member
Apr 16, 2019
165
65
28
I am confused by your statement of out of your DHCP server range. I'm sadly still a network noob and only using 192.168.1.0/24; but looking at my router I have confirmed 192.168.1.20 is not used; so can I use that IP in the above use case or must I use something like 192.0.10.0 ?
No, you can't use 192.0.10.0 because it's in a reserved IP range (192.0.0.0/24), and most notably, it's outside of your local network (as you said, if you're using 192.168.1.0/24, the valid addresses are in the range 192.168.1.1-192.168.1.254). The idea behind the use of a non-DHCP allocable address is to avoid duplicate IP on the network: if you choose an address in the pool, the DHCP server cannot know if something else has picked it before, and it could lease it out to a client.
Most of the times, you can see and/or edit the DHCP pool on you router config pages.
 
  • Like
Reactions: tommybackeast

tommybackeast

Active Member
Jun 10, 2018
251
82
28
No, you can't use 192.0.10.0 because it's in a reserved IP range (192.0.0.0/24), and most notably, it's outside of your local network (as you said, if you're using 192.168.1.0/24, the valid addresses are in the range 192.168.1.1-192.168.1.254). The idea behind the use of a non-DHCP allocable address is to avoid duplicate IP on the network: if you choose an address in the pool, the DHCP server cannot know if something else has picked it before, and it could lease it out to a client.
Most of the times, you can see and/or edit the DHCP pool on you router config pages.
Thank you - so if I login to my router and confirm that 192.168.1.20 is NOT used by anything on the LAN, that is an acceptable IP to use in my above use case
 

fohdeesha

Kaini Industries
Nov 20, 2016
1,945
1,777
113
29
fohdeesha.com
the note about being outside of your DHCP scope is just best practice, since it's a temporary IP you'll just be using to update the switch it's generally enough to just attempt to ping your chosen address and make sure you don't get a response. Best practice though, you should have your DHCP server "range" setting clamped down to only part of your local subnet, like 192.168.1.50 - 192.168.1.254. That way you know you can assign any IP from 192.168.1.2 - 192.168.1.49 statically and your DHCP server will never try to hand that address out to a client
 
  • Like
Reactions: tommybackeast

magi

New Member
Aug 22, 2019
9
3
3
United States
What temp are you looking at? The fan ramps are based on the "Fan controlled temperature:" you see in show chassis output

For instance on one of my stacks:

Code:
Fan controlled temperature: 71.5 deg-C

Fan speed switching temperature thresholds:
                Speed 1: NM<----->84       deg-C
                Speed 2:       79<-----> 87 deg-C (shutdown)
as you can see, it's about 13 degrees from ramping up
First thank you for the guides :)

One question, is there a way to tune these values? Aiming to further reduce noise...