Beware of EMC switches sold as Mellanox SX6XXX on eBay

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Psycho_Robotico

Active Member
Nov 23, 2014
111
39
28
What output does interface vlan ? give?
MX6012A [standalone: master] (config) # vlan ?
<vlan number 1-4094> OR <vlan range vlan_id-vlan_id>
10
MX6012A [standalone: master] (config) # interface vlan ?
<cr> Enter interface mode
alias Configure an alias on this interface
comment Add a comment for this interface
dhcp Enable DHCP for this interface
duplex Configure the duplex of this interface
ip Configure IP options on this interface
ipv6 Configure IPv6 options on this interface
mtu Configure the MTU of this interface
shutdown Disable this interface
speed Configure the speed of this interface
zeroconf Enable zeroconf for this interface
MX6012A [standalone: master] (config) # interface vlan
 

Rand__

Well-Known Member
Mar 6, 2014
6,622
1,762
113
I dont think you are using the correct syntax...

interface does not have vlan as sub command

Code:
sx60361 [standalone: master] # configure terminal
sx60361 [standalone: master] (config) # vlan 10
sx60361 [standalone: master] (config vlan 10) # exit
sx60361 [standalone: master] (config) # interface vlan 10
% Unrecognized command "10".
Type "interface vlan ?" for help.
sx60361 [standalone: master] (config) # interface
ethernet      ib0           mgmt0         port-channel
ib            lo            mgmt1         proxy-arp
 

Terry Wallace

PsyOps SysOp
Aug 13, 2018
196
118
43
Central Time Zone
when assigning ports to a vlan I would expect something more like this

[standalone: master] (config) # vlan 3
[standalone: master] (config vlan 3) exit
[standalone: master] (config) # interface ethernet 1/1
[standalone: master] (config interface ethernet 1/1) # switchport mode hybrid
[standalone: master] (config interface ethernet 1/1) # switchport access vlan 3

as Rand said
 

Rand__

Well-Known Member
Mar 6, 2014
6,622
1,762
113
This works for me...
Step 4 will not work with "interface ethernet <port> vlan" directly

upload_2019-12-20_8-10-44.png
 

Necrotyr

Active Member
Jun 25, 2017
206
52
28
Denmark
This happens if I try on my flashed SX6012

Code:
ORG21-SW-XLG01 [standalone: master] # conf t
ORG21-SW-XLG01 [standalone: master] (config) # interface vlan ?
<vlan number>
5
ORG21-SW-XLG01 [standalone: master] (config) # interface vlan 5
ORG21-SW-XLG01 [standalone: master] (config interface vlan 5) #
 
  • Like
Reactions: Psycho_Robotico

Psycho_Robotico

Active Member
Nov 23, 2014
111
39
28
This happens if I try on my flashed SX6012

Code:
ORG21-SW-XLG01 [standalone: master] # conf t
ORG21-SW-XLG01 [standalone: master] (config) # interface vlan ?
<vlan number>
5
ORG21-SW-XLG01 [standalone: master] (config) # interface vlan 5
ORG21-SW-XLG01 [standalone: master] (config interface vlan 5) #
Thanks, this is the output I get:
Code:
MX6012A [standalone: master] (config) # vlan ?
<vlan number 1-4094> OR <vlan range vlan_id-vlan_id>
5
MX6012A [standalone: master] (config) # interface vlan ?
<cr>                           Enter interface mode
alias                          Configure an alias on this interface
comment                        Add a comment for this interface
dhcp                           Enable DHCP for this interface
duplex                         Configure the duplex of this interface
ip                             Configure IP options on this interface
ipv6                           Configure IPv6 options on this interface
mtu                            Configure the MTU of this interface
shutdown                       Disable this interface
speed                          Configure the speed of this interface
zeroconf                       Enable zeroconf for this interface
MX6012A [standalone: master] (config) # interface vlan 5
% Unrecognized command "5".
Type "interface vlan ?" for help.
MX6012A [standalone: master] (config) #
System specs (version etc.):
Code:
MX6012A [standalone: master] # show version
Product name:      MLNX-OS
Product release:   3.6.1002
Build ID:          #1-dev
Build date:        2016-06-09 20:24:26
Target arch:       ppc
Target hw:         m460ex
Built by:          jenkins@fit-build-95
Version summary:   PPC_M460EX 3.6.1002 2016-06-09 20:24:26 ppc

Product model:     ppc
Product hw:        m460ex
Host ID:           MT1519X

Uptime:            12m 2.320s
CPU load averages: 1.33 / 1.51 / 1.05
Number of CPUs:    1
System memory:     792 MB used / 1235 MB free / 2027 MB total
Swap:              0 MB used / 0 MB free / 0 MB total


MX6012A [standalone: master] # show system type
SX6012


MX6012A [standalone: master] # show system profile
Profile: vpi-single-switch


MX6012A [standalone: master] # show system capabilities
IB: Supported, L2, Adaptive Routing
Ethernet: Supported, L2, L3
GW: Supported
Max SM nodes: 2048
IB Max licensed speed: FDR
Ethernet Max licensed speed: 56Gb



MX6012A [standalone: master] # show inventory
---------------------------------------------------------------------------
Module           Part Number      Serial Number        Asic Rev.    HW Rev.
---------------------------------------------------------------------------
CHASSIS          MSX6012F-2BFS    MT1519X              N/A          04
MGMT             100-886-236-04   MT1519X              2            04


MX6012A [standalone: master] # show configuration
##
## Active saved database "initial"
## Generated at 2019/12/21 11:43:24 +0000
## Hostname: MX6012A
##

##
## Running-config temporary prefix mode setting
##
no cli default prefix-modes enable

##
## Port configuration
##
   port 1/1 type ethernet force
   port 1/2 type ethernet force
   port 1/3 type ethernet force
   port 1/4 type ethernet force
   port 1/5 type ethernet force
   port 1/6 type ethernet force
   port 1/7 type ethernet force
   port 1/8 type ethernet force
   port 1/9 type ethernet force
   port 1/10 type ethernet force
   port 1/11 type ethernet force
   port 1/12 type ethernet force

##
## Interface Ethernet configuration
##
   interface ethernet 1/11 speed 1000 force

##
## Network interface configuration
##
no interface mgmt0 dhcp
   interface mgmt0 ip address 192.168.0.235 /24

##
## Network interface IPv6 configuration
##
no interface mgmt0 ipv6 address autoconfig default
no interface mgmt0 ipv6 enable

##
## Other IP configuration
##
   ip route 0.0.0.0 0.0.0.0 192.168.0.1
   ip domain-list lan
   ip name-server 192.168.0.1

##
## Local user account configuration
##
   username admin password
  
##
## AAA remote server configuration
##
# ldap bind-password ********
# radius-server key ********
# tacacs-server key ********

##
## Network management configuration
##
# web proxy auth basic password ********

##
## X.509 certificates configuration
##
#
# Certificate name system-self-signed, ID
# (public-cert config omitted since private-key config is hidden)

##
## Persistent prefix mode setting
##
cli default prefix-modes enable

MX6012A [standalone: master] #
 

Rand__

Well-Known Member
Mar 6, 2014
6,622
1,762
113
So it looks like its not creating the vlan... for me it looks like this:

Code:
SX60121 [standalone: master] (config) # vlan 99
SX60121 [standalone: master] (config vlan 99) # exit
SX60121 [standalone: master] (config) # no vlan 99
SX60121 [standalone: master] (config) #

 show version
Product name:      MLNX-OS
Product release:   3.6.1002
Build ID:          #1-dev
Build date:        2016-06-09 20:24:26
Target arch:       ppc
Target hw:         m460ex
Built by:          jenkins@fit-build-95
Version summary:   PPC_M460EX 3.6.1002 2016-06-09 20:24:26 ppc
The switch enters the newly created vlan after creation, but it does not create it in your case.
Have you tried via gui (just in case)?

And you are sure you are in VPI Mode and not ib only by chance?
 

Psycho_Robotico

Active Member
Nov 23, 2014
111
39
28
So it looks like its not creating the vlan... for me it looks like this:
It does create the vlan, as shown in a previous post:
Code:
MX6012A [standalone: master] (config) # vlan 10
MX6012A [standalone: master] (config vlan 10) # exit
MX6012A [standalone: master] (config) # interface vlan 10
% Unrecognized command "10".
Type "interface vlan ?" for help.
As Necrotyr said, the issue isn't creating the vlan but a vlan interface.
One of the first things I did was switch all ports to Ethernet, yet I also believe there is some precondition/setting that my setup currently doesn't meet.
 

Rand__

Well-Known Member
Mar 6, 2014
6,622
1,762
113
ah I didnt expand correctly, sorry

Also misunderstood that you're trying to create a VLAN interface instead of an interface with a VLAN - sorry.
Never used those, but I can confirm I get the same non functional output as you do on mine
 
  • Like
Reactions: Psycho_Robotico

Psycho_Robotico

Active Member
Nov 23, 2014
111
39
28
You're trying to help, there's no need to be sorry! Thanks for confirming I'm not the only one who is seeing this behaviour. :)
I just hoped someone in this thread might have come across the same issue and found a solution.
 

Necrotyr

Active Member
Jun 25, 2017
206
52
28
Denmark
Have you made sure that L3 mode is active?

Have you tried setting up the interface from the web Mgmt?

EDIT: NVM, you can't add vlan interfaces from the webpage on this firmware version.
 
  • Like
Reactions: Psycho_Robotico

Necrotyr

Active Member
Jun 25, 2017
206
52
28
Denmark
Here's my system info, the only real difference is that I don't run mine in VPI mode, but straight Ethernet.

Code:
ORG21-SW-XLG01 [standalone: master] # sh version
Product name:      MLNX-OS
Product release:   3.6.1002
Build ID:          #1-dev
Build date:        2016-06-09 20:24:26
Target arch:       ppc
Target hw:         m460ex
Built by:          jenkins@fit-build-95
Version summary:   PPC_M460EX 3.6.1002 2016-06-09 20:24:26 ppc

Product model:     ppc
Product hw:        m460ex
Host ID:           MT...

Uptime:            81d 2h 2m 4.672s
CPU load averages: 1.22 / 1.11 / 1.13
Number of CPUs:    1
System memory:     820 MB used / 1207 MB free / 2027 MB total
Swap:              0 MB used / 0 MB free / 0 MB total

ORG21-SW-XLG01 [standalone: master] # sh system type
SX6012

ORG21-SW-XLG01 [standalone: master] # sh system profile
Profile: eth-single-switch

ORG21-SW-XLG01 [standalone: master] # sh system capabilities
IB: Supported, L2, Adaptive Routing
Ethernet: Supported, L2, L3
GW: Supported
Max SM nodes: 2048
IB Max licensed speed: FDR
Ethernet Max licensed speed: 56Gb

ORG21-SW-XLG01 [standalone: master] # sh inventory
---------------------------------------------------------------------------
Module           Part Number      Serial Number        Asic Rev.    HW Rev.
---------------------------------------------------------------------------
CHASSIS          MSX6012F-2BFS    MT...                N/A          06
MGMT             100-886-236-04   MT...                2            06
 
  • Like
Reactions: Psycho_Robotico

Takrbark3

New Member
Dec 17, 2017
27
1
3
42
Is there Somebody who using the L3 feature for inter vlan routing?

The specs is writing about the "swicthing performance" but, nothing about the "routing performance"
(hardware assisted: line-rate ? CPU based: slow )
 

Blubster

New Member
Feb 25, 2014
29
4
3
38
Hey guys, i'm thinking about getting a SX6018 to replace an IS5022, i need more that 8 ports as this IB switch is now filled and would love to be able to also use ethernet with it to bridge to my regular network.
Currently i have mainly Connectx-2 in IB mode, they are not capable of more than 10gbe, but run fine in IB QDR.
I need to replace those with Connectx-3 of course, for the servers that can profit from it (so not the PCIe 2.0 limited westmere ones).

I found cheap options for the card on Ebay, and a very cheap for the switch, but this thread has been mainly about SX6012...

Are the instructions for the 6012 also applicable for the 6018? I would think "not" as the firmware would not match am i right?
Where could i find a source distro file compatible with SX6018?

I have not seen many people here with 6018, but i couldn't find any EMC 6012 on ebay unfortunately.

EDIT : looks like i didn't pay enough attention to page 22 here... ^^ i'll keep reading the doc provided by Necrotyr, thanks a lot to every one !
 

Necrotyr

Active Member
Jun 25, 2017
206
52
28
Denmark
The firmware image should include firmware for SX6018, I think I even have it lying around somewhere. Let me check and get back to you.

EDIT: I have the .bin for both MT1240212020 and MT1240213020, don't really know the difference though.
 
Last edited:
  • Like
Reactions: Blubster

r_sync_failed

New Member
Jan 18, 2020
3
0
1
Hello guys, I am able to load the MLNX-OS but unable to login with the default admin/admin login. Is there any way I can reset this?
Note I did removed /mnt/root2/etc/passwd and /mnt/root2/etc/shadow link. Do I need to generate them properly to make them work?
Thanks.

-----
No longer a problem. Just some soft links need to fix.
 
Last edited: