Beware of EMC switches sold as Mellanox SX6XXX on eBay

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Emek

Member
May 14, 2017
32
6
8
I have static ip set. but the link is down so there is no way to ping.
Try and switch cable with a known good one.
If that doesn't work, move over the cable to another port on the switch first and client second.
If that doesn't work it seems you have a bad card in the client.
 

Rand__

Well-Known Member
Mar 6, 2014
6,633
1,767
113
What is the speed configured/flashed to the NIC? Are you sure its 40G and not maybe 56G? You might need to adjust the connection speed... autoneg has some issues
 

metag

Member
Apr 26, 2016
64
16
8
What is the speed configured/flashed to the NIC? Are you sure its 40G and not maybe 56G? You might need to adjust the connection speed... autoneg has some issues
This is most likely it! Thank you! I brought down my FreeNas system for batch testing disks so I cannot verify now. But I check my Windows Server host, which has a ConnectX-2 card, and it says 10GBe. So I forced the connection speed of the switch port to 10Gbps. Now the connection is established.

Edit: this is it. I thought I put a Connectx-3 card in the FreeNas box but it is a Connectx-2 as well...
 
Last edited:

mb300sd

Active Member
Aug 1, 2016
204
80
28
34
Update on the search for 56Gb optics.

Mellanox MC2207411-SR4L WORKS!

These are a bit more expensive than random 4x14G optics, but the awesome part is the ConnectX-3 side doesn't care, so you only need them on the switch side.

I now have MC2207411-SR4L linked with Finisar FTL414QB2N-E5

Still chasing a way to get a BiDi/LR/UNIV transceiver to work though. Pulled a MPO upstairs but it'd be nice to have 40G over the LC jacks in every room for my laptop.
 

punkerman

New Member
Mar 10, 2019
2
0
1
Washington DC
Wow. How does one learn a trick like that?
I had the same problem, this fixed it.



That did the trick.
Is there any way to stop it from doing that?[/QUOTE]
 

punkerman

New Member
Mar 10, 2019
2
0
1
Washington DC
Okay I have a question for someone who has successfully got there switch converted using mpogr's guide.
after Step 5 create the config DB. Step 6 is flashing the firmware
1. Do you turn the switch off or reset it between those two points. or is it still sitting at the # prompt from mtdblock6 boot.
2. I've used flint to flash mellanox nic's before, but how do you do that for a switch as I don't see how to find the <yourswitchlid> info.
3. Last question step 7 point "rootfs to /dev/mtdblock 7" is this done by changing the "setenv rootdev /dev/mtdblock7".

Thanks for your help, I feel like I should be close here as most of the guide I got through without a problem.
by and by, the argument you (I) need(ed) is:

jffs2_args=setenv bootargs root=/dev/mtdblock7 rootfstype=jffs2 rw reset_button=0 loglevel=2
in uboot
 

Raice

Member
Jul 12, 2017
64
11
8
41
Guangzhou, China
Got an issue converting EMC to MLNX

On first boot i got this:

Code:
Remounting root filesystem in read-write mode:  [  OK  ]
Mounting local filesystems:  [  OK  ]
Running vpart script:  [  OK  ]
Applying file system skeletons: base_var base_config .
Running firstboot script usage: /sbin/aiset.sh -i [-l NEXT_BOOT_ID] [-p MD5_PASSWORD] [-r] [-f {true,false}] [-F] [-E]
usage: /sbin/aiset.sh -m -d BOOT_DISK [-L LAYOUT] [-l NEXT_BOOT_ID]
          [-p MD5_PASSWORD]

-i: not running at manufacture time (generally image install)
-m: running at manufacture time

-l NEXT_BOOT_ID: image location to boot from: 1 or 2
-d BOOT_DISK: (mfg only) /dev/sda or /dev/hda
-L LAYOUT: (mfg only) image layout, like STD
-w HWNAME: (mfg only) hardware name (usually optional on x86)
-p MD5_PASSWORD: MD5 encrypted password
-r: (install only) re-install the bootmgr itself (GRUB or u-boot)
-f {true,false}: enable or disable fallback reboot behavior for next boot
-I IMAGE_LOCATION_ID -s IMAGE_LOCATION_STATE : exclusive with -l
        States are: 0=invalid; 1=active; 2=fallback; 3=manual
-F FIPS: Use this flag to add fips=1 flag for command line run
-E FIPS_DISABLE: User this flag to set fips=0 for command line run

Writes a grub.conf which use the selected next boot location,
   and which contains the installed image version strings.

Generating SSH1 RSA host key: [  OK  ]
Generating SSH2 RSA host key: [  OK  ]
Generating SSH2 DSA host key: [  OK  ]
    Starting sx_low_level_if:
Loading i2c_mux_pca954x  - Success
Loading sx_glue_if  - Success
Loading watchdog  - Success
Loading cpld_handler  - Success
Loading mellaggra_mod  - Success
Loading switchx  - Success
Reloading udev:
Loading SX driver:[  OK  ]
Stopping iss-nvram-mac
Stopping sx_low_level_if
switchx module unloaded
mellaggra_mod module unloaded
cpld_handler module unloaded
watchdog module unloaded
i2c_mux_pca954x module unloaded
mlx system_profile: 3
mlx system_type: SX6012
mlx system_oid: 1.3.6.1.4.1.33049.1.1.1.6012
After that nothing happens.
Tried twice without any luck.

Any advice?
 

Raice

Member
Jul 12, 2017
64
11
8
41
Guangzhou, China
Got an issue converting EMC to MLNX

On first boot i got this:

Code:
Remounting root filesystem in read-write mode:  [  OK  ]
Mounting local filesystems:  [  OK  ]
Running vpart script:  [  OK  ]
Applying file system skeletons: base_var base_config .
Running firstboot script usage: /sbin/aiset.sh -i [-l NEXT_BOOT_ID] [-p MD5_PASSWORD] [-r] [-f {true,false}] [-F] [-E]
usage: /sbin/aiset.sh -m -d BOOT_DISK [-L LAYOUT] [-l NEXT_BOOT_ID]
          [-p MD5_PASSWORD]

-i: not running at manufacture time (generally image install)
-m: running at manufacture time

-l NEXT_BOOT_ID: image location to boot from: 1 or 2
-d BOOT_DISK: (mfg only) /dev/sda or /dev/hda
-L LAYOUT: (mfg only) image layout, like STD
-w HWNAME: (mfg only) hardware name (usually optional on x86)
-p MD5_PASSWORD: MD5 encrypted password
-r: (install only) re-install the bootmgr itself (GRUB or u-boot)
-f {true,false}: enable or disable fallback reboot behavior for next boot
-I IMAGE_LOCATION_ID -s IMAGE_LOCATION_STATE : exclusive with -l
        States are: 0=invalid; 1=active; 2=fallback; 3=manual
-F FIPS: Use this flag to add fips=1 flag for command line run
-E FIPS_DISABLE: User this flag to set fips=0 for command line run

Writes a grub.conf which use the selected next boot location,
   and which contains the installed image version strings.

Generating SSH1 RSA host key: [  OK  ]
Generating SSH2 RSA host key: [  OK  ]
Generating SSH2 DSA host key: [  OK  ]
    Starting sx_low_level_if:
Loading i2c_mux_pca954x  - Success
Loading sx_glue_if  - Success
Loading watchdog  - Success
Loading cpld_handler  - Success
Loading mellaggra_mod  - Success
Loading switchx  - Success
Reloading udev:
Loading SX driver:[  OK  ]
Stopping iss-nvram-mac
Stopping sx_low_level_if
switchx module unloaded
mellaggra_mod module unloaded
cpld_handler module unloaded
watchdog module unloaded
i2c_mux_pca954x module unloaded
mlx system_profile: 3
mlx system_type: SX6012
mlx system_oid: 1.3.6.1.4.1.33049.1.1.1.6012
After that nothing happens.
Tried twice without any luck.

Any advice?
Be patient, just wait )))
 

RageBone

Active Member
Jul 11, 2017
617
159
43
@JSLEnterprises thank you very much.

Did anyone find a working FW for the sx6018?
All the HP MlnxOSes i could get, only contain the two 36Port FWs as far as i could grasp.