Beware of EMC switches sold as Mellanox SX6XXX on eBay

Labs

Member
Mar 21, 2019
46
6
8
You DO need to get the matching firmware for your switch model.
The 6012.bin is for the sx6012 12 port version only.
You have to hex cut the 6018 or 6036 models yourself as documented.
Yes, of course you need the matching one but the thread was mainly for EMC SX6012 model.
Are there any other EMC versions besides SX6012 with EMC-OS ?
 

Rand__

Well-Known Member
Mar 6, 2014
4,551
901
113
o/c not all 6012/618 are EMC boxes, but many are (the others Mellanox). I have not seen an EMC 6036 yet and no non EMC/MLX 6012/18's.
 

Dörti-Häri

New Member
May 14, 2019
2
0
1
Hello,

i got two of the SX6012 with EMC firmware. I am not a pro but i will try the conversion to mlnx-os. Could somebody provide me the conversion guide and the neccessary files ?

Thank you
 

Necrotyr

Active Member
Jun 25, 2017
179
46
28
Denmark
Any of you tried using ip filtering on the switch?

I can't for the life of me seem to get it to do what I want, I've created a block rule to block access to a subnet from a vlan, but the rule is being ignored completely...
 

SMSPilot

New Member
Jun 4, 2019
1
0
1
I've just discovered this thread, very interesting. I snagged two of the EMC SX6018s,
and want some pointers for migrating the firmware to Mellanox SX6018 firmware.
Any links to Mellanox firmware images and/or a guide for the upgrade? Many Thanks.
 

neo

Well-Known Member
Mar 18, 2015
672
361
63
Would love some info on this, otherwise It seems I have a paperweight. I PMed @mpogr but he hasn't replied unfortunately.
 

chancedoorway

New Member
Jun 1, 2019
3
0
1
I would also like to see the instructions for an EMC MSX6012 switch. Thanks in advance to anyone who can help.

Edit: Got it, thanks!
 
Last edited:

ctzn siriusman

New Member
May 23, 2019
1
0
1
Hi, I bought an EMC SX6012 on eBay and I was having trouble running it when I came across this thread.
Can someone end my headache by sending me the conversion guide?
Thank you in advance !
 

Bill D

New Member
Jun 8, 2019
2
5
3
Happy to report a successful conversion, much thanks to @mpogr @JSLEnterprises @Rand__ and @Necrotyr .

I have an update to the guide. For step 6 you can do it from the switch instead of in-band. Also after doing an initial flash to convert the PSID to the mellanox one, you should be able to then use the mfa and skip the extraction step. The alternate way to perform the flint firmware commands for step 6 is as follows.
  1. Create chroot link
    Code:
    cd /bin
    ln -s busybox chroot
  2. Place extracted firmware in root2
    Code:
    tftp -b 8192 -gr <FIRMWARE_BIN_FILE> <TFTP_SERVER_IP>
    mv <FIRMWARE_BIN_FILE> /mnt/root2/
  3. Chroot into mellanox image
    Code:
    cd /mnt/root2/
    mount -t proc /proc/ proc/
    mount --rbind /sys sys/
    mount --rbind /dev dev/
    chroot /mnt/root2/ /bin/bash
  4. Start mst
    Code:
    mst start
  5. Get the device
    Code:
    mst status
  6. Verify image
    Code:
    flint -i /<FIRMWARE_BIN_FILE> q
  7. Flash image
    Code:
    flint --allow_psid_change --override_cache_replacement -d <SW_DEV> -i /<FIRMWARE_BIN_FILE> b
# cd /bin/
# ln -s busybox chroot
# cd /mnt/tmp/
# tftp -b 8192 -gr MSX6012.bin 10.47.0.47
MSX6012.bin 100% |*******************************| 1545k 0:00:00 ETA
# mv /tmp/MSX6012.bin /mnt/root2/
# cd /mnt/root2/
# mount -t proc /proc/ proc/
# mount --rbind /sys sys/
# mount --rbind /dev dev/
# chroot /mnt/root2/ /bin/bash
bash-4.1# mst status
MST modules:
------------
MST PCI module is not loaded
MST PCI configuration module is not loaded

MST devices:
------------

No MST devices were found or MST modules are not loaded.
You may need to run 'mst start' to load MST modules.
bash-4.1# mst start
Starting MST (Mellanox Software Tools) driver set
Loading MST PCI module - Success
Loading MST PCI configuration module - Success
Create devices
bash-4.1# mst status
MST modules:
------------
MST PCI module loaded
MST PCI configuration module loaded

MST devices:
------------
/dev/mst/dev-i2c-0 - Embedded I2C master
/dev/mst/dev-i2c-1 - Embedded I2C master
/dev/mst/mt51000_pciconf0 - PCI configuration cycles access.
domain:bus:dev.fn=0001:81:00.0 addr.reg=88 data.reg=92
Chip revision is: 02
bash-4.1# flint -i /MSX6012.bin q
Image type: FS2
FW Version: 9.3.8170
FW Release Date: 6.6.2016
Device ID: 51000
Description: Node Sys image
GUIDs: 0000000000000000 0000000000000000
Description: Base Switch
MACs: 000000000000 000000000000
VSD: n/a
PSID: MT_1270110020
bash-4.1# flint --allow_psid_change --override_cache_replacement -d /dev/mst/mt51000_pciconf0 -i /MSX6012.bin b

-W- Firmware flash cache access is enabled. Running in this mode may cause the firmware to hang.

Current FW version on flash: 9.9.1260
New FW version: 9.3.8170

Note: The new FW version is older than the current FW version on flash.

Do you want to continue ? (y/n) [n] : y


You are about to replace current PSID on flash - "EMC1270110020" with a different PSID - "MT_1270110020".
Note: It is highly recommended not to change the PSID.

Do you want to continue ? (y/n) [n] : y
Burning FS2 FW image without signatures - OK
Restoring signature - OK

Used 3.6.1002 for my conversion, going to try with 3.6.8008 tonight. Main concern is chad and hwd. I'd love to use the stock ones, don't know what was done to the modified ones.
 
Last edited:

Freebsd1976

Active Member
Feb 23, 2018
205
31
28
Used 3.6.1002 for my conversion, going to try with 3.6.8008 tonight. Main concern is chad and hwd. I'd love to use the stock ones, don't know what was done to the modified ones.
According conversation with OP , upgrade to 3.6.8008 is impossible without modify those binary files
 

Labs

Member
Mar 21, 2019
46
6
8
According conversation with OP , upgrade to 3.6.8008 is impossible without modify those binary files
I tried to upgrade the switch from 1002 to 8008 via standard cli procedure and the write image script fails to find the correct partitions. At the step where fstab needs to be modified you can see there the standard ones and a modded switch doesn't have the same layout of the nand flash now.

I was also thinking to follow the guide but use the 8008 image but the 3 files will not be modded and I am not sure about impact. Good to know that it will not work without modification so I will not lose time trying.
 

mb300sd

Active Member
Aug 1, 2016
197
74
28
30
Anyone have a line on working optics for 56GbE? I'm using connectx-3 cards that work fine at 40Gb, but can't get them to link up at 56Gb. Pretty sure it's my transceivers.
 

Labs

Member
Mar 21, 2019
46
6
8
Anyone have a line on working optics for 56GbE? I'm using connectx-3 cards that work fine at 40Gb, but can't get them to link up at 56Gb. Pretty sure it's my transceivers.
Try to force 56Gbe speed on the card and the switch and see if it is working.
With some DACs and optical transceivers auto-negotiation doesn't work at 56Gbe.
 

mb300sd

Active Member
Aug 1, 2016
197
74
28
30
How do I force it on the card? I can't find any references for how to do it on Server 2016.
 

Labs

Member
Mar 21, 2019
46
6
8
How do I force it on the card? I can't find any references for how to do it on Server 2016.
Looks like on the card there is no possibility to force the speed but in Advanced tab you can try to disable the Flow Control. Also on the switch it should be disabled.