bad mail input format: from root (uid 0)

nle

Member
Oct 24, 2012
200
11
18
I'm running omnios-r151030-f1189fc02c, and recently I started to see "bad mail input format: from root (uid 0)" in my logs every 5 minutes.

Any pointers on how to solve this? I can't seem to find much on google.

I'm using TLS emails (Google) if that has anything to do with it.
 

gea

Well-Known Member
Dec 31, 2010
2,500
842
113
DE
Do you use napp-it alert/status jobs with autojob set to 5min?
Then this can happen if alert or status jobs are set to TLS mail without TLS working.

If so, switch to standard email (port25) in menu Jobs > TLS email > enable regular email
 
  • Like
Reactions: nle

nle

Member
Oct 24, 2012
200
11
18
The weird thing is that I get the notification emails as usual via gmail. So it works.
I also set the port to be 25 a while back, because of another issue.
 

nle

Member
Oct 24, 2012
200
11
18
I'm trying to troubleshoot it further, by removing the jobs. They did not want to delete via GUI, so I removed them manually (that worked). The issue I face now, is that when I'm trying to add new alerts, I get:

Code:
Can't load '/var/web-gui/data/napp-it/CGI/auto/IO/Tty/Tty.so' for module IO::Tty:
ld.so.1: perl: fatal: /var/web-gui/data/napp-it/CGI/auto/IO/Tty/Tty.so: wrong ELF class: ELFCLASS32 at /usr/perl5/5.28/lib/i86pc-solaris-thread-multi-64/DynaLoader.pm line 193. at /var/web-gui/data/napp-it/CGI/IO/Tty.pm line 30.
Compilation failed in require at /var/web-gui/data/napp-it/CGI/IO/Pty.pm line 7.
BEGIN failed--compilation aborted at /var/web-gui/data/napp-it/CGI/IO/Pty.pm line 7.
Compilation failed in require at /var/web-gui/data/napp-it/CGI/Expect.pm line 22.
BEGIN failed--compilation aborted at /var/web-gui/data/napp-it/CGI/Expect.pm line 22.
Compilation failed in require at /var/web-gui/data/napp-it/zfsos/_lib/illumos/zfslib.pl line 2889.
BEGIN failed--compilation aborted at /var/web-gui/data/napp-it/zfsos/_lib/illumos/zfslib.pl line 2889. Compilation failed in require at admin.pl line 419.
EDIT:
Never mind. Fixed it by upgrading Napp-IT.

The information was on @gea's Napp-IT website:
OmniOS 151028 comes with a newer Perl and a different SSH/sudo handling.
Without an update to a recent napp-it Free/Pro/Dev release in About > Update,
you get errors about io.tty or permission errors
 
Last edited: