Audio Problem - nVidia 8400GS Passthrough - Windows 7 - ESXi 6.7.0 U1

petreza

New Member
Dec 28, 2017
16
1
3
Finally was able to achieve a stable passthrough with an old nVidia 8400GS
Windows 7
Supermicro X11DPG-QT

However, there are no audio playback devices showing.
I have:
Device Manager->Sound, video....->NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
Device Manager->System devices->High Definition Audio Controller

High Definition Audio Controller->right click->Properties->General Tab->Location: ..... (function 1)
matches the Location of the "NVIDIA GeForce 8400GS" display adapter ....(function 0)

so "High Definition Audio Controller" is the passthrough audio controller
on the Driver Tab it says that the driver provider is Microsoft
I tried forcing the nVidia HDAudio drivers "nvhda.inf" but Windows says they do not match

as I said, under "Playback devices" it says "No audio devices are installed"

Any ideas?
Thanks!
 

besterino

New Member
Apr 22, 2017
27
7
3
43
I struggled as well with certain NVIDIA cards. In one system I gave up and passthrough‘ed an USB-soundcard instead (Quadro P400), in another (2080Ti) I manually set the pcie-reset mode in passthru.map to d3d0 specifically for the audio device.

The last requires quite some trial and error, do not recommend. ;)
 

petreza

New Member
Dec 28, 2017
16
1
3
I struggled as well with certain NVIDIA cards. In one system I gave up and passthrough‘ed an USB-soundcard instead (Quadro P400), in another (2080Ti) I manually set the pcie-reset mode in passthru.map to d3d0 specifically for the audio device.

The last requires quite some trial and error, do not recommend. ;)

Aghhh...... figured it out!
From what you said, I started researching and in a vmware document they were talking about pci passthrough and pci ids and then it clicked:
I am blindly putting settings such as
pci.Passthru0.msiEnabled="FALSE"
as recommended online for nVidia passthrough

but my video card is not id=0 , that is my USB passthrough
my video card is id=1 so I changed that line to
pci.Passthru1.msiEnabled="FALSE"
which did NOT fix the problem, but then I added a second line
pci.Passthru2.msiEnabled="FALSE"
for the audio passthrough and as the VM booted up 4 audio devices were recognized including my Samsung TV.

I hope this helps someone out there
 
  • Like
Reactions: Gunnyp

Gunnyp

New Member
Oct 23, 2019
6
0
1
Aghhh...... figured it out!
From what you said, I started researching and in a vmware document they were talking about pci passthrough and pci ids and then it clicked:
I am blindly putting settings such as
pci.Passthru0.msiEnabled="FALSE"
as recommended online for nVidia passthrough

but my video card is not id=0 , that is my USB passthrough
my video card is id=1 so I changed that line to
pci.Passthru1.msiEnabled="FALSE"
which did NOT fix the problem, but then I added a second line
pci.Passthru2.msiEnabled="FALSE"
for the audio passthrough and as the VM booted up 4 audio devices were recognized including my Samsung TV.

I hope this helps someone out there
Oi! Was having same issue with a 2080Ti and the X11DPG-QT. Thanks for posting the solution!