Arista - disable STP on interface/port

Discussion in 'Networking' started by Stril, Jan 10, 2019.

  1. Stril

    Stril Member

    Joined:
    Sep 26, 2017
    Messages:
    149
    Likes Received:
    6
    Hi!

    I am just trying to disable STP on some (edge-)ports of my Arista 7050s, but I do not find a solution to disable STP on a port.

    I only found the possibility to define as "portfast", but there is not much documentation on what the commands REALLY do:

    spanning tree portfast
    --> STP is on, but with VERY short block time?
    spanning-tree portfast edge
    --> STP is off?
    spanning-tree portfast normal
    --> STP is off, but will be on, if BPDU is received?
    spanning-tree portfast network
    --> NO idea...

    Can you help me?

    Thank you for your help!!
    Stril
     
    #1
  2. Seema

    Seema New Member

    Joined:
    Mar 1, 2019
    Messages:
    2
    Likes Received:
    0
    Hi
    we have disabled spanning tree on a port in such a way:

    interface Ethernet34
    description peering
    switchport trunk native vlan 13
    switchport trunk allowed vlan 13,791
    switchport mode trunk
    spanning-tree bpduguard disable
    spanning-tree bpdufilter enable
    !
     
    #2
Similar Threads: Arista disable
Forum Title Date
Networking Arista 7050QX - Cut-through - Store and Forward - iSCSI Feb 8, 2019
Networking Arista 7050QX - hard reboot and packet-storm Sep 20, 2018
Networking Arista DCS-7050QX-32S, 4-SFP+ ports - can't configure Sep 15, 2018
Networking Arista EOS for MLAG Upgrade Sep 11, 2018
Networking Arista 7050 - Which Firmware are you using Sep 3, 2018

Share This Page