2.5 Gbe Nic only getting 1.5 Gb/sec in Hyper-V Linux?

Kevin Peters

New Member
Jan 21, 2021
14
1
3
Hi, I have two computers, both with Realtek 2.5Gbe Nics. One is built into the motherboard of my Windows Pro server and the other is via USB3 on my iMac. They are connected via a Zyxel 2.5 Gbe switch.

Using iperf3 on my iMac and Windows 10 Pro I consistently get about 2.3 Gb/sec, as I would expect. However, I am running a Debian VM using Hyper-V on the server that consistently only gets around 1.5 Gb/sec. The Debian VM has plenty of RAM (8GB) and CPU (4 cores of an intel 10100). I can run iperf3 using Hyper-V's 10Gbe virtual switch between two VMs on the server and get a full 10Gbe speed.

Why am I only getting 1.5 Gb/sec?

I have tried a direct cable to eliminate the Zyxel switch (no change).
I have tried removing and re-adding the switch to my Hyper-V (no change).
The cable is a brand new Cat 6a and I have tried various other cables as well.
Debian reports that the NIC is connected at 2.5Gbe as expected.

What else can I try?

Thanks
Kevin
 

saravalkyrie

New Member
Mar 7, 2021
4
2
3
Which generation VM have you setup? if your using Gen 1 vm's I've seen similar behaviour before, but not usually on Gen 2. If they aren't server NIC's make sure SR-IOV isn't enabled in the vNic settings. Imo, if you can shell out on a cheap refurb server Nic you might getter better results, I've seen some weird behaviour with Realtek nic's in Hyper-V and VMware