Why is my E5-2690v4 running below base frequency in Windows

Eson

New Member
Oct 14, 2012
26
0
1
Running 2x E5-2690v4 CPUs in Cisco UCS c240 M4 server with Server 2019 and Hyper-V. Windows is set to High Performance power plan. I have optmized BIOS settings after Ciscos own guide for virtualization, disabling all C-states, choosing enteprise on all power and energy options.

A few years ago I mostly remember just setting the Windows plan to HP was enough to avoid the CPU going below base freq. Is there something different with Server 2019?

1626696910036.png
 

Eson

New Member
Oct 14, 2012
26
0
1
if you add some load on CPU, it should rump up. do it?
Yes, putting 100% load takes it to 3.2ghz. But it bothers me a bit that it goes below base as soon as Im not pushing the CPU, its not idling, its having a few VMs on it. I dont recognize this behavior from 2016. Does task manager show the frequency for core 0 ?
 

i386

Well-Known Member
Mar 18, 2016
2,657
773
113
32
Germany
You have to disable all powersaving features (it's not the default bios/uefi setting!) if you don't want the system to try saving power and "underclocking" the cpu.
But your screenshot suggests that the system runs at <10%, I wouldn't change these settings...
 

Eson

New Member
Oct 14, 2012
26
0
1
I have already made the BIOS-changes in the Virtualization column, one would think that should be enougn:

1626700827211.png
 

Whaaat

Active Member
Jan 31, 2020
170
44
28
In windows power plan for CPU power set minimum level equal to 100%. This will prevent cpu from demotion of cores. You can also make all those changes and monitor the behavior of CPU real-time using QuickCPU tool
 

Eson

New Member
Oct 14, 2012
26
0
1
In windows power plan for CPU power set minimum level equal to 100%. This will prevent cpu from demotion of cores. You can also make all those changes and monitor the behavior of CPU real-time using QuickCPU tool
Its already at 100% on the minimum, still goes below 2.6
 

Whaaat

Active Member
Jan 31, 2020
170
44
28
It's speedstep, can be disabled in bios then. In the table above I don't agree that freq-floor override has to be enabled. in this case windows power plan changes doesn't have effect. And what is platform default for 'CPU hardware power management'?
 
Last edited: