Size mismatch VM windows with Proxmox ZFS?

Albert Yang

Member
Oct 26, 2017
70
1
8
28
Hi
I was wondering if someone else has had this issue before,
Currently have Proxmox with raid 10 in ZFS and a VM windows server with virutal disk scsi 128 gigs with discard
in the VM shows 4gigs used but on proxmox zfs says its using 87 gigs
I checked the volblocksize on proxmox which is 8k
also tried running on powershell

Code:
Optimize-Volume -DriveLetter D -ReTrim -Verbose
But still the same issue any ideas?
 

andrewbedia

Active Member
Jan 11, 2013
690
223
43
Disclaimer: I am not a proxmox user, but am well familiar with KVM and have used ZFS for many years.

I am curious if you figure out a way to do this. What I've seen is that Windows will not unmap blocks in a way that ZFS sees as "freed" when stored as image files (e.g. qcow2) in a zfs filesystem or in a zfs volume (zvol). From my understanding, ZFS has no filesystem-awareness of what is happening in the volume or disk image. All it is there to do is act as a bucket and store 1s and 0s that a filesystem puts into the volume.

I've theorized that using software to manually zero out the free space in the guest and having ZFS compression turned on should effectively free space in ZFS, but I have never tried. My solution has just been to properly size disk images and reshape them if I need them to be larger later.