Proxmox on a server with SFP - not working - compatibility issue?

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Matthei

New Member
May 17, 2022
2
0
1
Hey guys, I'm installing Proxmox on a system (motherboard is Supermicro X11SPM-TF) which has the Intel X557 chip and two SFP+ ports. But there's no connection.
The switch says "link: on", but doing "ip a" shows "link DOWN" for both interfaces, even tried connecting the SFP module to the other cage.

The SFP "module" is a Ubiquity direct attach cable, 1 meter, "UDC-1 10G SPF+DAC 1m"
Could it be incompatibility between the Intel X557 and the direct attach cable?
Or what else could I try?
 

iZohanX

New Member
May 21, 2021
16
10
3
It could be a problem with link-speed negotiation.
Make sure the link is set to the same speed at both ends.

I've had a problem with an SFP+ module that could only do 10g and couldn't "fallback" to 1gig - took me the good part of a day to have that sorted and figured out (never before had I encountered this).
I would check if you can set the link speed manually on the switch and Proxmox (perhaps even on the bios of the Supermicro board?)
if both links are set to the same speed, I would check if that particular DAC cable works only with specific equipment - some vendors require that the module have a firmware burned onto it in order to function properly (this is mostly the case with some switches, only accept vendor specific modules).
 

i386

Well-Known Member
Mar 18, 2016
4,239
1,546
113
34
Germany
Intel 10gbe nics + ubiquity reminds me instantly of the beta 10gbe switches that they sold and the compatibility problems (There are multiple threads on sth about it).

Have you tried to connect one end in sfp+ port 1 and the other end in sfp+ port 2 on the mainboard to eliminate the switch as cause?
X11SPM-TF
are you sure? supermicro website lists it as 10gbase-t (copper rj45 connector)
X11SPM-TPF has sfp+ ports
 

RTM

Well-Known Member
Jan 26, 2014
956
359
63
What does the Proxmox system say when you connect the DAC cable?
You could do something like this to check:
Bash:
sudo dmesg | grep ixgbe
If it actually detects that something is connected, it may be as simple as you need to configure the /etc/network/interfaces file to "up" the interface.

I can't remember the precise syntax, but perhaps something like this (I seem to recall that replacing the "static" keyword with "manual" may be preferrable, but I've forgetten why, of course replace interface name as appropriate):
Code:
allow-hotplug enp1s0
iface enp1s0 inet static
Afterwards you should be able to "up" the interface like so:
Code:
sudo ifup enp1s0
Of course you should probably check the Proxmox documentation:
 
Last edited:

Matthei

New Member
May 17, 2022
2
0
1
Thanks for replying everyone!

From further experimenting with all this info, I've came to the conclusion that (since this is my first time dealing with SFP), the link doesn't auto-negotiate down. The switch i currently have is only regular SFP with 1G, so i'll need to plug this into the switch with 10g cages.