OmniOS Upgrade to r151022 unsuccessful - not booting

amp

New Member
Aug 24, 2016
15
0
1
45
Hi to all,

we have a small server for the office running OmniOS and napp-it. It is based on a Supermicro barebone SC743TQ-865B-SQ 4U with mainboard X11SSH-CTF and a Xeon 1225.
All running well.

Have been running r151018 since a year and the plan was to upgrade to the community LTS edition r151022ce.

The upgrade path would be r151020 > r151022 OmniTi Version > r151022ce.
Upgrade to r151020 went well, currently running this one. Also the switch to OpenSSH was done.

Then wanted to upgrade to a new BE r151022 omniti:

# pkg unset-publisher omnios
# pkg set-publisher -P --set-property signature-policy=require-signatures -g package repository omnios
# pkg update -v --be-name r151022
# reboot

But the machine is not booting successfully. I get into Grub but afterwards it gets stuck at a certain point. When i edit boot the grub entry for BE r151022 with verbose option, i can see where it is stuck:
http://shots.rendertaxi.de/screenshots/2017-12-08_17-21-04.png

Do you have any ideas why it is stuck there or what i can do to resolve it? I have also tried Gea's mirror for the installation files, no success.

The pci1a03 device seems to be the onboard Aspeed AST2400 BMC for IPMI and Graphics, when i google for this device number.

Thank you for your help.

Alex
 
Last edited:

gea

Well-Known Member
Dec 31, 2010
2,831
990
113
DE
OmniOS 151022 use a new loader. Only known problem is related to 4kn disks that is resolved in 151024ce

I would bootup the 151022 BE and try to update to 151024ce directly
see http://www.napp-it.org/doc/downloads/setup_napp-it_os.pdf

# step 1: update certificate
wget -P /etc/ssl/pkg https://downloads.omniosce.org/ssl/omniosce-ca.cert.pem
pkg update web/ca-bundle

# step 2: update (if you get an error about pkg, update pkg via „pkg update pkg“ and retry)
pkg unset-publisher omnios
pkg set-publisher -g OmniOS r151024 core omnios

pkg update
reboot
 

amp

New Member
Aug 24, 2016
15
0
1
45
Good morning gea, thanks for your reply.

You mean to try to upgrade from r151020 (OmniTi) to r151024ce directly? Because r151022 i can not boot into.

On this machine i have no 4kn disks.

I actually tried to upgrade to r151022ce directly (from r151020) but i am hitting errors about certificate errors in some packages. I have imported the omniosce-ca.cert.pem before.

Best, Alex
 

gea

Well-Known Member
Dec 31, 2010
2,831
990
113
DE
Both ways should work.
What you may try is to update 151020 Omniti to newest 151020 OmniTi prior the update

pkg update
reboot

then add ce certificate, change repository and update to a a newer ce release
 

amp

New Member
Aug 24, 2016
15
0
1
45
Hi gea,

another go on upgrading to r151022ce. Upgrade itself is running all fine, but it is not booting into the new BE.

It is stuck here:


I edited the boot entry to get more verbose output:


Here is the result where the machine is stuck:


Do you have any further ideas?

I will try another day again with r151024ce, but as this is a server in a small office not often tiime for reboots.. :)

Thank you, Alex
 

gea

Well-Known Member
Dec 31, 2010
2,831
990
113
DE
If you do not have native 4kn disks I would probably next try a vanilla setup of 151024.
If this is a pure filer, its up an running with a pool import in 10 minutes.