napp-it gui failing to start after updating OmniOS to r151038 LTS

VenChron

New Member
Dec 2, 2014
10
3
3
Hey @gea , earlier today I update napp-it to the newest pro version. Everything was working fine after that update.

Then about an hour ago I decided to update OmniOS from the last LTS (r151030 I think?) and now the napp-it gui isn't coming up. I backed up my BE before each of these updates so I can roll back but I figured you might have a quick answer.
 

VenChron

New Member
Dec 2, 2014
10
3
3
Thanks gea, I upgraded to 151038 so I'm not sure if the OpenSSL update would still be the issue.

When I try to run the napp-it startup script from the command line, I get the following error messages:

Code:
root@Stronghold:~# /etc/init.d/napp-it start
/etc/init.d/napp-it: line 3:   856 Killed                  /var/web-gui/data/tools/httpd/napp-it-mhttpsd -c \*\*.pl -u napp-it -d /var/web-gui/data/wwwroot -p $Port -S -E /var/web-gui/data/tools/httpd/mini_httpd.pem > /dev/null 2>&1
/etc/init.d/napp-it: line 3:   857 Killed                  /var/web-gui/data/tools/httpd/napp-it-mhttpd -c \*\*.pl -u napp-it -d /var/web-gui/data/wwwroot -p 81 > /dev/null 2>&1
I tried creating the symlinks and it got rid of one of the two errors (the napp-it-mhttpsd error remained).

I then reran the wget installer but am still having the same issue.

Is it worth upgrading to 151040 to see if that helps?
 

gea

Well-Known Member
Dec 31, 2010
2,817
975
113
DE
When you want to use https, mini_httpd is now a problem on a current OmniOS as there are some updates and deprecated features around OpenSSL, omnios-build/ReleaseNotes.md at r151040 · omniosorg/omnios-build

As there are only minimal updates for mini_httpd I will move the napp-it webserver to Apache as this is maintained by OmniOS (extra repository).

If you need https, you can switch to Apache with the following setup, napp-it // webbased ZFS NAS/SAN appliance for OmniOS, OpenIndiana and Solaris : Extensions and set http on port 81 and https on port 82 (disable autostart of mini_httpd in /etc/init.d/napp-it).

After some tests I will include this in the default setup.
 

Hadrien

New Member
Jun 18, 2014
17
5
3
42
I am running across this issue as well with OmniOs r151040q.

I ran the link commands from the post above which was able to get me back into the http interface, but https is still not possible. Re-running the napp-it installer still nets this log error about the SSL site:

/etc/init.d/napp-it: line 3: 5846 Killed /var/web-gui/data/tools/httpd/napp-it-mhttpsd -c \*\*.pl -u napp-it -d /var/web-gui/data/wwwroot -p $Port -S -E /var/web-gui/data/tools/httpd/mini_httpd.pem > /dev/null 2>&1

I will try moving this to apache and report back. Hopefully my test go well so I can get back under napp-it and omnios support for this project.
 

Hadrien

New Member
Jun 18, 2014
17
5
3
42
Gea,

I am running through the instructions for Apache 2.4, I get stopped at
copy service manifest template /var/web-gui/data/tools/httpd/apache/apache-24.xml to
/lib/svc/manifest/ooce/apache-24.xml
I do not seem to have the apache folder in /var/web-gui/data/tools

root@zfs01:/var/web-gui/data/tools# ls -lrta
total 43
drwxr-xr-x 5 napp-it root 7 Mar 11 09:10 ubuntu
-rwxr-xr-x 1 napp-it root 95 Mar 11 09:10 readme.txt
drwxr-xr-x 2 napp-it root 6 Mar 11 09:10 nicstat
drwxr-xr-x 2 napp-it root 5 Mar 11 09:10 scanpci
drwxr-xr-x 2 napp-it root 4 Mar 11 09:10 nc
drwxr-xr-x 3 napp-it root 5 Mar 11 09:10 filebench
drwxr-xr-x 2 napp-it root 11 Mar 11 09:10 other
drwxr-xr-x 4 napp-it root 10 Mar 11 09:10 httpd
drwxr-xr-x 2 napp-it root 4 Mar 11 09:10 bonnie
drwxr-xr-x 7 napp-it root 7 Mar 11 09:10 b_stru
drwxr-xr-x 2 napp-it root 4 Mar 11 09:10 solarish
drwxr-xr-x 11 napp-it root 12 Mar 11 09:10 omnios
drwxr-xr-x 3 napp-it root 5 Mar 11 09:10 iperf
drwxr-xr-x 2 napp-it root 6 Mar 11 09:10 linux
drwxr-xr-x 3 napp-it root 3 Mar 11 09:10 hipster
drwxr-xr-x 3 napp-it root 10 Mar 11 09:10 rsync
drwxr-xr-x 2 napp-it root 8 Mar 11 09:10 iozone
drwxr-xr-x 6 napp-it root 7 Mar 11 09:10 tftpd-hpa
drwxr-xr-x 20 napp-it root 21 Mar 11 09:10 .
drwxr-xr-x 6 napp-it root 7 Mar 11 09:10 solaris
drwxr-xr-x 5 napp-it root 6 Mar 11 09:10 ..
I have done a fresh install of OmniOS r151040q and run the `wget -O - www.napp-it.org/nappit | perl` installer 3 times now with reboots in between.

Thank you for all you do with napp-it, if it would be best for me to purchase it first and then put in a support issue, let me know. I was just trying to prove this out with the free version first.
 

gea

Well-Known Member
Dec 31, 2010
2,817
975
113
DE
Apache is currently only in 22.dev as a beta.
Some items like appliance group are not working.

When it is ready (estimate in 06.2022), I will include in free/default edition 21.06 also.
 

RonanR

Member
Jul 27, 2018
35
0
6
Hi Gea

I just saw your post and was wondering if it was possible for you to use the latest version of mini_httpd (1.30) which is working well in https instead of the 1.27 you're actually using?

FYI, I tried to use mini_httpd 1.30 instead of napp-it-mhttpd, but it's not working properly. I can access to the login page (in http and https) but once logged-in I got a connection reinitialized error (ERR_EMPTY_RESPONSE).
If it's not something you already tried and it's not too much work it would be great to have this solution while waiting for the adaptations to get it working with Apache.
 

gea

Well-Known Member
Dec 31, 2010
2,817
975
113
DE
I discovered the same with mini_httpd 1.30. It worked for the initial screen but not for submenus and I was not able to fix this. As there is nearly no active development on mini_httpd this seems a dead end although it is really a great embedded webserver.

In current napp-it (22.02b, 22.03b, newest 22.dev) Apache is working for https. In current 22.dev it is even possible to disable Apache ex to continue to use the SmartOS/pkgsrc AMP stack.
 

RonanR

Member
Jul 27, 2018
35
0
6
Ok, too bad. I didn't know if you used a modified version of mini_httpd or not.
I will test Apache version asap!
Thanks a lot for your work!