HGST Ultrastar SSD1600MM FW B100, B300, B360

mnode

New Member
Jul 23, 2021
5
0
1
Hi,

I have a 93xx 12gb/s sas raid card and I am trying to get the correct firmware on my drive. When I go to HGST site to find firmware it says non G-tech product when I provide serial of drive. Drive itself is HUSMM1616ASS201

Does anyone have or know where I can get any of these three firmware files?

This is what broadcom's site reports as working firmware with this raid card -
B100, B300, B360
 

TheCigarMan

New Member
Oct 15, 2021
6
0
1
Also looking for firmware; this isn't recognized in my DL385 Gen10 w/ a HPE Smart Array P408i-a SR Gen10 controller. Seems to be recognized by my
3ware 9750-8i.
I appear to be running B204.
 

Propaganda

Active Member
Dec 6, 2017
103
25
28
42
Also looking for firmware; this isn't recognized in my DL385 Gen10 w/ a HPE Smart Array P408i-a SR Gen10 controller. Seems to be recognized by my
3ware 9750-8i.
I appear to be running B204.
Make sure you are on 512 block size...
 

TheCigarMan

New Member
Oct 15, 2021
6
0
1
Make sure you are on 512 block size...
I’m fairly certain I am on 512 block size. With the Niagara tool, I was able to format the drives, even though it doesn’t appear I can do much else.

Edit: Now Niagara tool is not allowing me to format, so maybe it didn't work. I will continue to investigate.
 
Last edited:

Propaganda

Active Member
Dec 6, 2017
103
25
28
42
I’m fairly certain I am on 512 block size. With the Niagara tool, I was able to format the drives, even though it doesn’t appear I can do much else.

Edit: Now Niagara tool is not allowing me to format, so maybe it didn't work. I will continue to investigate.
sg_format can be used to format these drives
 

TheCigarMan

New Member
Oct 15, 2021
6
0
1
sg_format can be used to format these drives
Looks like sg_format fails and returns:
bad field in MODE SENSE (10) [mode_page 1 not supported?]

Meanwhile, using the same command with a -v flag returns:
sudo sg_format -v --format --size=512 /dev/sgx

LSI 9750-8i DISK 5.12 peripheral_type: disk [0x0]
PROTECT=0
inquiry: transport: Host_status=0x08 [DID_RESET]
Driver_status=0x00 [DRIVER_OK]
VPD_UNIT_SERIAL_NUM corrupted
mode sense(10) cdb: 5a 00 01 00 00 00 00 00 fc 00
mode sense(10):
Fixed format, current; Sense key: Illegal Request
Additional sense: Invalid field in cdb
bad field in MODE SENSE (10) [mode_page 1 not supported?]


Appreciate any and all help.

Is this something I should open a new post for, instead of piggybacking off of this post?
 

TheCigarMan

New Member
Oct 15, 2021
6
0
1
sg_format can be used to format these drives
Confirmed, I am on 512 block size. I obtained a second raid controller that is allowing me greater access to the drives. Upon closer inspection, however, I can't tell if it's a Broadcom 9340-8i, a Avago LSI 9341-8i, or Broadcom SAS9340-8i. Or perhaps those are all the same? This is the eBay listing.
 
Last edited:

TheCigarMan

New Member
Oct 15, 2021
6
0
1
I ended up discovering that my problem was a faulty backplane. After removing and re-seating everything, I am now able to access and use my drives. I probably won't update the firmware, as the folks from micromarkllc had already flashed to OEM. Highly recommend them, btw, excellent customer service.
 

Vitalium

New Member
Jan 12, 2022
1
0
1
Hello!

I have a lot of HGST HUSMM1616ASS201 which is flashed as IBM-SSG HSVJ1P6 with B204 firmware.
It seems they aren't fully compatible with HP MSA disk shelf and I want to re-flash them to OEM firmware.

I spent several days to find such a firmware but have no luck :( Does anyone have one?
I found IBM's firmware B364, but there is an error while trying to flash via Hugo or Niagara.

Can it be firmware vendor lock? Is it possible to unlock it?

Thank you!
 

Whaaat

Active Member
Jan 31, 2020
181
49
28
I found IBM's firmware B364, but there is an error while trying to flash via Hugo or Niagara
Look inside into this file. In the first part just before large blank chunk there are a list of supported models. HUSMM1616ASS201 is not there, only 1640 and 1680.