Experiences with NetApp DS4243

NablaSquaredG

Well-Known Member
Aug 17, 2020
602
258
63
A friend of mine is considering to buy NetApp DS4243s - I'm not convinced yet...

How loud are these?

And the most important questions:
Are they vendor locked to NetApp branded HDDs?

I guess there are lots of things we / he needs to be aware of...
As far as I've understood, these things are 3Gb/s with the original NetApp controllers? But the controllers can be replaced with Dell ones that add 6G/s support.
 

andrewbedia

Active Member
Jan 11, 2013
690
223
43
I have one DS4243. The first thing I did was put in a pair of Dell Compellent 6Gbps controllers (as you've referenced) that use normal SFF-8088. Sometimes these can be found cheap. Example here Genuine Dell Compellent HB-SBB2-E601-COMP 0952913-07 6GB SAS EBOD Controller OEM 787421252224 | eBay

Sometimes the DS4246 controller is cheaper. If you have the 8088-8088 cables already, it may be worth getting the Dell Compellent controllers. If not and you need to buy cables anyway, DS4246 controller may be a cheaper way to go. If you're running spinning hard drives, also consider you may be happy with 3Gbps performance.

In terms of quietness... I don't have a sound meter, but it is very noticeably quieter than HP StorageWorks MSA60 / D2600. I wouldn't put it in my livingroom, but it's reasonably quiet.

I have only used SAS drives with mine. I threw the SATA interposers out. I have used a mix of netapp and non-netapp 4TB and 8TB SAS disks in mine and never had trouble. I have no idea how SATA drives work in DS4243 or if there are weird caveats.

Good luck
 

gregsachs

Active Member
Aug 14, 2018
457
139
43
I've run sata drives in a ds2446, the 24x2.5 version. They only showed for one controller, not both, since single path. Proper sata->sas interposers would fix that. Never had issue. All the SBB documentation I've been able to find says that the expander and smarts are all in the controller/IOM module, not in the unit itself. That said, I know "people" have said they had issues putting the Dell IOM units in.
 

ItsaMeDS4243

New Member
May 11, 2021
9
0
1
With both power supplies and IOMs installed, it makes about the same amount of noise as one of those plug in air filter things. It's fan noise, but mine doesn't make any fan whine, it's mostly wooshing. I'd consider it very tame given that it idles at ~250w when populated with drives, but by modern desktop computer standards it's far from silent.

Now if you detatch one of the power supplies or IOMs (physically remove, not just unplug), it will make a scary amount of noise even for a rack mount device. I think I actually measured something like 70w extra power draw just from the fans when I tried pulling one of the IOMs to save a bit of power. Not recommended.

I can also report that the HB-SSB2-E602 is also not drive locked, I picked up a 601 and 602 and currently just have the 602 being used. Both can be had for under $30 on the bay, and the 601 has much wider availability.
 

gtcdma

New Member
Oct 29, 2020
19
7
3
I have 2 of these shelves. The first one is older and came with IOM3 controllers, the other one is newer and came with IOM6s. I think it might be actually a DS4246, but it doesn't have "DS4246" written anywhere on it.

I also picked up a Dell HB-SBB2-E601-COMP controller. It worked fine installed into the older shelf, but not in the newer one: the yellow light was on and the fans spun like crazy.
I tried to get it to work by installing it in different slots, together with an IOM3, IOM6 or both, etc, but nothing helped until I swapped the power supplies from the older shelf. Apparently the Dell unit can't properly communicate with the newer PSUs.

The older PSU part number is 82562-12 / HB-PCM01-580-AC and the newer one is 114-00087 / Delta TDPS-580BB A
Both of them work fine with IOM3 or IOM6, it's only Dell unit that has issues with the newer one.
Newer PSUs are also more efficient (35W vs 50-60W idle with no disks, 2 PSUs, 1 IOM).
 
Last edited:

gtcdma

New Member
Oct 29, 2020
19
7
3
Now if you detatch one of the power supplies or IOMs (physically remove, not just unplug), it will make a scary amount of noise even for a rack mount device. I think I actually measured something like 70w extra power draw just from the fans when I tried pulling one of the IOMs to save a bit of power. Not recommended.
I can't confirm this. Yes, they need 2 PSUs minimum, but work just fine with one IOM, no noise increase.
 
  • Like
Reactions: Bert

gtcdma

New Member
Oct 29, 2020
19
7
3
I have only used SAS drives with mine. I threw the SATA interposers out. I have used a mix of netapp and non-netapp 4TB and 8TB SAS disks in mine and never had trouble. I have no idea how SATA drives work in DS4243 or if there are weird caveats.
I have a wild mix of different SAS and SATA drives, 4TB-12TB, 512e and 4kn. No caveats so far. I'm not using interposers.

Also, it looks like there is absolutely no difference between IOM6 and Dell 601-COMP with regard to performance and drive compatibility. I'm pretty sure both of them are made by the same OEM.
 
  • Like
Reactions: Stefan75

gtcdma

New Member
Oct 29, 2020
19
7
3
are these units also easy in use with Windows 10 enterprise and any LSI 6gbps HBA ?

or is it difficult with some proper drivers ??
I didn't try it on Windows, but I suppose it should just work as well without any special drivers.
 

gregsachs

Active Member
Aug 14, 2018
457
139
43
I had a netapp ds2246 show under hyper-v 2016 with no issues, connected to a 9286-cv-8e
 

Preston Youngsley

New Member
Feb 29, 2016
3
2
3
36
I have 2 of these shelves. The first one is older and came with IOM3 controllers, the other one is newer and came with IOM6s. I think it might be actually a DS4246, but it doesn't have "DS4246" written anywhere on it.

I also picked up a Dell HB-SBB2-E601-COMP controller. It worked fine installed into the older shelf, but not in the newer one: the yellow light was on and the fans spun like crazy.
I tried to get it to work by installing it in different slots, together with an IOM3, IOM6 or both, etc, but nothing helped until I swapped the power supplies from the older shelf. Apparently the Dell unit can't properly communicate with the newer PSUs.

The older PSU part number is 82562-12 / HB-PCM01-580-AC and the newer one is 114-00087 / Delta TDPS-580BB A
Both of them work fine with IOM3 or IOM6, it's only Dell unit that has issues with the newer one.
Newer PSUs are also more efficient (35W vs 50-60W idle with no disks, 2 PSUs, 1 IOM).

reviving this thread from the dead, as it has the most info I have found in regards to my request. I have 2 DS424x's in service in my home rack, and I've recently been trying to get some power consumption numbers down. I'm running them with 2x PSUs (X518A-R6), plugged in and powered, 1 IOM 6 Module, and blanks to stop the fans from ramping up. The first shelf is full of SATA disks that range from 2TB - 18TB. I'm just stating the fill up the 2nd shelf. I know Xyratex was the OEM for alot of different shelves and I've noticed that many have the same form factor of PSUs. From some precursory reading and searching it seems that Netapp provided two part numbers for PSUs for the DS424x series of disk shelves.
X518A-R6 |114-00070 / HB-PCM01-580-AC - PSU W/FANS,580W,AC,DS424x,R6
r/netapp - Netapp DS424x - Compatible with HP / Dell PSUs with 80+ Gold rating?
X522A-R6 |114-00026 / Delta TDPS-580BB A - PSU W/FANS,Estar,580W,AC,DS424x
r/netapp - Netapp DS424x - Compatible with HP / Dell PSUs with 80+ Gold rating?

My original plan was to grab a X522A and test it out with a Kill-a-watt to see if the Estar rated PSU is any more efficient with my setup. Not sure how much difference this would potentially make, as the comparison of power draw was @ idle with no disks. Further searching down the rabbit hole led me to more PSUs with the same form factor, but I am unsure if their pinouts would remain the same, but I would assume so much. Two of the additional units stood out specifically to me -
SP-PCM01-HE580-AC / Delta TDPS-580AB - PSU W/FANS, 580W, 80+Silver - These seem to come out of Dells or HPs and often have a -AC-DELL / -AC-HP PN listed.
r/netapp - Netapp DS424x - Compatible with HP / Dell PSUs with 80+ Gold rating?
SP-PCM02-HE580-AC / Flextronics XRT-S-0580ADU00-103 / 0996223-02 - PSU W/FANS, 580W 80+GOLD - These seemed to be mainly from HPs and often have the -AC-HP PN listed.
r/netapp - Netapp DS424x - Compatible with HP / Dell PSUs with 80+ Gold rating?
These two units from Dells and HPs seem to be the same form factor, but the PCM01 is 80+ Silver, and the PCM02 is 80+Gold Rated. I know that Energy star != Gold / Silver Efficiencies, but I was wondering if anyone knows A) if the Dell / HP PSUs will work in a netapp, (are pinouts the same. Does anyone have a datasheet for any of these PSUs?) B) if the 80+Gold or 80+Silver is more efficient than the Energystar Netapp PSU, C) if this exercise is insane and i'm probably not going to save any power and just spend money on stupid old psus.
 
  • Like
Reactions: richard.dzavoronok
Jun 23, 2021
48
15
8
I'm too trying to get down consumption of ds4243, I'll check what PSU's I'm having tomorrow and report back consumption.
Also I read on reddit that HB-SBB2-E601-COMP (while having sff8088 ports, for which cables are a lot cheaper than qsfp-sff) has some additional fan/voltages control as it is communicating with PSU and can be quieter and consume lower energy. I have no idea if it's PSU version dependent though.
 

Preston Youngsley

New Member
Feb 29, 2016
3
2
3
36
Got a single TDPS-580BB / X522A in for testing and it looks promising. I've only done some surface level quick testing. I would say it's not the most scientific or exact measure approach, but a good enough measure to prove the point. The unit slots in with no issues as expected, as it is a netapp P/N for this PDU.

Testing methodology- Single PDU, slotted in, connected to the wall. 3x PDUs slotted in, not connected to the wall. 1x IOM6 Controller. Controller blanks to keep the fans from ramping. Tested Idle W and VA with no drives, as well as connected with 2x 18TB SATA drives. Wattage and VA were measured with a kill-a-watt type device and after the array had been powered on for a few minutes and the start up procedure and fan check have been completed. I am in the US running AC 120V.

X518A-R6 - No Drives + Idle - 60.02W / 52.15VA
X522A / TDPS-580BB - No Drives + Idle - 37.32W / 39.16VA
rough power savings @ idle with an empty shelf ~ 23W / ~13VA

X518A-R6 - 2x 18TB Drives / Connected to Unraid but idle - 73.47W / 75.02VA
X522A / TDPS-580BB - 2x 18TB Drives / Connected to Unraid but idle - 52.95W / 54.07VA
rough power savings @ idle with 2x 18TB SATA disks ~20.5W / 21VA

I'd say the TDPS-580BB / x522A are worth the upgrade to save some power. Most I found were in the $45US range, but some ebayers accepted offers of prices as low as $18US.

I was able to also test a SP-PCM02-HE580-AC. The unit physically slots in with no issues and powers the shelf on. That's about where the test stopped. Once the IOM is initialized the fan on the PCM cranks up to maximum RPM. Any PCM that is plugged in will also ramp up its fans. The fans in the SP-PCM02 are also different and make more of a higher pitched whine noise as opposed to the whoosh of the Netapp Units. I did not measure any wattage pull, as the fans were unbearably loud. Imagine an electric leaf blower plugged and blowing in behind the rack. My thoughts are that the PCM does not talk to the IOM properly and thus just defaults to full speed. I would think maybe this could be remediated with a different controller, either the HP3 Par controller or a Dell Comp controller, neither of which i have on hand right now. Extrapolating results from this test, I'd also venture to guess that the SP-PCM01 80+ Silver rated would most likely do the exact same thing.


TL;DR - TDPS-580BB / X522A can save some wattage and is a worthy upgrade if you can find them for a low enough price. The HP / Dell PCMs slot in physically and will power the shelf without issue, however the PCM does not communicate with the Controller properly and the fan speed ramps up to maximum RPMs. The noise is unbearable for regular use.
 
  • Like
Reactions: UhClem
Jun 23, 2021
48
15
8
Thanks for your effort. I didn't checked my PSUs as two Delta ones are in shelf that I need to be powered up.
Maybe SP-PCM02-HE580-AC are for xyratex/dell controllers?
I suggest to read this thread on reddit:
OP in that thread did test a few things that are worth trying I guess? Specifically another savings from smart control of fans with SBB2 controller. I found some of them for 14 bucks on US ebay. Here in EU they are going for 90 euros which sucks.

Edit: media insert from reddit thread hidden behind Spoiler
 

Preston Youngsley

New Member
Feb 29, 2016
3
2
3
36
From my minimal investigations, it seems that the SP-PCM02-HE580-AC is from an HP 3PAR M6720, even then, most of those came with the PCM01 version that is 80+ Silver.

Being a glutton for punishment and exhausting my potential savings on science, I grabbed a set of Dell Compellent SAS Controllers to test. I ended up with some very interesting findings. More reading has shown that the compellent controller requires 2x psus powered before it will spin up any disks, not sure the truth to this, but it may explain some of my experiences.

Backstory:
I have 2 DS424x Shelves.
The original one I picked up years ago, we'll call this OG, has Xyratex 2008 on the PCB. OG came with 2x IOM3's, 4x X518a-R6 Power One branded PSUs. A later IOM6 (single IOM6 Controller, 3x Blanks) upgrade slotted in fine with no issues, worked on first boot;
The newer shelf I got recently, we'll call this FNG, has Xyratex 2010 on the PCB. FNG also came with 2x IOM3's, 4x X518a-R6 Power One branded PSUs.a later IOM6 (single IOM6 Controller, 2x Blanks, one IOM3 flipped into the blank position with no physical connection just to serve as a blank) upgrade slotted in fine with no issues, worked on first boot
Both shelves show power savings when moving to a TDPS-580BB / X522A psu. Currently running 2x TDPS-580BBs plugged in to the wall and switched on in both OG and FNG, with 2x X518a-r6 psus slotted in, but not plugged in to the wall (essentially blanks). Plugged in PSUs are in Top left and bottom right positions when facing the rear of the chassis.
When I swap the IOM6 for the Compellent in OG, with no other changes to PSUs or anything, the shelf immediately ramps up the two plugged in PSUs fans, and stays there, however the shelf ID registers and the device seems to be functional (I've only done idle testing so far, no usage testing yet). When I swap the IOM6 for the compellent in FNG the fans ramp up, but no shelf ID registers, after 30 seconds the fans go into full on combustion mode. The shelf ID never registers with the 2010 unit.

Since I only have one SP-PCM02-HE580, (looking for another one to satisfy proper testing) I have limited testing to one plugged in PSU, the PCM02. The rest of the 3x psus are slotted in but not plugged in, serving as blanks.
OG with a Compellent controller and one PCM02 will spin up fans in a more normal speed and fashion, register the shelf id. after 30 seconds the non plugged in slot 4 PSU will ramp its fan into full on combustion mode, while the PCM02 fan stays relatively tame. Unit seems functional outside of the excess noise from psu4.
FNG with a compellent controller and one PCM02 will spin up fans quickly, no shelf id registers, after 30 seconds the shelf goes in to full power fan mode. excessive noise, not usable.

So here is where I'm at. . . My understanding is that the 2010 and later Xyratex PCBs were more desired for IOM6 upgrades / high capacity drives. I have never had any capacity issues with my OG 2008 PCB, Ive got some 18TB and 14TB drives running fine. Im wondering what if any differences there are between backplane revisions. Some lockout must exist, either on the PSU, the PCB, or SAS Controller. I'm wondering if the HP SAS controllers are another route or if they are just clones of compellent. It seems I need at least another SP-PCM02-HE580 to test the psu4 fan speed issue when deploying in OG. The saga continues...