Arista DCS-7050T-64-R QSPF+ 40gb question

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

pinkyd

New Member
Jan 4, 2023
2
0
1
Hey folks, I got the above mentioned switch off ebay. However, I loaded 4.18.11M firmware on it (it had a 4.10) previously and Im trying to configure the QSFP ports for 40gb. Im using the userguide of EOS website which states default speed is set to 40gb. the default config on mine came with the command transceiver qsfp default-mode 4x10G already in the config and I can't no it away(even with a fresh reset from aboot). I got the switch to replace an icx6610 thats dying so im fresh on brocade, but rusty on cisco and arista. I'm trying to preconfigure the switch so I can just take everything down and swap it out but I have a 2x40gb nas I use for storage and can't seem to figure out how to get the ports configured. the switch doesn't take the speed 40gfull command on the qsfp interface and ? for help under speed looks like its out of date because it only shows:
Code:
(config-if-Et51/1)#speed ?
  100full        Disable autoneg and force 100 Mbps/full duplex operation
  10full         Disable autoneg and force 10 Mbps/full duplex operation
  auto           Enable autoneg for speed, duplex, and flowcontrol
  forced         Disable autoneg and force speed/duplex/flowcontrol
  sfp-1000baset  Configure autoneg and speed/duplex on 1000BASE-T SFP
and I dont have the show interfaces ethernet 51/1 hardware command in my OS version either so I cant confirm capabilities. However, everything i checked says it should be 40gb capable

Any help or suggestions on getting it to work would be appreciated.

Thanks!
 

ano

Active Member
Nov 7, 2022
618
248
43
conf t
interface ethernet 51/1
speed forced 40gfull


you will get a info message about duplex


edit, read @klui 's link, everything is there as well.
 
  • Like
Reactions: pinkyd

Rahvin9999

Active Member
Jan 14, 2016
134
85
28
Rotterdam, The Netherlands
The " transceiver qsfp default-mode 4x10G " is a default in the config.

Just do:
Code:
speed forced ?
  10000full  Disable autoneg and force 10 Gbps/full duplex operation
  1000full   Disable autoneg and force 1 Gbps/full duplex operation
  1000half   Disable autoneg and force 1 Gbps/half duplex operation
  100full    Disable autoneg and force 100 Mbps/full duplex operation
  100gfull   Disable autoneg and force 100 Gbps/full duplex operation
  100half    Disable autoneg and force 100 Mbps/half duplex operation
  10full     Disable autoneg and force 10 Mbps/full duplex operation
  10half     Disable autoneg and force 10 Mbps/half duplex operation
  25gfull    Disable autoneg and force 25 Gbps/full duplex operation
  40gfull    Disable autoneg and force 40 Gbps/full duplex operation
  50gfull    Disable autoneg and force 50 Gbps/full duplex operation

speed forced 40gfull
and it will set the port to the right speed. the /2/3/4 ports will no longer be visible.
Only issue I have had on occasion is artifacts of the old config for the /2 /3 /4 split ports hanging around in the config file even though its no longer active.
 
  • Like
Reactions: pinkyd