vSphere 7 Update 3 PSOD with Epic Milan 7443p and Asrock ROMED8-2T

mirol

Member
Jan 6, 2018
34
4
8
35
Hi Guys yesterday I tried to update my esxi host from VMware ESXi, 7.0.2, 18538813 to ESXi-7.0U3-18644231-standard via ssh metod like i always do.After restart I got PSOD visible on Attached photo from this link Untitled .I tried update it twice and everytime I got the same issue after restart its come back to previous version.Anyone have idea why its happening its some bug with update 3 or some bios settings cause it any clues?
My server spec is:
Amd Epyc 7743P
Asrock ROMED8-2T with Bmc v 1.19.00 and Bios v L3.28
8x 128GB M393A4K40DB3-CWE
And Corsair ax1600i psu
----Pcie Cards:
Chelsio t540-cr
Samsung PM1735 3.2gb
Amd pro w 3100
Nvidia Quadro A4000
 

jpmomo

Active Member
Aug 12, 2018
286
97
28
Hi Guys yesterday I tried to update my esxi host from VMware ESXi, 7.0.2, 18538813 to ESXi-7.0U3-18644231-standard via ssh metod like i always do.After restart I got PSOD visible on Attached photo from this link Untitled .I tried update it twice and everytime I got the same issue after restart its come back to previous version.Anyone have idea why its happening its some bug with update 3 or some bios settings cause it any clues?
My server spec is:
Amd Epyc 7743P
Asrock ROMED8-2T with Bmc v 1.19.00 and Bios v L3.28
8x 128GB M393A4K40DB3-CWE
And Corsair ax1600i psu
----Pcie Cards:
Chelsio t540-cr
Samsung PM1735 3.2gb
Amd pro w 3100
Nvidia Quadro A4000
same here with a supermicro h12ssw-in. i am going to try on another server that has an amd 7452 and another one that has an ice lake. will update this thread with my results.
 

jpmomo

Active Member
Aug 12, 2018
286
97
28
just to clarify, I had the psod with an amd milan 7313p on a supermicro h12ssw-in when trying to upgrade to 7.0.U3. I did not have this issue with either an amd 7452 or an intel 8352s (ice lake xeon).
 

mirol

Member
Jan 6, 2018
34
4
8
35
I got virtualization emabled besides it work with old version.I think this update got issues with milan cpus then :( we prob need to w8 for next update and try.
 

HilkoVMware

New Member
Oct 12, 2021
2
3
3
Netherlands
There is a bug in AGESA MilanPI 1.0.0.1/1.0.0.2 where the LOCK in VM_CR MSR isn't equal between the first core and the other cores.
Ask your motherboard vendor for AGESA 1.0.0.3 or 1.0.0.4 or (not recommended as you're bypassing a problem) use cpuUniformityHardCheckPanic = FALSE ESXi kernel boot option.

1.0.0.1:

1.0.0.4:
 

mirol

Member
Jan 6, 2018
34
4
8
35
Ehh I just dont see asrock will do it if I ask tbh (will try) I will prob need to w8 and pray for updated bios someday then...
Big thx for make us aware about this tho:D
 

HilkoVMware

New Member
Oct 12, 2021
2
3
3
Netherlands
Asrock-rack and Supermicro are amazing at providing BIOS-es. I usually get them within an hour to 24 hours. Even without using my at vmware email address.
 

jpmomo

Active Member
Aug 12, 2018
286
97
28
Asrock-rack and Supermicro are amazing at providing BIOS-es. I usually get them within an hour to 24 hours. Even without using my at vmware email address.
I contacted both but do not have a date for when they will be available. I had much better responses in the past with both companies but not so much lately. I will update this thread as soon as I get any bios that fixes this issue.