VMware 6.7 Issue with intel x540-t2 SR-IOV

Discussion in 'VMware, VirtualBox, Citrix' started by l0l0l0, Apr 30, 2018.

  1. l0l0l0

    l0l0l0 New Member

    Joined:
    Apr 30, 2018
    Messages:
    1
    Likes Received:
    0
    Hello,

    I try to activate the sr-iov for my x540-t2 card but the esxi asks me for a constant reboot to activate it !

    I found on the internet that we could disable ACS check (VMkernel.Boot.disableACSCheck = true) but it has no effect for me!

    In the bios, vt-d is activated and the vib of the latest intel drivers is installed.

    in the log I constantly "0000: 01: 00.1: Bypassing non-ACS capable device in hierarchy"

    I was wondering if the problem came from the fact that the network card is connected to the only pcie port that is directly linked to the cpu?! (ESXi 6.5 PCI passthrough issue • r/vmware)

    thank you for your help and have a nice day
     
    #1
  2. Rand__

    Rand__ Well-Known Member

    Joined:
    Mar 6, 2014
    Messages:
    2,362
    Likes Received:
    294
    What board are you using?
    Can you swap the card maybe to rule out that issue? :)
     
    #2
  3. K D

    K D Well-Known Member

    Joined:
    Dec 24, 2016
    Messages:
    1,331
    Likes Received:
    277
    I tried remotely upgrading my home server that has a x540 which is passed through to omnios and directly connected to my workstation. Upgrade went flawlessly and had no issues. I'm only using pass through and not SR-IOV though.
     
    #3
  4. AveryFreeman

    AveryFreeman ESXi + ( BSD / ZFS ) = HAPPY

    Joined:
    Mar 17, 2017
    Messages:
    64
    Likes Received:
    4
    I am having an issue similar to this --

    FreeNAS VM working fine with Cougar Point SATA controller passthrough since ESXi 5.5 - so, several years now. Just upgraded to 6.7 - can't pass through the controller anymore, have rebooted 5 times after toggling passthrough on it, every time I reboot it's disabled again - very frustrating.

    I found this flag - vmkernel.boot.disableACScheck - it's set to false (presumably meaning, ACS check will happen on boot). I set it to 'true' to disable the check. I rebooted the machine. It's set to false again after reboot.

    WTF? Can't I even change the settings in the manager anymore? Does anyone know what's going on here?
     
    #4
  5. AveryFreeman

    AveryFreeman ESXi + ( BSD / ZFS ) = HAPPY

    Joined:
    Mar 17, 2017
    Messages:
    64
    Likes Received:
    4
    I am noticing something new, pcipassthrough does not load during the boot process --- but I still cannot change vmkernel.boot.disableACScheck to true because none of my settings are persistent through reboot.

    This is the error I see in the console during boot:

    method invocation failed: pcipassthrough->start() failed: error while executing the cli

    In boot.cfg, I tried setting:

    kernelopt=autoPartition=TRUE skipPartitioningSsds=TRUE autoPartitionCreateUSBCoreDumpPartition=TRUE

    Settings still not persistent. I'm feeling like I'm hijacking this thread, even though the issues are likely related. Going to start a new thread.
     
    #5
Similar Threads: VMware Issue
Forum Title Date
VMware, VirtualBox, Citrix Help needed VMware ESXi 6.5 issues with HBA Dec 26, 2017
VMware, VirtualBox, Citrix VMware, ZoL, and targetcli odd issue... Mar 26, 2016
VMware, VirtualBox, Citrix Migrate Xenserver to VMware - Good idea? Aug 2, 2018
VMware, VirtualBox, Citrix VMWare vSAN, quad M.2 NVME + 1 cache vs SATA SSDs? Jul 5, 2018
VMware, VirtualBox, Citrix VMware Guest RAID pass through question May 1, 2018

Share This Page