Updating Wiwynn Open compute bios for E5 V2's Edit. Gave up trying. :(

Klee

Well-Known Member
Jun 2, 2016
1,292
395
83
The adding the ivy bridge microcode is on hold for now and I started to play around modding the date and version again.

I can update the .rom with newer microcode for the cpu and update the code for the network chips and it boots fine.

Now it has cpu microcode from 2018 instead of from six years ago.

And I was able to change the date and version that shows on the initial bios screen.



EDIT: some reason the pic on imgur is gone, will need to dig it up and repost.
 
Last edited:

Klee

Well-Known Member
Jun 2, 2016
1,292
395
83
I gave up trying to get V2 E5 Xeons working, even had help from a couple people with way more knowledge about bios's than me.
 

Klee

Well-Known Member
Jun 2, 2016
1,292
395
83
Also I figured out why a newly fully flashed bios chip would spit out an error on the first boot.

The Intel ME see's that there is not a valid mac address for either network interface then adds the correct ones to the bios and then reboots.

It's probably does other stuff also but thats the only thing that I can see it do.

And that saved me a ton of time by not having to manually edit the mac address on the bios chips I have flashed.

I am tired of using a HEX editor.;)
 

Klee

Well-Known Member
Jun 2, 2016
1,292
395
83
For those who are curious what is updated in the bios that I modded.

The cpu microcode I updated from 70d dated from 2011 or 2012 to 714 dated mid 2018.

Both the network chipsets also updated to a much newer version.

Also PRO_TIP!!! Use fresh CR 2032 battery's, I found out that even tho the old battery's all show a little over 3.0 volts with my test meter that caused issues of not booting after a new flash and after a fresh battery that showed 3.3 those issues went away.

It was driving me crazy chasing why sometimes a flash would boot and sometimes it would not, even tested my ram a second time and after I pulled the battery out for the upteenth time on my last node that refused to boot and then tested that and it showed 3.01 v with my multi meter I decided to throw in a new one that did show 3.3 v and it booted.o_O
 

Attachments

Klee

Well-Known Member
Jun 2, 2016
1,292
395
83
Full-o-ram and E5-2650L v1 cpu's.

Samsung ecc pc8500 4gb sticks and cpu's for cheap.

The 2650L v1 cpu's were right at 20.00 each shipped, wanted the most cores with the lowest tdp at the cheapest prices I could find.

Not looking for cpu's that will turn my house into an oven like the 2665's I had and these run pretty cool.

The ram ended up costing me $.63 per GB.

EDIT: I just bought some even cheaper pc8500 ram at $.32 per GB, just love "Make Offer" listings.:D
That's $1.25 per 4 GB stick of ram, its nice having so many ram slots that I can fill with cheap 4gb DDR3 instead of pricier 8 GB. 64 gb per node will be plenty for now.
 

Attachments

Last edited:

Mehmet

New Member
Mar 26, 2016
13
1
3
48
Can you upload original bios EP_P09RG.01 and ME firmware? I lost mine. Thank you.