The Elusive HGST Drive Manager

Rand__

Well-Known Member
Mar 6, 2014
4,494
878
113
Unless you have been looking for this specific version I think there are a couple of threads here where one version or another was linked...

And the only thing I remember my old 2.4.x version needed was an older Java version (1.8) or so...
 

piexil

New Member
Aug 26, 2019
4
2
3
Unless you have been looking for this specific version I think there are a couple of threads here where one version or another was linked...

And the only thing I remember my old 2.4.x version needed was an older Java version (1.8) or so...
This specific version is the latest afaik.
It also supports SN200/SN260 drives, which I don't believe the older ones do.