The Complete LSI/Avago/Broadcom SBR Download MegaThread

Jensen567

New Member
Apr 24, 2022
11
6
3
Hate to keep being a pain, but megarec3 seems to freeze up using the "megarec3 -readsbr 0 9362.sbr" command. Obviously I'm doing something wrong. It does give me a list of commands when I just type megarec3.

MegaCLI seems to work, but I don't want to flash the firmware before pulling the SBR from the unmodified cards. I dont see the 9362 or EP420i SBRs listed in the first post, so would like to provide them if I can.

Also, appreciate the Fujitsu link, even though it doesn't seem to know what an EP420i/D3216 is. Going to try searching by serial number next.

Finally, if you have a donation link I would definitely contribute, have already received more than my fair share of help. Lol
 
  • Like
Reactions: Sleyk

Sleyk

Well-Known Member
Mar 25, 2016
1,309
651
113
Stamford, CT
Hate to keep being a pain, but megarec3 seems to freeze up using the "megarec3 -readsbr 0 9362.sbr" command. Obviously I'm doing something wrong. It does give me a list of commands when I just type megarec3.

MegaCLI seems to work, but I don't want to flash the firmware before pulling the SBR from the unmodified cards. I dont see the 9362 or EP420i SBRs listed in the first post, so would like to provide them if I can.

Also, appreciate the Fujitsu link, even though it doesn't seem to know what an EP420i/D3216 is. Going to try searching by serial number next.

Finally, if you have a donation link I would definitely contribute, have already received more than my fair share of help. Lol
No worries my friend, I got you. I do have the 9362-8i and Fujitsu EP400i/420i sbr's already, just haven't made the time to upload em' :.)

So you can flash no worries. If you need to restore the card, just pm me. Will provide you the sbr or restore procedure if you run into any issues.
 
  • Like
Reactions: Jensen567

RAIDER

New Member
Apr 16, 2020
5
2
3
Is there a good walkthrough for how to get started flashing? I tried using StorCLI to flash the 9361 firmware file onto the EP420i and 9362, but both cards came back with an error "controller 0 not found"

For the EP420i it has RAID6 already, so really I probably just need to get the latest firmware on there.
Hmm not sure if my brain is fooling me but as far as I remember I had no issue flashing the latest 9361 firmware on EP420i using LSA within Windows.
 

Attachments

  • Like
Reactions: Sleyk

Jensen567

New Member
Apr 24, 2022
11
6
3
Latest 9361 firmware written to both cards no issues at all with megaCLI. Thanks so much for the help. Still want to play with some SBR stuff, so will likely be back here again. Really want the 9362 to appear as a 9361, or maybe even another EP420i.
 
  • Like
Reactions: Sleyk

Fritz

Well-Known Member
Apr 6, 2015
2,725
807
113
68
I've got a QUANTA 3108 DAS2BTH7CB0 on the way to me and went looking for firmware. Can't find it or any 3108 firmware.

Have any advice ? :)
 
  • Like
Reactions: Sleyk

Sleyk

Well-Known Member
Mar 25, 2016
1,309
651
113
Stamford, CT

Attachments

  • Like
Reactions: Fritz and Jensen567

Jensen567

New Member
Apr 24, 2022
11
6
3
If you want the original Avago firmware it is available on the Broadcom website here.


To find the older cards you will need to select "Legacy Products" at the first selection box, then "Legacy RAID Controllers". Use the first post from the legend Sleyk to determine the closest match 3108 controller to yours.
 
  • Like
Reactions: Sleyk and Fritz

Fritz

Well-Known Member
Apr 6, 2015
2,725
807
113
68
If you want the original Avago firmware it is available on the Broadcom website here.


To find the older cards you will need to select "Legacy Products" at the first selection box, then "Legacy RAID Controllers". Use the first post from the legend Sleyk to determine the closest match 3108 controller to yours.
I don't think I've ever been able to find squat on Broadcom's website. I drill down to it and it say "No Results Found" which pretty much happens every time I search for anything.
 
  • Like
Reactions: Sleyk

fffsfdsf

New Member
May 20, 2022
13
4
3
Ah, sadly the card's flash may is dead/non-functioning. There is a "fix", well, sort of, but you lose the LSI/Avago vendor branding.

Right now, the card's flash is completely corrupt and essentially dead with little to no chance for recovery, but you could recover it by flashing the IBM 9364/M5210 firmware to it, and writing the recovery firmware.

It will boot and work as a sort of downgraded "IMR" mode card and you will see the drives, but you will not have an official "LSI/Avago 9361-8i anymore, as the flash is corrupted and there isn't a way to fix it on these cards.

I know firsthand, as I have 2 9361-8i cards with the same exact issue, and I was only able to do this. Been working on this for a while now. Alot of 9361 cards actually have a reputation for falling out of the blue. It might have been the cheap flash module Avago used at the time, but who knows. I f you use megarec3, you can still see the SAS3108 chipset, so the chipset itself is fine, but the flash has sorta, kinda died, so no way to get it to factory settings again.

Trust me, I've tried :.(

I know the message reads as "bad or missing raid controller memory module", but what the card is essentially reporting, is the factory flash has failed :.(

However, you can still use the card, just without LSI/Avago branding.

PM me for more info my friend.
hi,my 9361-8i recently failed,too,same 'bad or missing memory'
is there any web page have the procedures what I should do
thanks
 
  • Like
Reactions: Sleyk

Sleyk

Well-Known Member
Mar 25, 2016
1,309
651
113
Stamford, CT
hi,my 9361-8i recently failed,too,same 'bad or missing memory'
is there any web page have the procedures what I should do
thanks
Sure, so all you would need to do is flash the IBM M5210 firmware. You can use Megarec3.

Type: Megarec3 -writesbr 0 9364.sbr

(You can find the 9364 sbr on the first page of the thread.)

then type: Megarec3 -m0flash 0 ibm3108.rom and it should flash to the M5210 firmware. It should now boot, and you can use it, but you will lose RAID6, and the LSI branding.

Here is the IBM M5210 firmware: 9364 firmware (M5210)

I linked Megarec3 below for ya
 

Attachments

  • Like
Reactions: fffsfdsf and Fritz

Fritz

Well-Known Member
Apr 6, 2015
2,725
807
113
68
I'm currently in the process of initializing a 24 drive RAID 60 pool. MSM is showing a yellow square or something or other next to one of the drives. I can't make any sense of the documentation so I'm not sure what this means. HD Sentinel says the drive is perfect. Upon further investigation I've determined that this particular drive, an Hitachi HUC109090CSS601, is different from all the rest. It's a 10K drive shows as Data Protection Capable in MSM whereas the rest of the drives are 7200k and show Incapable.

Anybody know what the yellow thingamajij means?

Yellow.PNG
 

Fritz

Well-Known Member
Apr 6, 2015
2,725
807
113
68
I'm currently in the process of initializing a 24 drive RAID 60 pool. MSM is showing a yellow square or something or other next to one of the drives. I can't make any sense of the documentation so I'm not sure what this means. HD Sentinel says the drive is perfect. Upon further investigation I've determined that this particular drive, an Hitachi HUC109090CSS601, is different from all the rest. It's a 10K drive shows as Data Protection Capable in MSM whereas the rest of the drives are 7200k and show Incapable.

Anybody know what the yellow thingamajij means?

View attachment 22930
Crap, looks like they are all 10K so the only thing different about this drive is Data Protection.
 
  • Like
Reactions: Sleyk

Fritz

Well-Known Member
Apr 6, 2015
2,725
807
113
68
Yeah was gonna suggest that, since your using Windows, so most likely it has some sort of protection/encryption :.)
Got another 14 and a half hours to go before initialization is complete. I'll investigate some more after it's done.
 
  • Like
Reactions: Sleyk

fffsfdsf

New Member
May 20, 2022
13
4
3
Sure, so all you would need to do is flash the IBM M5210 firmware. You can use Megarec3.

Type: Megarec3 -writesbr 0 9364.sbr

(You can find the 9364 sbr on the first page of the thread.)

then type: Megarec3 -m0flash 0 ibm3108.rom and it should flash to the M5210 firmware. It should now boot, and you can use it, but you will lose RAID6, and the LSI branding.

Here is the IBM M5210 firmware: 9364 firmware (M5210)

I linked Megarec3 below for ya
thaks
i'll try when i go back from work
 
  • Like
Reactions: Sleyk

fffsfdsf

New Member
May 20, 2022
13
4
3
Sure, so all you would need to do is flash the IBM M5210 firmware. You can use Megarec3.

Type: Megarec3 -writesbr 0 9364.sbr

(You can find the 9364 sbr on the first page of the thread.)

then type: Megarec3 -m0flash 0 ibm3108.rom and it should flash to the M5210 firmware. It should now boot, and you can use it, but you will lose RAID6, and the LSI branding.

Here is the IBM M5210 firmware: 9364 firmware (M5210)

I linked Megarec3 below for ya
ahh
when i flash
it stop at
flashing ctrl
invalid image
 

fffsfdsf

New Member
May 20, 2022
13
4
3
Sure, so all you would need to do is flash the IBM M5210 firmware. You can use Megarec3.

Type: Megarec3 -writesbr 0 9364.sbr

(You can find the 9364 sbr on the first page of the thread.)

then type: Megarec3 -m0flash 0 ibm3108.rom and it should flash to the M5210 firmware. It should now boot, and you can use it, but you will lose RAID6, and the LSI branding.

Here is the IBM M5210 firmware: 9364 firmware (M5210)

I linked Megarec3 below for ya
Currently flashing component = CTLR
Invalid Flash Image. flashOffset: 1200000, flash_part_size: 1000000
Error in programming image into flash.
Error code = 64
Failed to flash the image. Please retry recovery
 

fffsfdsf

New Member
May 20, 2022
13
4
3
now change to this

currently flashing component=app
programming flash...
completed:0% and buffer timeout
amdwb err fa ff2015fe last data 38e0 rb1 2000 rb2 fea015fe
fa ff2015c0 count 40 i = 40

checking for secondary iMR image

error in programming image into flash.
error code = 64
failed to flash the image .
please retry recovery