Supermicro X9DRX - do I really need NVMe BIOS mod?

Discussion in 'Processors and Motherboards' started by jfharper, Nov 23, 2018.

  1. jfharper

    jfharper New Member

    Joined:
    Nov 23, 2018
    Messages:
    1
    Likes Received:
    0
    I can't get the UEFI to recognize the NVMe drive in the EFI shell.

    I was able to create a UEFI bootable USB Win 10 install stick using RUFUS which the BIOS can see.

    Win 10 install can see the NVMe drive and I can select it as the install drive, and Win 10 creates the partitions and copies the install files to this drive, but when Win 10 reboots to finish install, it goes to the EFI Shell only (since I have this as the UEFI 1st boot option assuming it might work).

    There is no fsx: available for the NVMe, only the USB fs0: is visible.

    SM said the Samsung NVMe would be supported for my board under UEFI mode, but I cannot get it to work.

    Just wanted to see if there was anything I could do before I go the mod bios route. I have UEFI only set in BIOS and the only UEFI drive seen under the Boot section is the USB UEFI...only other option is UEFI EFI shell.

    The PCIe slot option is enable or disable for the NVMe drive. Unless I need to put the drive in PCIe slot 1, instead of slot 8. I have 2 graphics cards on slot 1 and 2.
     
    #1
  2. bzaras

    bzaras New Member

    Joined:
    Apr 15, 2019
    Messages:
    7
    Likes Received:
    0
    first of all you need the latest bios, if you dont have it please update
    second - clear cmos via jumper and load setup defaults (somehow i run with a strange quirk on my X9DRi-LN4F that nvme became bootable only after defaults loaded into setup even tough the settings after loading defaults were configured to be exactly the same as before),
    if the board still does not see the drive you need modded bios.
     
    #2
  3. azev

    azev Active Member

    Joined:
    Jan 18, 2013
    Messages:
    588
    Likes Received:
    146
    Have you gone back to the bios and check the boot order ?? In my case I have to change the uefi boot order to use the windows os or windows boot manager and that allows me to boot using my samsung nvme.... Some X9 board requires you to edit the overall boot order and put the uefi windows boot at the very top for it to automatically boot to windows. Some other X9 board have no issue to put them at the bottom of the boot order, I am not sure why this is the case.
     
    #3
  4. rrubberr

    rrubberr New Member

    Joined:
    Friday
    Messages:
    6
    Likes Received:
    0
    I got a 1TB PCIe based NVME drive yesterday, and installed it on a sketchy third-party add in card yesterday only to find it didn't boot, as well. The BIOS would not detect the Windows boot manager.

    Similarly, I didn't want to modify my BIOS, but what worked for me was using a Duet/ReFind boot USB, and setting that as the first boot option.

    You can find guides to make such a USB quite easily, just remember to copy the NVME driver into the proper folder before trying to boot or it will not detect your drive.

    I had first tried to use Clover, as many guides suggest, but this didn't work for me, as Clover got stuck on "scanning entries" and refused to start.
     
    #4
  5. T_Minus

    T_Minus Moderator

    Joined:
    Feb 15, 2015
    Messages:
    6,603
    Likes Received:
    1,374
    All, @jfharper hasn't been back since the day after he made this post. 1 Post & gone.

    Might want to start a new thread with your own questions \ concerns.
     
    #5
Similar Threads: Supermicro X9DRX
Forum Title Date
Processors and Motherboards Supermicro X9DRX+-F and multi-GPU, PCIe power concerns, risers, etc. Dec 12, 2018
Processors and Motherboards Supermicro X9DRX-F, no post no beep no VGA Aug 22, 2017
Processors and Motherboards Supermicro X9DRI-LN4F+ Sound Card Incompatibility Friday at 7:53 AM
Processors and Motherboards Supermicro C2758 vs C3758 SoC's and boards May 14, 2019
Processors and Motherboards Supermicro FatTwins: AOC Cards Apr 22, 2019

Share This Page