Supermicro X9DRI-LN4F+ Sound Card Incompatibility

rrubberr

New Member
May 17, 2019
6
0
1
Sorry if this is the wrong category to file this in, but it is my first time posting and the issue seems closely related to the motherboard!

I have recently decided to convert from an aging Z800 workstation to a Supermicro server system with newer components. While transferring components, I discovered that the Soundblaster Z sound card, which has always worked perfectly in the Z800 (and still does), is not recognized by the X9DRI-LN4F+under Windows 7 or Windows 10.

I place the Soundblaster card into the system, and its LEDs turn on as they should (showing it is powered), but the card is never recognized in the device manager. I have tried multiple slots as a troubleshooting step, and I can confirm all of the PCIe slots are functional (a USB 3.0 add-in card works in any slot).

This wouldn't be much of an issue, but the motherboard has no on-board audio.

Has anyone had a similar issue with the board recognizing cards? Does anyone have good experiences with a different sound card in this system?

Thanks for the help!
 

bzaras

New Member
Apr 15, 2019
15
0
1
Poland, Cieszyn
I use usb sound card / usb microphone - works pretty well both in linux and in windows. Maybe you can manipulate bios settings and lower the slot speed to 2.0 ? do you have 2 cpus? if no only lower half of the slots works
 

rrubberr

New Member
May 17, 2019
6
0
1
I use usb sound card / usb microphone - works pretty well both in linux and in windows. Maybe you can manipulate bios settings and lower the slot speed to 2.0 ? do you have 2 cpus? if no only lower half of the slots works
Yes, I have dual 2690s and thus all the PCIe slots are functional. I've tried setting the speed to 2.0 in the Bios, to no effect. I've also tried changing some ASPM settings, also to no effect.

I would prefer to have an internal solution to a USB solution.
 

bzaras

New Member
Apr 15, 2019
15
0
1
Poland, Cieszyn
did you tried setting oprom to legacy for this slot, and manipulating bifurcation settings?
i assume you have latest bios already?

unfortunately i dont have any pcie soundcard handy to test :(
 

rrubberr

New Member
May 17, 2019
6
0
1
did you tried setting oprom to legacy for this slot, and manipulating bifurcation settings?
i assume you have latest bios already?

unfortunately i dont have any pcie soundcard handy to test :(
I have not tried setting the oprom settings for the slot, though I previously used the system in "Legacy Oprom Only" mode which I assume would accomplish the same thing, and that didn't work either. I will try this solution once I get home!

I updated to the latest 2018 v3.3 Bios last night and that didn't change anything.