SuperMicro Fan Speed Won't Slow

T_Minus

Build. Break. Fix. Repeat
Feb 15, 2015
7,007
1,569
113
CA
So it looks like the "SUPER" (100%) Fan speed is triggered when a fan 'disconnects' from the motherboard and SM motherboard freaks out and runs all fans at 100%.

The problem is.

- IPMI Fan Mode change then change back doesn't slow them down
- Rebooting doesn't help (YIKES!)
- You have to actually UNPLUG the cord from the wall, and plug it back in, and then boot.

This is a huge problem as obviously not everyone has power port control but may have IPMI to solve/fix these types of issues.

We'll see what the SM Techs say, I've updated them with this further information.
 

britinpdx

Active Member
Feb 8, 2013
354
157
43
Portland OR
Isn't that Standard Operating Procedure with the Supermicro boards ? (BMC sees a fan failure and failsafe mode is to set all others to 100%)

I presume the reboot doesn't help because it doesn't reset the BMC, which the power cycle does ?

IPMIview has some options you may want to try. On the "IPM Device" tab there are options to reset the BMC as well as select different fan modes. From the docs ...

BMC Cold Reset (for the Administrator only)
Clicking the Cold Reset button allows you to reset the BMC. After confirming the reset of the BMC,
the session will be terminated immediately. The user has to close this session manually. This feature
is rarely used. It is only used for an event when you suspect a system malfunction for example.

Fan Speed Mode
Select the desired fan speed mode and click Update. Note that available speed options vary.
 
  • Like
Reactions: T_Minus

PigLover

Moderator
Jan 26, 2011
2,964
1,271
113
It is standard and expected behavior. The BMC characterizes the hardware when power is applied and if something it thinks is there stops working it goes into a protective mode (full fans, etc).

When you power cycle or reset the MB you are not power cycling the BMC. It runs on the ATX standby power lead and only resets when AC power is fully removed or via a BMC reset command.
 
  • Like
Reactions: T_Minus

Patrick

Administrator
Staff member
Dec 21, 2010
11,908
4,871
113
I think I had a HP or Lenovo server do this also. Fairly common. I think you can also reboot the BMC as @PigLover mentioned.
 

T_Minus

Build. Break. Fix. Repeat
Feb 15, 2015
7,007
1,569
113
CA
Weird that SM wouldn't just come out and say "REBOOT THE BMC" in IPMI.

They had me do as I did which was change fan modes, then change them back. This works when it's not in current state of 'overheat' until unplugged.

I'll try to reboot the BMC in IPMI, and post results.
 

T_Minus

Build. Break. Fix. Repeat
Feb 15, 2015
7,007
1,569
113
CA
Isn't that Standard Operating Procedure with the Supermicro boards ? (BMC sees a fan failure and failsafe mode is to set all others to 100%)

I presume the reboot doesn't help because it doesn't reset the BMC, which the power cycle does ?

IPMIview has some options you may want to try. On the "IPM Device" tab there are options to reset the BMC as well as select different fan modes. From the docs ...

BMC Cold Reset (for the Administrator only)
Clicking the Cold Reset button allows you to reset the BMC. After confirming the reset of the BMC,
the session will be terminated immediately. The user has to close this session manually. This feature
is rarely used. It is only used for an event when you suspect a system malfunction for example.

Fan Speed Mode
Select the desired fan speed mode and click Update. Note that available speed options vary.
This was it, but in my motherboard the instructions weren't the same as you said... must just be different IPMI versions.

Mine was called "Maintenance" and "Unit Reset" to reset IPMI it says.


Also, now that my fans can be played with loud and quiet... It would appear SM has a minimum RPM for fans... anyone else notice this?
 

scobar

Member
Nov 24, 2013
100
10
18
I had this on an Intel board. Spent a lot of time combing docs and such with no luck. Posted a thread here and then someone pointed out the frusdr util which was packed with the firmware. This sets the fan/chassis info. Did this, been quiet since. The board was setup to run with redundant fans which i did not have. Board freaked and went to 100%. Dunno if this is your case or not...
 

T_Minus

Build. Break. Fix. Repeat
Feb 15, 2015
7,007
1,569
113
CA
SM sent me a new firmware I just haven't had time to get this out and try.
 

HorizonXP

Member
May 23, 2016
74
2
8
35
Resurrecting this old thread. My X9DRD-iF isn't allowing me to change my fan speeds. This morning, the fans were running at normal speeds, without issue. Now, after some fiddling around to try to debug a new board, this old board is now stuck with the 1U fans at 14k RPM. Changing fan mode via IPMI and thresholds via ipmitool doesn't seem to affect the current operating fan speed.

Any help?
 

HorizonXP

Member
May 23, 2016
74
2
8
35
I've done that a number of times. Even did a complete shutdown and power plug pull. I tried switching fan headers around, and that didn't change the behaviour. No matter what Fan Mode I choose in the IPMI, the fans stay at the same speed. I even tried upgrading the IPMI to the latest version.

I must be missing something here, because clearly this worked properly earlier today before I started mucking around with it.





Reset the BMC. Maintenance -> Unit Reset
 

T_Minus

Build. Break. Fix. Repeat
Feb 15, 2015
7,007
1,569
113
CA
If you updated the firmware it will reset any new fan limits set.
 

HorizonXP

Member
May 23, 2016
74
2
8
35
So how do I set the fan limits back to their old values?

I don't mind if the fans spin up to 14k RPM when the CPUs are under load. But right now, they're spinning even when the CPUs are idle.

If you updated the firmware it will reset any new fan limits set.
 

rsadix

New Member
Sep 12, 2017
1
0
1
50
So how do I set the fan limits back to their old values?

I don't mind if the fans spin up to 14k RPM when the CPUs are under load. But right now, they're spinning even when the CPUs are idle.
You probably don't need to set the limits back to their old values, as changing them requires some effort (see below). Check to see that the board isn't changing the Fan Mode to Full Speed. If a temp issue or fan issue is detected by the board, it will switch to Full Speed. If you change the Fan Speed via command utility of IPMIView and the board believes something is amiss, it will change the Fan Speed back to Full Speed. You can go back and forth with the board changing the setting every few seconds only to have the board change it back to Full Speed. If you make any Fan setting changes that would potentially fix the issue, you must restart the BMC, else the board will continually switch back to Full Speed even if the new settings are correct. Fortunately you don't have to restart the server, power down or unplug from A/C, just reset the BMC.

I had similar issues with my Supermicro - X9SRL-F unRaid build in a Consumer Phanteks Enthoo Pro case with a built in PWM hub fan controller. On initial boot using a Noctua NF-A9 PWM Fan on the CPU cooler directly connected to the board (fan 2) and the built in low RPM case fans connected to the PWM hub connected to the board (fan 1), the fans would surge up and down until after a few minutes they settled in at a lower RPM.

Following this advice on the lime-tech/unraid forums
NOTE:

When plugging any fan other than a SuperMicro fan into a SuperMicro motherboard, you need to adjust the IPMI fan thresholds, otherwise the board will detect the fan as spinning too slow, and it will compensate by spinning all of the other fans up to full speed. You can fix this with the IPMITOOL or IPMIUTIL.​

I began tinkering with the thresholds for these much lower speed fans to try and resolve the surging up and down on bootup.

Although SMC provides several tools including IPMIView and command line tools like SCMPITool and IPMICFG tools for different OS's, I couldn't figure out how to set the new thresholds with those tools. I used the sourceforge ipmiutil tool to set the thresholds using the following command:

ipmiutil.exe sensor -N *IP address of IPMI interface* -U *Username* -P *Password* -n *snum* -l *lower threshold* -h *upper threshold*​

The default values appear to be 0 and 19050. Although I've noticed rounding when making small changes, so the defaults may be 0 and 19k.

To change fan thresholds you identify the SNum of the fan port on the board and set each one individually.
To find the SNum of the fans (add the -q switch for the current thresholds)
ipmiutil.exe sensor -N <IP address of IPMI interface> -U <username> -P <password> -c -g fan
OR using SMCIPMITool in Shell mode: SMCIPMITool.exe <IP> <username> <password> shell
>ipmi sensor --full | FAN​

After setting more appropriate thresholds for the fans I was using, I must have set the lower thresholds too high and noticed all fans quickly spun up to max speed. Checking the Fan Mode it was set to Full Speed. Changing it to Standard only lasted a few seconds and then checking it again it was at Full Speed. I continually lowered the lower threshold until it stopped doing that and eventually decided to set the lower threshold to zero. While setting the thresholds may have some effect on fan speeds, I believe that they serve more to alert the board when fan speeds are out of alignment. If too high - an alarm, which is nice, if too low - panic and ramp all fans to full speed. In my case I found that setting (or leaving) the lower threshold at zero worked best. I thought that setting the the lower threshold would help keep a minimum fan speed but it appears to only trigger an alarm state.