Quanta LB6M (10GbE) -- Discussion

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

mb300sd

Active Member
Aug 1, 2016
204
80
28
33
Does anyone have an extra set of the recessed rack ears they'd be willing to sell/trade?
 

DASHIP

New Member
May 4, 2016
15
0
1
54
actually just found stuff under configure# set igmp
Happy day!
So I am having trouble with multicast requirements for VMWare vSAN. Apparently, multicast is a requirement to make that work, but it is an option which my particular switch doesn't have. If you do a SHOW TECH-SUPPORT command, look at the "Additional Packages" section. Other options are supposedly FASTPATH QOS, FASTPATH Multicast, FASTPATH IPv6, FASTPATH IPv6 Management, FASTPATH Wireless, FASTPATH Stacking, FASTPATH Metro. I only have FASTPATH Routing and FASTPATH QoS.

Is there a way I can get the Multicast feature I need? Would updating the firmware version change anything (I have .14)? I have heard there is a command "license advanced <key>" to upgrade the features, but I haven't seen anywhere you could even buy a key.

Also, I am wondering if not having some of the FASTPATH feature sets are why some members have found that certain commands don't seem to work?
 

dwright1542

Active Member
Dec 26, 2015
377
73
28
50
Ok I'm being an ass here, and can't see where I'm going wrong.
trying to connect the LB6M to a Dell 5424 thru a 1G copper port, and have VLAN 2 talk to VLAN 20
The Dell 5424 has an untagged VLAN 2 with iscsi on it
The LB6m has a tagged VLAN 20 with iscsi on it.
All jumbo frames (ok jumbo on dell, mtu 9216 on LB6M)
I have a cable connecting both ports (16 on 5424, 28 on LB6M)

Here's my config on the LB6M for that port:

interface 0/28
mtu 9216
vlan pvid 20
vlan participation exclude 1
vlan participation include 20



Here's the config on the 5424:

interface range ethernet g(1-16)
flowcontrol on
exit
port jumbo-frame
vlan database
vlan 2-3
exit
interface range ethernet g(1-16)
switchport access vlan 2

----------------------------------------------
Nothing can ping from one side to the other
However, if I plug a laptop in, set jumbo's, and plug into either of those ports, I can ping just fine to anything else on that switch. Something between the switches just isn't talking.

What did I miss?
 

DASHIP

New Member
May 4, 2016
15
0
1
54
So I am having trouble with multicast requirements for VMWare vSAN. Apparently, multicast is a requirement to make that work, but it is an option which my particular switch doesn't have. If you do a SHOW TECH-SUPPORT command, look at the "Additional Packages" section. Other options are supposedly FASTPATH QOS, FASTPATH Multicast, FASTPATH IPv6, FASTPATH IPv6 Management, FASTPATH Wireless, FASTPATH Stacking, FASTPATH Metro. I only have FASTPATH Routing and FASTPATH QoS.

Is there a way I can get the Multicast feature I need? Would updating the firmware version change anything (I have .14)? I have heard there is a command "license advanced <key>" to upgrade the features, but I haven't seen anywhere you could even buy a key.

Also, I am wondering if not having some of the FASTPATH feature sets are why some members have found that certain commands don't seem to work?
I have learned that Broadcom offered two different versions of the FASTPATH software, FASTPATH-SMB and FASTPATH-ENT. Some documents also refer to the "Advanced" feature set. I am not sure if that means FASTPATH-ENT or not. So far, I have not seen any keys or information on how to upgrade from -SMB to -ENT, or to add individual features. It seems like you get one or the other. Did all LB6M switches come with the same FASTPATH feature set, or are there different switch versions?

For vSAN I really just need Multicast support. Has anyone besides me tried to set up vSAN on one of these switches? Could upgrading the firmware help my cause?
 

BLinux

cat lover server enthusiast
Jul 7, 2016
2,663
1,078
113
artofserver.com
I finally put my LB6M in production this weekend. I changed the 3 fans on the back of the unit with the Delta AFB0412LB fans. The same fans can be used in the power supply as well. Very quiet at 18.5 dBA.

Some of the specs:
Size : 40mmX40mmX15mm
RPM: 5000 RPM
Air Flow: 6.5 CFM
Noise Level: 18.5 dBA

https://www.amazon.com/gp/product/B004VNBQ28/ref=oh_aui_detailpage_o05_s00?ie=UTF8&psc=1

Because these are 3 pin and not 4 pin, I can no longer get the temperature and fan speed using the "show environment" command.

Hopefully this will be helpful to others because I have gotten a lot of support on this forum.
how is the switch doing? just wondering if those quiet fans provide enough cooling?
 

PGlover

Active Member
Nov 8, 2014
499
64
28
57
This is almost exactly what I've got being done, except with a number more vlans.

The L2 Layout is the below:





I've got a number of devices off the LB6M

NAS1 - LACP with 2x DACs (FS.com 30awg DAC - Intel vedor code) to the 10GB SFP Nic on a X10SDV-4C-7TP4F
Hyp1 - LACP with 2x DACs (FS.com 30awg DAC - Intel vendor code) to a Intel x520-DA2 on a X10SDV-TLN4F
CCR - LACP with 2x DACs (FS.com 30awg DAC - Generic Vendor code) to a Mikrotik CCR1036-8g-2s+ <-- this is routing between the VLANs
CRSCAB - Static LAG with 2x DAC (FS.com 30awg DAC - Generic Vednor code) to a Mikrotik CRS226-24G-2S+RM
CRSOffice - Static LAG with 2x SFP+ (FS.com 10g 850nm SR (300m) - Generic vendor code) to a Mikrotik CRS226-24G-2S+RM
TPSW1 - Single Ethernet to TPLink SG2210P

My Config on the LB6M is as follows
Code:
vlan database
vlan 2,4,6,8,10,12,14,16,18,20,22,24,26,28,30,32,34,36,38,40,42,44,46,48
vlan 50,52,54,56,58,60,1000-1005,1010,3000-3001,3996-4000
vlan name 2 "Name Removed"
!.....
!..... Vlan names removed
!.....
vlan name 4000 "Name Removed"
exit
configure
interface 0/1
no auto-negotiate
addport 1/1
exit
interface 0/2
no auto-negotiate
addport 1/1
exit
interface 0/3
no auto-negotiate
addport 1/2
exit
interface 0/4
no auto-negotiate
addport 1/2
exit
interface 0/5
no auto-negotiate
addport 1/3
exit
interface 0/6
no auto-negotiate
addport 1/3
exit
interface 0/7
no auto-negotiate
addport 1/4
exit
interface 0/8
no auto-negotiate
addport 1/4
exit
interface 0/9
no auto-negotiate
addport 1/5
exit
interface 0/10
no auto-negotiate
addport 1/5
exit
!
interface 0/1
description 'Hyp1-vmnic0'
snmp-server enable traps violation
exit

interface 0/2
description 'Hyp1-vmnic1'
snmp-server enable traps violation
exit

interface 0/3
description 'NAS-ix0'
snmp-server enable traps violation
exit

interface 0/4
description 'NAS-ix1'
snmp-server enable traps violation
exit

interface 0/5
description 'CCR-SFP1'
snmp-server enable traps violation
exit

interface 0/6
description 'CCR-SFP2'
snmp-server enable traps violation
exit

interface 0/7
description 'CRSOffice-SFP1'
snmp-server enable traps violation
exit

interface 0/8
description 'CRSOffice-SFP2'
snmp-server enable traps violation
exit

interface 0/9
description 'CRSCAB-SFP1'
snmp-server enable traps violation
exit

interface 0/10
description 'CRSCAB-SFP2'
snmp-server enable traps violation
exit

interface 0/28
description 'TPLSW1'
vlan participation include 8,12,18,20,22,24,28
vlan tagging 8,12,18,20,22,24,28
snmp-server enable traps violation
exit

interface 1/1
description 'Hyp1-lag0'
no port-channel static
vlan participation include 14,3999
vlan tagging 14,3999
snmp-server enable traps violation
exit

interface 1/2
description 'NAS-lagg0'
no port-channel static
vlan pvid 3999
vlan acceptframe admituntaggedonly
vlan participation include 3999
snmp-server enable traps violation
exit

interface 1/3
description 'LACP-CCR'
no port-channel static
vlan participation include 2,4,6,8,10,12,14,16,18,20,22,24,26,28,60,1000-1005
vlan participation include 1010,3000-3001,3997-3998
vlan tagging 2,4,6,8,10,12,14,16,18,20,22,24,26,28,60,1000-1005,1010,3000-3001
vlan tagging 3997-3998
snmp-server enable traps violation
exit

interface 1/4
description 'LACP-CRSOffice'
vlan participation include 8,12,18,26,60,3997-3998
vlan tagging 8,12,18,26,60,3997-3998
snmp-server enable traps violation
exit

interface 1/5
description 'LACP-CRSCab'
vlan participation exclude 60,3996-4000
vlan participation include 2,4,6,8,10,12,14,16,18,20,22,24,26,28,1000-1005
vlan participation include 1010,3000-3001
vlan tagging 2,4,6,8,10,12,14,16,18,20,22,24,26,28,1000-1005,1010,3000-3001
snmp-server enable traps violation
exit

My CRSes are similar to below

Code:
/interface ethernet
set [ find default-name=sfpplus2 ] master-port=sfp-sfpplus1
/interface vlan
add interface=sfp-sfpplus1 name=MGMT-Networking vlan-id=##############
/interface ethernet
set [ find default-name=ether2 ] master-port=sfp-sfpplus1
set [ find default-name=ether3 ]  disabled=yes master-port=sfp-sfpplus1
set [ find default-name=ether4 ] master-port=sfp-sfpplus1
set [ find default-name=ether5 ] master-port=sfp-sfpplus1
set [ find default-name=ether6 ] master-port=sfp-sfpplus1
set [ find default-name=ether7 ] master-port=sfp-sfpplus1
set [ find default-name=ether22 ] master-port=sfp-sfpplus1
set [ find default-name=ether23 ] master-port=sfp-sfpplus1
set [ find default-name=ether24 ] master-port=sfp-sfpplus1
set [ find default-name=sfpplus2] master-port=sfp-sfplus1
/interface ethernet switch trunk
add member-ports=sfp-sfpplus1,sfpplus2 name=trunk1
/interface ethernet switch egress-vlan-tag
add tagged-ports=trunk1,switch1-cpu vlan-id=######
add tagged-ports=trunk1 vlan-id=#####
add tagged-ports=trunk1 vlan-id=#####
add tagged-ports=trunk1 vlan-id=#####
add tagged-ports=trunk1,ether3 vlan-id=#####
add tagged-ports=trunk1 vlan-id=####
add tagged-ports=trunk1 vlan-id=####
/interface ethernet switch ingress-vlan-translation
add new-customer-vid=#### ports=ether23 sa-learning=no
add new-customer-vid=#### ports=ether22 sa-learning=no
add new-customer-vid=#### ports=ether2 sa-learning=no
add new-customer-vid=##### ports=ether4 sa-learning=no
add new-customer-vid=##### ports=ether7 sa-learning=no
/interface ethernet switch vlan
add ports=trunk1,switch1-cpu vlan-id=#####
add ports=trunk1,ether23 vlan-id=#####
add ports=trunk1,ether22 vlan-id=#####
add ports=trunk1,ether2 vlan-id=#####
add ports=trunk1,ether3 vlan-id=######
add ports=trunk1,ether4,ether7 vlan-id=#####
add ports=trunk1,ether4 vlan-id=#####
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=MGMT-Networking
The CCR is as follows

Code:
/interface bonding
add comment="Uplink to LB6M Switch" lacp-rate=1sec mode=802.3ad name=bonded_lb6m slaves=sfp-sfpplus1,sfp-sfpplus2 transmit-hash-policy=layer-2-and-3
[whmcr]

Can you provide your LB6M configuration for the NAS/SAN server and the Hypervisor server. I am having a hard time with my LB6M setup. For some reason the Hypervisor server is not seeing the SAN server. Here is my configuration for the SAN and Hypervisor server. Not sure if it is correct.

Hypervisor Server:
vlan database
vlan 10,20,2000
vlan name 10 "Hypervisors_Servers"
vlan name 20 "NAS_SAN_Storage"
vlan name 2000 "Transit_Network"
!
interface 1/4
description 'Static LAG interface to Hypervisor Server'
port-channel load-balance 6
vlan participation include 10,20
vlan tagging 10,20
snmp-server enable traps violation
!
interface 0/7
no auto-negotiate
addport 1/4
exit
interface 0/8
no auto-negotiate
addport 1/4
exit
interface 0/9
no auto-negotiate
addport 1/4
exit
interface 0/10
no auto-negotiate
addport 1/4
exit
!
interface 0/7
description 'Hypervisor Server Ethernet nic0'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
snmp-server enable traps violation
exit
interface 0/8
description 'Hypervisor Server Ethernet nic1'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
snmp-server enable traps violation
exit
interface 0/9
description 'Hypervisor Server Ethernet nic2'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
snmp-server enable traps violation
exit
interface 0/10
description 'Hypervisor Server Ethernet nic3'
vlan pvid 10
vlan participation exclude 1
vlan participation include 10
snmp-server enable traps violation

SAN Server:
vlan database
vlan 10,20,2000
vlan name 10 "Hypervisors_Servers"
vlan name 20 "NAS_SAN_Storage"
vlan name 2000 "Transit_Network"
!
interface 1/3
description 'A LACP interface to SAN Server'
no port-channel static
vlan pvid 20
vlan participation include 20
!
interface 0/13
no auto-negotiate
addport 1/3
exit
interface 0/14
no auto-negotiate
addport 1/3
exit
interface 0/15
no auto-negotiate
addport 1/3
exit
interface 0/16
no auto-negotiate
addport 1/3
exit
!
interface 0/13
description 'SAN Server Ethernet nic0'
vlan pvid 20
vlan participation exclude 1
vlan participation include 20
snmp-server enable traps violation
exit
interface 0/14
description 'SAN Server Ethernet nic1'
vlan pvid 20
vlan participation exclude 1
vlan participation include 20
snmp-server enable traps violation
exit
interface 0/15
description 'SAN Server Ethernet nic2'
vlan pvid 20
vlan participation exclude 1
vlan participation include 20
snmp-server enable traps violation
exit
interface 0/16
description 'SAN Server Ethernet nic3'
vlan pvid 20
vlan participation exclude 1
vlan participation include 20
snmp-server enable traps violation
exit

Additionally can you provide a screenshot of your Hypervisor setup as well.

Thanks.
 

PGlover

Active Member
Nov 8, 2014
499
64
28
57
On the ESXI host, I am using the following command to try to ping the SAN Server and I get no reply.

[root@home-esx-01:~] ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2): 56 data bytes

--- 10.0.0.2 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
 

PGlover

Active Member
Nov 8, 2014
499
64
28
57
Same results.. For some reason I am not able to ping the SAN server at the IP address of 10.0.0.2.

[root@home-esx-01:~] vmkping 10.0.0.2
PING 10.0.0.2 (10.0.0.2): 56 data bytes

--- 10.0.0.2 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
 

PGlover

Active Member
Nov 8, 2014
499
64
28
57
Well I now can ping my SAN Server. I changed the Vlan assignment on the VMWare host from vlan 20 to Vlan All.

Capture_100.PNG

I still feel that the my VMWare setup is not correct.
 

serverworks

New Member
Aug 5, 2015
19
0
1
49
I have installed 4 noctua fan speed reducers in the power supplies and it seems that they were the more annoying of the fans in my lb6m. I will try to find the section of the discussion about reading temperature and consider changing the fans in the hot swap fan module. But as i said it seems much less annoying with the psu fans slowed down (lower tone)
 

jmonteiro

New Member
Sep 15, 2016
2
0
1
53
Does anyone know if the RJ45 ports on the LB6M are 10Gbps ports (10gbase-T) or just 1Gbps?

I actually need a couple of RJ45 10gbase-T ports on my switch.
 

Blinky 42

Active Member
Aug 6, 2015
615
232
43
48
PA, USA
Unfortunately, ports 25-28 are 1G copper. The other 2 are management ethernet, and then the serial console off by itself.
 

Drewy

Active Member
Apr 23, 2016
208
56
28
54
Just had my lb6m crash. Completely dead. Green psu power light on and some fans running slowly. All front lights out and not responding to anything. Pulled the power cord, reconnected and it's come back up.
Anyone seen similar or have clue how to access any logging?

Cheers
 

NetWise

Active Member
Jun 29, 2012
596
133
43
Edmonton, AB, Canada
Did you have syslog or snmp traps configured BEFORE the issue? If not, likely you did not ask for the logs to exist you're hoping to read...


Sent from my iPhone using Tapatalk