Plextor M6e PCI Express SSD & Other SSDs

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

maxermaxer

Active Member
Oct 28, 2016
289
48
28
49
Hello! Need some advice and help here.

My workstation has been using Plextor M6e PCIE SSD without any issue. Recently I have got one Intel S3710 DC SSD and would like to add it to the system. However when I boot the machine it hangs after the BIOS (before seeing the Windows logo). The underscore sign keeps blinking.

I changed the SATA controller setting in BIOS from ACHI to IDE then I can boot into Windows without any issue. I still want to use ACHI since it is better for the SSD.

Can anyone advise what happens and how can I change it back to ACHI and still boot the machine fine with 2 SSDs connected.

Thanks!
 

Patrick

Administrator
Staff member
Dec 21, 2010
12,513
5,804
113
What is your boot order? Usually that is the issue.
 

maxermaxer

Active Member
Oct 28, 2016
289
48
28
49
Can you change the boot priority/order in the BIOS/EFI so that the PCIe card is earlier than your SATA device?
Here is the screen setting up the boot order. Plextor PCIE SSD is the No.1 boot drive. However I can't see Intel SSD showing up here.


Sent from my iPhone using Tapatalk
 

j_h_o

Active Member
Apr 21, 2015
644
180
43
California, US
Your current 1st entry, Hard Drive: Plextor entry is the compatible BIOS boot entry. But this might not be what you intend.

What version of Windows? Do you have an UEFI installation of Windows 10? Assuming Yes, try moving the UEFI entry of your Plextor drive up to the top.
 

Patrick

Administrator
Staff member
Dec 21, 2010
12,513
5,804
113
To see the Intel SSD you would scroll down to set hard drive priorities on that screen.

Is that with IDE where it works or where you are getting the blinking cursor?
 

maxermaxer

Active Member
Oct 28, 2016
289
48
28
49
Your current 1st entry, Hard Drive: Plextor entry is the compatible BIOS boot entry. But this might not be what you intend.

What version of Windows? Do you have an UEFI installation of Windows 10? Assuming Yes, try moving the UEFI entry of your Plextor drive up to the top.
I use Windows 2016 server. I don't remember if I installed Windows with UEFI installation. I can try removing the UEFI entry. Thanks!


Sent from my iPhone using Tapatalk
 

maxermaxer

Active Member
Oct 28, 2016
289
48
28
49
To see the Intel SSD you would scroll down to set hard drive priorities on that screen.

Is that with IDE where it works or where you are getting the blinking cursor?
It works with IDE mode. Changing to ACHI is the problem.


Sent from my iPhone using Tapatalk