Picked up an Emulex oce11102-nx 10G adapter, need help with firmware

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Jeff Robertson

Active Member
Oct 18, 2016
429
115
43
Chico, CA
I managed to pick up a brand new emulex 2 port 10Gb fiber adapter on ebay the other day. I have just over zero knowledge about this brand but it looks like it will work in a qnap so I'm going to give it a try. I would like to flash it to the latest firmware in windows before I put it in the nas, can anyone direct me to the download page and possible the proper method for updating? I've been googling but this looks like an older card so info is thin. Here is an image with the model number:

emulex.JPG

For all I know 4.6.142.10 is the latest firmware, when searching I can't find the specific model on broadcoms site. A link to the latest windows drive would also be awesome, win10 seemed to pick it up without a problem but I always prefer to use the latest if possible.

Thanks!
 

azev

Well-Known Member
Jan 18, 2013
767
251
63
You dont have to get file specifically for the part#, just fine firmware for OCE11102 in iso format and boot the pc with the card it it using the ISO.
A few click for acknowledgement and you're finished.
 

Jeff Robertson

Active Member
Oct 18, 2016
429
115
43
Chico, CA
And... updated:

emulex.JPG

I was only able to find a windows driver from 2014 so I've left it with the stock microsoft driver. Are there newer drivers out there or should I just use the built in one while it's in the pc?

Thanks!
 

azev

Well-Known Member
Jan 18, 2013
767
251
63
I'd say just test performance using those drivers and see which one netted better performance and functionality.
 

shpitz461

Member
Sep 29, 2017
108
16
18
50
Can you share a link to the .iso? Can't find it anywhere...
Mine shows as OCe11102-NM in Ubuntu 20.04 server.
During post it shows Bios v4.0.360.3.
Thanks
 

Freebsd1976

Active Member
Feb 23, 2018
378
73
28
  • Like
Reactions: klui and shpitz461

shpitz461

Member
Sep 29, 2017
108
16
18
50
You da man!
Will give it a shot tomorrow.
This will make the card 'HP' branded? I have no idea what brand my card is... Bought it looooooooooong time ago.
Also, I ordered a Dell OCE14102-U1-D, can I 'crossflash' to HP? Or do I need specific Dell firmware?
Is there any way to 'unlock' the cards so they are not brand-specific for flashing?
Thanks!
 

Freebsd1976

Active Member
Feb 23, 2018
378
73
28
You da man!
Will give it a shot tomorrow.
This will make the card 'HP' branded? I have no idea what brand my card is... Bought it looooooooooong time ago.
Also, I ordered a Dell OCE14102-U1-D, can I 'crossflash' to HP? Or do I need specific Dell firmware?
Is there any way to 'unlock' the cards so they are not brand-specific for flashing?
Thanks!
should be fine. if you do care about this, flash 11.4 from broadcom
OCe11000-series Firmware and Boot Code (broadcom.com)
 
  • Like
Reactions: shpitz461

shpitz461

Member
Sep 29, 2017
108
16
18
50
I can't seem to get it to work.
I initially burned the iso on a USB stick using Balena Etcher, it said iso is not bootable.
I then flashed it with rufus and it booted, but getting the following screen:
emulex_boot.png
There is no keyboard access, I can't type anything...
Any ideas?
 

shpitz461

Member
Sep 29, 2017
108
16
18
50
And if I boot into Ubuntu 22.04, this is what I see on the USB stick:
emulex_iso_content.jpg
I don't see any tools in the folders, just linux system stuff...
The UFI folder contains the firmware only, one for OCe11 and one for OCe14.
 

shpitz461

Member
Sep 29, 2017
108
16
18
50
I can't find shit on Broadcom's site, all it find is documents, not utilities, their site is hot-garbage...
I tried booting up the USB on another PC with UEFI, all I get is the screen gets stuck on this:
emulex_uefi.png
If I boot in legacy I always get the cdrom not found error show in prior post.
Would you have links to the utilities you mentioned by any chance?
Thanks
 

shpitz461

Member
Sep 29, 2017
108
16
18
50
So after looking and looking I finally was able to find the GUI installer for OneCommand Manager.
I ran it but got an error about a dll missing, turns out it was hbaapi.dll.
I downloaded a copy from Hbaapi.dll Download: Fix DLL Missing or Not Found Error.
It finally ran, but it cannot find anything:
onecommand manager.png
The card is up and running.
Does it matter I'm running Windows 11? The tool says it's for Win 8.x and 10.
I ordered a blank CD, going to try and burn the iso to a disc and see if that helps. Haven't burned a disc in 15 years...
 

Freebsd1976

Active Member
Feb 23, 2018
378
73
28
So after looking and looking I finally was able to find the GUI installer for OneCommand Manager.
I ran it but got an error about a dll missing, turns out it was hbaapi.dll.
I downloaded a copy from Hbaapi.dll Download: Fix DLL Missing or Not Found Error.
It finally ran, but it cannot find anything:
View attachment 27984
The card is up and running.
Does it matter I'm running Windows 11? The tool says it's for Win 8.x and 10.
I ordered a blank CD, going to try and burn the iso to a disc and see if that helps. Haven't burned a disc in 15 years...
wrong version , download this
brcmOneInstall-Setup-11.4.1173.0.exe
 

shpitz461

Member
Sep 29, 2017
108
16
18
50
So I've wasted a CD-R, won't boot in UEFI (freezes), and in regular legacy boot it complains it can't find the CDROM.
Would you have a link to brcmOneInstall-Setup-11.4.1173.0.exe or can upload it somewhere?
Thanks