PERC H700 - Immediate Physical Disk Failure Upon VD Creation

Discussion in 'RAID Controllers and Host Bus Adapters' started by routenull0, Oct 9, 2017.

  1. routenull0

    routenull0 New Member

    Joined:
    Dec 28, 2016
    Messages:
    11
    Likes Received:
    2
    I'm having a rather odd issue that I cannot seem to find a resolution to.

    I have a Dell PERC H700 RAID controller installed on my Intel S2600CP board, connected to the matching Intel 8 bay cage.

    The PERC bios sees all 8 physical disks just fine and I've cleared any foreign configurations. The moment I create a VD of any type or combination of drives, right after the warning about initializing, all the disks selected for the VD show up as failed. Reseating them allows them to show back up, but no configuration for the VD remains.

    The PERC controller is running the native Dell BIOS
    PERC Info:
    Package: 12.3.0-0032
    FW Version: 2.30.03-0872
    BIOS: 3.09.00

    Drives:
    HGST 600GB
     
    #1
  2. Terry Kennedy

    Terry Kennedy Well-Known Member

    Joined:
    Jun 25, 2015
    Messages:
    955
    Likes Received:
    422
    That is an ancient version. Latest for the H700 is 12.10.7-0001. I'd give you a link, but Dell has broken their download site in new and exciting ways.
    Are these OEM pulls? Are you sure they are set for 512 byte-sectors?
     
    #2
  3. routenull0

    routenull0 New Member

    Joined:
    Dec 28, 2016
    Messages:
    11
    Likes Received:
    2
    I upgraded the firmware no change but I have a feeling your latter statement is the issue. I put them into another machine with a H710 and upon insertion they came up in a "Blocked" state.

    I'm trying to find a controller with passthrough so I can perform a low-level format and adjust the sector size to see if that fixes the issue.
     
    #3
  4. thenicnet

    thenicnet New Member

    Joined:
    Sep 14, 2018
    Messages:
    2
    Likes Received:
    0
    Hey I know this is kind of a hail mary but did you ever figure this out? I'm running into the exact same scenario and it's driving me nuts!
     
    #4
  5. thenicnet

    thenicnet New Member

    Joined:
    Sep 14, 2018
    Messages:
    2
    Likes Received:
    0
    SOLVED: I did in fact have to connect the drives to a controller that could provide a pass through connection for the drives. I then had to perform a low level format to adjust the sector size to 512 byte-sectors. Thankfully I had the hardware available to do this. I used a boot able version of CENTOS and a tool called sg_format. Worked like a charm. I hope this helps someone else!

    Below is the reddit thread I also posted attempting to fix this issue.
    Help: R710, PERC H700, 10TB Drives, two men and a baby. : homelab
     
    #5
Similar Threads: PERC H700
Forum Title Date
RAID Controllers and Host Bus Adapters DELL PERC H700 not running in Supermicro board Aug 22, 2017
RAID Controllers and Host Bus Adapters Dell PERC H700 adapter Aug 18, 2017
RAID Controllers and Host Bus Adapters Perc H700 (LSI SAS 2108) possible to support Raid-1 and passthrough ? Feb 16, 2017
RAID Controllers and Host Bus Adapters Recovering Drive Configuration on vanilla PERC H700 (LSI 9260-8i) Jul 10, 2016
RAID Controllers and Host Bus Adapters Server crashes when hotswapping drives with Perc H700 Jan 19, 2016

Share This Page