OmniOS 151030 VM (ESXi) with LSI 9400-8i Tri-Mode HBA freezing up

Discussion in 'Solaris, Nexenta, OpenIndiana, and napp-it' started by nezach, Aug 10, 2019.

  1. nezach

    nezach Active Member

    Joined:
    Oct 14, 2012
    Messages:
    182
    Likes Received:
    83
    I setup OmniOS 151030 VM on ESXi v6.7 U2 with LSI 9400-8i HBA passed through to it. Problem is OmniOS occasionally freezes up on me. I think this is related to the HBA, probably driver, because it usually freezes when I start running filebench or fio benchmark and there is really nothing else special about this VM. There are no errors in the logs or the console, it just freezes up and rebooting it is the only thing that works.

    Does anyone else run OmniOS with LSI Tri-Mode adapter?
     
    #1
  2. gea

    gea Well-Known Member

    Joined:
    Dec 31, 2010
    Messages:
    2,264
    Likes Received:
    751
    I have never tried this but I can remember a mail in Illumos-dev or discuss where it was not recommended (or suppported) to use the 9400 with NVMe attached. The 9400 is supported for Sata/SAS only.

    Nvme should be connected directly via pci-e, M.2, U.2 or oculink.
     
    #2
  3. nezach

    nezach Active Member

    Joined:
    Oct 14, 2012
    Messages:
    182
    Likes Received:
    83
    Thanks for the info @gea

    The thing is I am not using NVMe on this build. HBA is connected to BPN-SAS3-826EL1 backplane and I have some SAS2 spinners as well as some SAS3 SSDs connected to the backplane.

    I did some testing with FreeNAS VM and everything is working fine, so I am sure that the issue is not hardware related.
     
    #3
  4. gea

    gea Well-Known Member

    Joined:
    Dec 31, 2010
    Messages:
    2,264
    Likes Received:
    751
    You may ask at Illumos discuss where a driver developer may answer
    Topicbox
     
    #4
Similar Threads: OmniOS 151030
Forum Title Date
Solaris, Nexenta, OpenIndiana, and napp-it Napp-It: Active Directory tab totally blank in 18.12 OmniOS 151030 Jun 2, 2019
Solaris, Nexenta, OpenIndiana, and napp-it Problem upgrading OmniOS r151028 to r151030 May 20, 2019
Solaris, Nexenta, OpenIndiana, and napp-it OmniOS 151030 LTS Mar 30, 2019
Solaris, Nexenta, OpenIndiana, and napp-it intel x540-t2 passthrough to OmniOS 151032 on ESXi 6.7u3 Nov 30, 2019
Solaris, Nexenta, OpenIndiana, and napp-it OmniOS (CE) nvdimm Nov 17, 2019

Share This Page