OmniOS 151028 stable

Discussion in 'Solaris, Nexenta, OpenIndiana, and napp-it' started by gea, Sep 11, 2018.

  1. gea

    gea Well-Known Member

    Joined:
    Dec 31, 2010
    Messages:
    1,857
    Likes Received:
    613
    OmniOS 151028 stable, announced Nov 2018
    omniosorg/omnios-build

    If you want to evaluate the new features ex Bhyve or the other LX zones or ZFS improvements you can install OmniOS bloody 151027. This is the development path to the stable 151028.

    As there is a newer Perl release, you must use or update napp-it to newest 18.01d free, 18.06 or 18.09dev from today. The new releases now support 151027+.
     
    #1
  2. asche

    asche New Member

    Joined:
    Oct 6, 2017
    Messages:
    6
    Likes Received:
    0
    For OmniOS 151027 (bloody): I can't get around the "sudo: PAM account management error: Permission denied " error.

    I note that you, gea, have stated on your napp-it homepage that

    Problems with OmniOS 151027 bloody
    If you get PAM authentication error when starting napp-it, you must reset the password for user napp-it:
    At console as root, run:
    # passwd napp-it

    then reboot

    but it does not work - neither setting an empty password nor a new non-empty one (whether as "su" root via SSH or whether directly logged in as root via console). This is from a fresh install of bloody.
     
    #2
  3. gea

    gea Well-Known Member

    Joined:
    Dec 31, 2010
    Messages:
    1,857
    Likes Received:
    613
    When I installed the bloody, adding a password to user napp-it fixed the problem. The newer SSH implementation seems to be the reason as this does not allow empty passwords (even when the account is disabled like with user napp-it).,

    Have you also added a password to root?
     
    #3
  4. gea

    gea Well-Known Member

    Joined:
    Dec 31, 2010
    Messages:
    1,857
    Likes Received:
    613
    If the permission problem persists, try the following commands

    userdel napp-it
    useradd -s /bin/false napp-it
    passwd napp-it
    rm /tmp/err.log
    /etc/init.d/napp-it restart

    then retry the GUI
     
    #4
  5. asche

    asche New Member

    Joined:
    Oct 6, 2017
    Messages:
    6
    Likes Received:
    0
    Sorry for the late reply gea, I think I might have managed to solve this issue with installing without passwords and setting a user and root password (and napp-it?) from the console (not over SSH).

    In the end I went back to OmniOS stable (...26) however as I could not set up a ZFS pool from my SATA drives from the CLI. CLI set up of the pool worked under OmniOS stable.

    Need to revise my setup once more anyway, so may give bloody another shot.
     
    #5
Similar Threads: OmniOS 151028
Forum Title Date
Solaris, Nexenta, OpenIndiana, and napp-it OmniOS/napp-it self-sign certificate Oct 4, 2018
Solaris, Nexenta, OpenIndiana, and napp-it Solaris (OmniOS) w/ Napp-It ZPool Share Permissions for CIFS [Solved] Sep 17, 2018
Solaris, Nexenta, OpenIndiana, and napp-it OmniOS 151026: Locale issues Aug 31, 2018
Solaris, Nexenta, OpenIndiana, and napp-it Future of OmniOS development? Aug 31, 2018
Solaris, Nexenta, OpenIndiana, and napp-it Trouble installing OmniOS on X11SSH-CTF with NVME M.2 PCIe Drive Aug 27, 2018

Share This Page