NVMe boot with SuperMicro X9DA7 & X9DRi-F

olivierLA75

New Member
Nov 15, 2021
6
0
1
Hello there, is there anyone that was able to make the NVMe work with Supermicro X9DRD-7LN4F and that would have the modified bios in hand? that would be very appreciated. thanks in advance!
 

olivierLA75

New Member
Nov 15, 2021
6
0
1
I forgot to mention, I installed Ubuntu 18.04 onto the drive. I was able to avoid having to use Windows on the server. But I still had to use Windows on a separate box in order to splice the new nvme rom into the original BIOS.


Sent from my iPhone using Tapatalk
Hey, I’m trying to install Ubuntu on an NVMe as well. Do you mean that I should have windows installed first?
 

RolloZ170

Active Member
Apr 24, 2016
913
241
43
54
One question: I got the X9DAi (16 memory slots). Is it possible to have some Nvme Raid?
you can build a software raid in windows with every kind of drive you want.
if you want to boot from a Nvme drive without modifiying the BIOS install windows on a SATA SSD,
then install windows from that drive running Win on the Nvme drive. The Bootloader stays on the SATA SSD, but all
the remaining system ist booted from the Nvme.
 
  • Like
Reactions: SniperTB

SniperTB

New Member
Dec 6, 2021
2
0
1
Modified the BIOS, I have now some "PP: " Drive available. Next step will be installing Windows Server 2019 on that machine.
Tried a lot already, always hangs on the moving dots in the setup preload. Did you face that as well?
 

awedio

Active Member
Feb 24, 2012
561
125
43
Wow, just came back to look at this thread.
Back in 2017, I didn't think anyone else would care about X9 MBs booting off NVMe!

I can see that much smarter people than myself have contributed!
 
  • Haha
Reactions: SniperTB

madLyfe

Member
Jul 18, 2017
48
4
8
41
Just wanted to signal that I applied the nvme bios/uefi patch today on the most recent bios 2.3a for a X9SCL-F board. To my best knowledge the X9SCM and X9SCL share the same bios.
Now happily running a proxmox setup booting from nvme on the X9SCL-F.

I followed the guide from win-raid forum, had to choose the NvmExpressDxe_Small.ffs when inserting after the CSMCore
When installing proxmox all bios settings were set to UEFI only, before running the proxmox installer.
do you have this bios file any longer?
 

Jonnyomega

New Member
Jan 23, 2016
4
0
1
Just want to chime in.


I was able to get this working on my system after a bios update. I hope this helps someone.


X9DRI-F REV 1.11A
AOC-SLG3-2M2.
Boot drive Sata ssd.
Bios set to legacy.
Server 2012.
plugged into CPU 2 Slot 6 x16 - set in bios to 4x4x4x4.
TEST DRIVES - samsung 950 pro 512GB + samsung 970 pro 1TB. ( both drives has w10 installed and are over 50% full)

In bios 3.3 only one drive was showing in the OS.

Updated bios via official SM download to 3.4.
Both drives show up in device manger now.
Samsung magician sees both drives as gen 3 x4 but says they are not supported. (Probably due to the card)

Crystal disk mark ran independently on each drive. (Default 1GB setting)
970 pro – 2980 read – 2722 write
950 pro – 2355 read – 1480 write

I am thinking of doing a simple mirror storage pool so I wanted to test both drives at the same time.

Crystal disk mark ran at the same time both drives. (Testing R/W accessing both)
970 pro – 2922 read – 2721 write
950 pro – 2414 read – 1481 write

Now that this is working in plan to get 2 SN700 4TB drives and set in a simple storage spaces mirror. Simple storage for everything I need.