Need FreeNAS sharing help

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
I have 2 FreeNAS boxes. Box A I can copy files to all day long.

Box B says "Destination folder access denied"

Both boxes are set up exactly the same.

I've read everything I can find on how to set up shares and I'm sure the answer is buried somewhere in them but I can't find it. There are ZERO security concerns. I just want to copy files to the damn box.

If someone can tell me what this message means and how to fix it I would be eternally grateful. :(
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
Got it working. In all my hours of googling and reading, nowhere was there mentioned -

Storage / Pools / Edit Permissions. :mad:
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
Well maybe I should just abandon FreeNAS again. Sharing is just to damned difficult.

FreeNAS box is "BACKUPS". I can access it from Windows just fine but not from a Linux Box. This message pops up instantly. Looks like it isn't even trying to connect to the share.

Anybody know what might be going on?

Screenshot from 2019-07-10 16-58-04.png
 

marcoi

Well-Known Member
Apr 6, 2013
1,398
222
63
Gotha Florida
under sharing tab, what do you have defined? For windows you might have a SMB share (or iscsi), for Linux you would probably need NFS share. I dont think Linux and window would share the same storage. Under your defined pool you probably need to create two datasets. One for windows share, the other for Linux. If security isnt a concern, you can use nfs3 and on the share under advance set the security to root and wheel. Then you dont need to log into nfs share.

if you need screen shots i can get you some tomorrow at some point.
 
  • Like
Reactions: Fritz

Rand__

Well-Known Member
Mar 6, 2014
4,558
909
113
It also might be (supported/configured) smb versions...
And its not ideal to have the same dataset for both due to permission logic that gets applied...
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
under sharing tab, what do you have defined? For windows you might have a SMB share (or iscsi), for Linux you would probably need NFS share. I dont think Linux and window would share the same storage. Under your defined pool you probably need to create two datasets. One for windows share, the other for Linux. If security isnt a concern, you can use nfs3 and on the share under advance set the security to root and wheel. Then you dont need to log into nfs share.

if you need screen shots i can get you some tomorrow at some point.
Screen shots would be great. :)
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
Gonna play around with NFS. I've always avoided it because it seems to be a royal PITA to get working.
 

marcoi

Well-Known Member
Apr 6, 2013
1,398
222
63
Gotha Florida
Note: i like using the legacy interface. just more use to how to configure it.

For windows shares:
1. Under Storage tab - create a new dataset and setup as shown below.
2. Under Sharing tab - Windows - add new smb share and select the dataset you made for windows. check on guests.
3. Under the Services tab - Edit the smb settings. Change to match below image.
4. On windows box put in windows explorer \\IP of Freenas\ you will see the Windows folder.

This setup using guest logging and uses root to add content to the share. No security whatsoever.

upload_2019-7-11_11-55-26.png
upload_2019-7-11_11-58-2.png
upload_2019-7-11_12-3-12.png
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
Share works fine in Windows. It's Linux that won't work. Found a tutorial that shows how to establish a connection via NSF but as usual, it assumes you know a great deal about NSF going in. I'd don't so said tutorial is full of gibberish. :(
 

marcoi

Well-Known Member
Apr 6, 2013
1,398
222
63
Gotha Florida
For linux shares:
1. Under Storage tab - create a new dataset and setup as shown below.
2. Change permissions on the new dataset to allow everyone access.
3. Under the Sharing tab - Unix NFS - Add a new share and configure as shown below.
4. Make sure NFS service is running. You can adjust threads etc if needed or bind to a particuar IP.

When you mount it, make sure to mount using nfs3. Below is example adding to esxi since i dont have unix vm ready to grab screen shots.
Remember no security here.

upload_2019-7-11_12-6-37.png
upload_2019-7-11_12-8-33.png
upload_2019-7-11_12-10-8.png

upload_2019-7-11_12-13-9.png
upload_2019-7-11_12-13-56.png
Use the IP of FreeNas server and the mount you added under NFS share.
 

marcoi

Well-Known Member
Apr 6, 2013
1,398
222
63
Gotha Florida
Share works fine in Windows. It's Linux that won't work. Found a tutorial that shows how to establish a connection via NSF but as usual, it assumes you know a great deal about NSF going in. I'd don't so said tutorial is full of gibberish. :(
IDK if all flavors of linux mount the same but for ubuntu. I use the /etc/fstab and use the following line

dev-freenas:/mnt/Data_Rz10_8TB/Software /Software/ nfs auto,noatime,nolock,bg,nfsvers=3,intr,tcp,actimeo=1800 0 0
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
Thank you sir, much appreciated. It seems like my version and yours are not the same. I have System Dataset -> System Dataset Pool. The pool name is Backup and it's already listed under Dataset Pool.
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
IDK if all flavors of linux mount the same but for ubuntu. I use the /etc/fstab and use the following line

dev-freenas:/mnt/Data_Rz10_8TB/Software /Software/ nfs auto,noatime,nolock,bg,nfsvers=3,intr,tcp,actimeo=1800 0 0
Am I correct in assuming the what follows "/mnt" is the name of the share I'm trying to connect to?

Also, my HostName is BACKUPS.local and the pool name is backup.
 

marcoi

Well-Known Member
Apr 6, 2013
1,398
222
63
Gotha Florida
Am I correct in assuming the what follows "/mnt" is the name of the share I'm trying to connect to?

Also, my HostName is BACKUPS.local and the pool name is backup.
so your example would be
BACKUPS.local:/mnt/backup /folder your mounting to in unix/ nfs auto,noatime,nolock,bg,nfsvers=3,intr,tcp,actimeo=1800 0 0
 

Fritz

Well-Known Member
Apr 6, 2015
2,120
483
83
66
Is a Dataset the same as a Datastore ?

Nope, looks totally different.
 
Last edited: