EU Mellanox SX6036 36ports QSFP €150

RedX1

Member
Aug 11, 2017
58
52
18
Hi



I hope you might be able to help.



Like many of you I became interested in these QSFP switches.

I just received a SX6036 switch, the full depth version with 2 PSU. This Switch fails at a boot error and only displays the Red System Failure triangle.

The console output consists of the following.

_______________________________________________________________________

U-Boot 2009.01 SX_PPC_M460EX SX_3.2.0330-82 ppc (Dec 20 2012 - 17:53:54)

CPU: AMCC PowerPC 460EX Rev. B at 1000 MHz (PLB=166, OPB=83, EBC=83 MHz)
Security/Kasumi support
Bootstrap Option H - Boot ROM Location I2C (Addr 0x52)
Internal PCI arbiter disabled
32 kB I-Cache 32 kB D-Cache
Board: Mellanox PPC460EX Board
FDEF: No
I2C: ready
DRAM: Auto calibration -DQS memory calibration windows can not be determined.
U-Boot cannot continue. Please consider defining
fallback values and utilizing them to avoid this
situation.
### ERROR ### Please RESET the board ###

_________________________________________________________________________

Pushing the normal reset button on the front display does not help.


Can this possibly be fixed or should I return the switch?



Thanks



RedX1
 

Rand__

Well-Known Member
Mar 6, 2014
4,558
909
113
If you can get a replacement just send it back, dont think its worth the hassle
 

hmartin

Active Member
Sep 20, 2017
179
120
43
34
Hi



I hope you might be able to help.



Like many of you I became interested in these QSFP switches.

I just received a SX6036 switch, the full depth version with 2 PSU. This Switch fails at a boot error and only displays the Red System Failure triangle.

The console output consists of the following.

_______________________________________________________________________

U-Boot 2009.01 SX_PPC_M460EX SX_3.2.0330-82 ppc (Dec 20 2012 - 17:53:54)

CPU: AMCC PowerPC 460EX Rev. B at 1000 MHz (PLB=166, OPB=83, EBC=83 MHz)
Security/Kasumi support
Bootstrap Option H - Boot ROM Location I2C (Addr 0x52)
Internal PCI arbiter disabled
32 kB I-Cache 32 kB D-Cache
Board: Mellanox PPC460EX Board
FDEF: No
I2C: ready
DRAM: Auto calibration -DQS memory calibration windows can not be determined.
U-Boot cannot continue. Please consider defining
fallback values and utilizing them to avoid this
situation.
### ERROR ### Please RESET the board ###

_________________________________________________________________________

Pushing the normal reset button on the front display does not help.


Can this possibly be fixed or should I return the switch?



Thanks



RedX1
DRAM training failed. Most likely the switch has faulty RAM. I would request an exchange or refund if you are able to.
 

RedX1

Member
Aug 11, 2017
58
52
18
Hi



Thanks so much for your instant answers and insight.



I am in the UK and vendors with these switches are not easily found. I will return it for a refund.



I am still on the look out for one of these.





Thanks again.







Redx!
 

Tt78

New Member
May 7, 2020
2
0
1
Took way longer to get the SX6036 to the latest firmware than it did to get the ethernet license. Thanks to a couple folks that helped point me the right direction.

I did NOT need the conversion so simply needed to create the dummy license, watch the call via ltrace, grab the shared secret, and create the key. Will keep the ubuntu VM around that I used for this in case someone else needs assistance.
Can anyone point in my the right direction for this?
 

gisshan

New Member
Feb 26, 2018
17
1
3
41
Anyone know if this switch is any quieter (before or after the listed fan modification in this thread) than the Voltaire 4036e?
 

jmsq

New Member
Dec 30, 2019
13
5
3
I'm looking into fan control options on these, my starting point being to try and create some pigtail intercept cables to monitor what sort of signalling is going on between the switch Mobo <> Fan Control Module PCB (Will see on this, lots of pins), and then the Fan Control Module PCB <> Fans. Similarly for the power supplies and their respective fan.

Step one was working out what the hell the connector was, after literally hours of searching (never knew how many 4 pin connectors there could be....), I've concluded that in my SX6036's, it uses Molex PicoBlades, being either 3 pin or 4 pin varieties:
PicoBlade Connector System - Molex
The 3 pin connector just goes to the indicator panel on the fan module for diagnostic light.

I'm going to hunt some down, make up some cables and then have a look see on the o'scope. Not expecting anything magic, presuming pretty standard freq PWM and 2 pulse per rev tacho on the fans, but just want to get some baseline numbers from the switch at a known ambient temp and idle load, before I start stuffing around with it all....I'm also allergic to cutting cables in things that otherwise working correctly....
Were you able to make any progress on this? Very curious on what my fan-quieting options are with this switch; also preferably without cutting wires :)
 

Tt78

New Member
May 7, 2020
2
0
1
Thanks to those that responded for enabling ethernet. I now can't seem to get RoCE working through the switch. I followed the L2 setup guide here and am running Windows Server 2019/Windows 10 Pro for Workstations and used the Mellanox and Microsoft guides to set up QoS/PFC/ETS etc. RDMA works just fine when the two systems are attached directly and the network is working through the switch but no RDMA love. Anyone have any ideas? The linked switch setup guide configures a Linux server and has a section on setting vlan egress but it seems to me that was just setting QoS priority for interfaces; I shouldn't need to configure VLAN in my Windows systems with hybrid switchports accepting all VLANs, correct?

switchpfc.PNG
Server:
server-qos-config.PNG
Client (same as server):
client-qos-config.PNG
 
Nov 23, 2014
90
29
18
Took way longer to get the SX6036 to the latest firmware than it did to get the ethernet license. Thanks to a couple folks that helped point me the right direction.

I did NOT need the conversion so simply needed to create the dummy license, watch the call via ltrace, grab the shared secret, and create the key. Will keep the ubuntu VM around that I used for this in case someone else needs assistance.
Any help on getting the latest firmware would be greatly appreciated! :)
 

nina

New Member
Aug 15, 2020
1
0
1
Took way longer to get the SX6036 to the latest firmware than it did to get the ethernet license. Thanks to a couple folks that helped point me the right direction.

I did NOT need the conversion so simply needed to create the dummy license, watch the call via ltrace, grab the shared secret, and create the key. Will keep the ubuntu VM around that I used for this in case someone else needs assistance.
Hi everyone, can someone help me with this please? I'm stuck at the grab part.
 

gisshan

New Member
Feb 26, 2018
17
1
3
41
For anyone wondering the same as I was about the noise level compared to the 4036e, I went ahead and bought one. I hooked it up and powered it on. I then had to make sure that it had lit up since I couldn't hear it next to the 4036e. Now to see if I can figure out cabling. One of the same dacs that worked on the 4036e won't shows as not connected on the SX6036.
 
Nov 23, 2014
90
29
18
Has anyone tried connecting 100Mbps (aka Fast Ethernet) devices to the switch? I'm wondering if I could use a spare port for linking to a PDU.
 

chaxXxe

New Member
Sep 10, 2020
1
0
1
Can anyone point in my the right direction for this?
Working on this same thing. I've got a linux VM setup and am using qemu-ppc-static to run the binaries from the unpacked mlnxos image, but each string I generate is getting rejected as invalid by the switch. Anyone able to give an assist? Thanks
 

joddlarn

Member
Jul 14, 2018
43
15
8
Sweden
Working on this same thing. I've got a linux VM setup and am using qemu-ppc-static to run the binaries from the unpacked mlnxos image, but each string I generate is getting rejected as invalid by the switch. Anyone able to give an assist? Thanks
Use the x86 image from the Lenovo download site instead.
That way you can use tools such as ltrace.
 
  • Like
Reactions: chaxXxe

ItsValium

New Member
May 28, 2015
4
1
3
42
I just bought two of these switches, and am looking to enable ethernet and/or 56gbe license on them. Seems like it used to be explained here somewhere but can't seem to find how to do it. Can anyone point me in the right direction? That would be awesome!
 

kedzior

Member
Mar 21, 2018
32
7
8
46
Poland
Maybe someone is interested I have the last one SX6036 with all capabilities to sell 250 EUR, I need to clean up my office with all this equipment (condition like New).
I have also the last one SX1036 with all capabilities as well, price is the same as for SX6036 (Used) 2*PSU.