LAN Ports on the X470D4U -- How i unbonded IPMI and then bonded in the OS

ricardo-sf

New Member
May 26, 2020
6
4
3
I'm just going to summarize what i just did, perhaps it will help someone out there. While figuring it out i found very little info from ASRock and found some confusion on the forums.

The X470D4U has 3 ethernet ports: LAN1, LAN2, and IPMI_LAN

Out of the box my X470D4U was configured like this: (BMC1.90, BIOS 3.3)

LAN2 + IPMI_LAN bonded in active-backup mode.

LAN1 - free

I guess they do this in case the ethernet jack breaks in shipment? -- you have the ability to connect to LAN2 or IPMI_LAN to get to the BMC

What i wanted to do was have IPMI_LAN be the only port for the BMC, and then BOND LAN1 + LAN2 on my OS (proxmox).

-- I had already installed PROXMOX with the out-of-thebox configuration.

Unbonding and disabling the BMC on LAN2

In the BMC;
  1. Power down the machine, then open the BMC
  2. Go to Settings -> Network Settings -> Network Bond Configuration
  3. Deselect "Enable Bonding"
  4. Wait for the BMC to reboot
  5. Go to Settings -> Network Settings -> Network IP Settings
  6. Select eth1 under the "Lan Interface" dropdown
  7. Deselect "Enable LAN"
  8. Wait for the BMC to reboot
Thats it -- the BMC is now no longer bonded or enabled on LAN2

I then just had to bringup the ethernet interface in proxmox (debian) and configure it as a bonded interface (plenty of material out there on how to do that, so i'll skip it).
 
Last edited:

EffrafaxOfWug

Radioactive Member
Feb 12, 2015
1,289
441
83
I should add that there's a bug in at least some batches of this board where, once you turn off the active-backup bonding method, you experience:
* Very long POST times
* The IPMI interface reboots every time you reboot the machine

This seems to be due to ASRock mistakenly setting the MAC address of the IPMI NIC to the same as one of the onboard NICs (at least that's what they said needed fixing in the support ticket) which resulted in the IPMI OS crashing every time the NIC was enumerated at boot. They provided me with a command line util (linux and DOS versions called BMCMAC and S_BMCMAC.EXE) to reprogram the BMC MAC address and this fixed the issue.

Original post

If the IPMI NIC dies, you should be able to turn bonding back on via the BIOS (although that'd likely require a crash cart). In Supermicro IPMI you can change the NIC mode from the OS via the IPMI raw 0x30 0x70 0x0c but I've no idea if ASRock have an equivalent.
 

DavidB

Member
Aug 31, 2018
54
17
8
I should add that there's a bug in at least some batches of this board where, once you turn off the active-backup bonding method, you experience:
* Very long POST times
* The IPMI interface reboots every time you reboot the machine

This seems to be due to ASRock mistakenly setting the MAC address of the IPMI NIC to the same as one of the onboard NICs (at least that's what they said needed fixing in the support ticket) which resulted in the IPMI OS crashing every time the NIC was enumerated at boot. They provided me with a command line util (linux and DOS versions called BMCMAC and S_BMCMAC.EXE) to reprogram the BMC MAC address and this fixed the issue.

Original post

If the IPMI NIC dies, you should be able to turn bonding back on via the BIOS (although that'd likely require a crash cart). In Supermicro IPMI you can change the NIC mode from the OS via the IPMI raw 0x30 0x70 0x0c but I've no idea if ASRock have an equivalent.
I have 4 boards from the same batch, and two have this problem with the two others not having this issue. Seems to me like some work before shipping was done manually on these boards.