Iron Wolfs aggressively spinning down

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Chris230291

New Member
Jun 23, 2019
7
0
1
Hello. My new Iron Wolf 10TB drives are aggressively spinning down in Ubuntu. Does anyone know how to prevent this? I have tried setting the standby time in drive settings. I have also tried setting the spindown through hdparm, but nothing works. The moment a file has finished being written, they go back to standby.

Has anyone got any ideas? Seagate told me they cant help me because I'm using Linux...

Cheers,
Chris
 

canta

Well-Known Member
Nov 26, 2014
1,012
215
63
43
Hello. My new Iron Wolf 10TB drives are aggressively spinning down in Ubuntu. Does anyone know how to prevent this? I have tried setting the standby time in drive settings. I have also tried setting the spindown through hdparm, but nothing works. The moment a file has finished being written, they go back to standby.

Has anyone got any ideas? Seagate told me they cant help me because I'm using Linux...

Cheers,
Chris
typical seagate Desktop aggressive power saving.
a simple way is disable APM by running hdparam
to check APM level: hdparam -B /dev/sdX
to set APMlevel: hdparm -B <1-255> /dev/sdX
unit to install hdparm package that based on your running linux distro
could be off (does not mean disabled ), 1 to 255. but the number does not reflect identical how aggressive power-saving on seagate or WD. this number is useless and can be try by trial

seagate (based on my SG HDD, barracuda and current SMR drive including 5TB 2.5 SMR): 240 or greater turn APM is disable.
WD white label ( has 8T and 10T), default is off but it would parking/spinning down within 5 mins. 200 or greater turns APM to disable

seagate is very aggressive compared WD. I do not know on NAS drive due on not having it.


I have a simple script that installed as a systemd unit to disable APM for all HDDs.
if you need the script and systemd unit file, I can post it here.
 

Chris230291

New Member
Jun 23, 2019
7
0
1
typical seagate Desktop aggressive power saving.
a simple way is disable APM by running hdparam
to check APM level: hdparam -B /dev/sdX
to set APMlevel: hdparm -B <1-255> /dev/sdX
unit to install hdparm package that based on your running linux distro
could be off (does not mean disabled ), 1 to 255. but the number does not reflect identical how aggressive power-saving on seagate or WD. this number is useless and can be try by trial

seagate (based on my SG HDD, barracuda and current SMR drive including 5TB 2.5 SMR): 240 or greater turn APM is disable.
WD white label ( has 8T and 10T), default is off but it would parking/spinning down within 5 mins. 200 or greater turns APM to disable

seagate is very aggressive compared WD. I do not know on NAS drive due on not having it.


I have a simple script that installed as a systemd unit to disable APM for all HDDs.
if you need the script and systemd unit file, I can post it here.
Thanks for the reply. Yes doing more research I discovered this stupid power management stuff.
Unfortunately I cant seem to be able to disable it though.

Code:
sudo hdparm -B 255 /dev/sdc

/dev/sdc:
 setting Advanced Power Management level to disabled
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 40 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 APM_level      = not supported
I think I'm just going to return them and go WD.
 

fossxplorer

Active Member
Mar 17, 2016
554
97
28
Oslo, Norway
Was curious and did check upon my 8TB IronWolfs:
/dev/sdc:
APM_level = not supported

I use it in a 24/7 file access ZFS system and i haven't noticed any spindowns. Could also be that it's co-located at a remote data center. I would definitely like to know a way that the disks aren't spinning down at any time :)
 

Chris230291

New Member
Jun 23, 2019
7
0
1
Was curious and did check upon my 8TB IronWolfs:
/dev/sdc:
APM_level = not supported

I use it in a 24/7 file access ZFS system and i haven't noticed any spindowns. Could also be that it's co-located at a remote data center. I would definitely like to know a way that the disks aren't spinning down at any time :)
I am running Ubuntu. I was wondering why it was taking so long to transfer files in the mergerfs setup I created (set to use the disk with most free space). I noticed the "zzz" icon in the disk utility, which means the disk has spun down. It was taking so much time because it was having to spin each disk up every time a new file was being created.

When doing research I saw some posts regarding ZFS and how to stop the disks spinning down using hdparm. So they could be for sure.

Anyways... They are out of the system now. Going to go with the WD red white labels instead.
 

canta

Well-Known Member
Nov 26, 2014
1,012
215
63
43
Thanks for the reply. Yes doing more research I discovered this stupid power management stuff.
Unfortunately I cant seem to be able to disable it though.

Code:
sudo hdparm -B 255 /dev/sdc

/dev/sdc:
 setting Advanced Power Management level to disabled
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 40 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 APM_level      = not supported
I think I'm just going to return them and go WD.

can you try to set -B 240 ?

I am still running 3T and 4T barracuda and including 5TB Seagate SMR drive.


I disable APM on 8TB/1-0TB white label WD (removed from external USB3 drive) . the default APM is off. but will spin-down and parking within 4-5 min. Due to running Containers on ZoL. the "193 Load_Cycle_Count" is increasing quickly, I disable APM finally with -B 240 (apm level) due to can not use wdidle on white label WD.

note:
return it by assuming not fee returned charge,If you can not disable APM.

I am getting consumed with whitelable WD HDD, still holding for prior Black friday (hopefully can score $145 for 10TB)
hey, thanks for reporting, banning iron wolf desktop on my list.
 

canta

Well-Known Member
Nov 26, 2014
1,012
215
63
43
Was curious and did check upon my 8TB IronWolfs:
/dev/sdc:
APM_level = not supported

I use it in a 24/7 file access ZFS system and i haven't noticed any spindowns. Could also be that it's co-located at a remote data center. I would definitely like to know a way that the disks aren't spinning down at any time :)
is this NAS or Desktop version?
 

canta

Well-Known Member
Nov 26, 2014
1,012
215
63
43
I am running Ubuntu. I was wondering why it was taking so long to transfer files in the mergerfs setup I created (set to use the disk with most free space). I noticed the "zzz" icon in the disk utility, which means the disk has spun down. It was taking so much time because it was having to spin each disk up every time a new file was being created.

When doing research I saw some posts regarding ZFS and how to stop the disks spinning down using hdparm. So they could be for sure.

Anyways... They are out of the system now. Going to go with the WD red white labels instead.
I started disable APM in 2013-ish, when seagate 3TB (removed from USB external drive) was nasty in spinning down/parking head, I lost three drive within 6-8 months , and realized that "load_cycle_count" shoot to the roof quickly. the other positive side, replacing bad HDD was easy on ZFS :-D. I rma'd the drive and got refurbished that last for 1.5 years (seagate refurbished drive from rma were not good overall)

my preference HDD is White label WD (and red) whichever that I get from WD external drive.

white label and red seems has 4-5 minutes before spinning down , based on my observation.
 

Chris230291

New Member
Jun 23, 2019
7
0
1
Thanks for the replies guys but the drives are already on there way back to the store for a refund.
I should have gone with WD to begin with. Never had any issues with them.

Honestly, if the white labels are set to park after 5 mins, then that sounds perfect for me and my mergerfs setup.
 

hjfr

Member
Nov 21, 2013
79
20
8
France
Chris230291> It's head parking ?
For my IronWolf Pro, I used the Seagate tool "SeaChest_PowerChoice" to modify the EPC (Extended Power Conditions) settings.
These drives have 4 powers saving mode (idle_a, idle_b, idle_c and standby_z).
I increased the idle_b (head parking) timer and disabled idle_c (default value for idle_b is 2min and idle_c : 4min)