IPMI Viewer KVM Console Color issue

Jiaxinxi

Member
Aug 23, 2017
73
35
18
50
I am using IPMI Viewer 20 to connect to SuperMicro X9DRi-F motherboard.

Everything works great except the color of the kvm console is distorted. Everything seems tainted with green.

As you can see from the attached screenshot.

How can I address this issue?

Thanks
 

Attachments

AveryFreeman

ESXi + ( ILLUMOS / ZFS ) = HAPPY
Mar 17, 2017
165
19
18
39
Near Seattle
averyfreeman.com
No, I still have this issue.
Sorry to hear that!

After I responded to your thread, I noticed I wasn't having the same issue on a Windows VM I use as a desktop w/ GPU passthrough. I am only having issues with my Thinkpad running Ubuntu 20.04.

Maybe you could try another machine or another version of IPMIView to see if that's the issue(?)

Here's what my Ubuntu IPMIView looks like: upload_2020-2-7_19-37-8.png

I will try a different version of IPMIView just to see if that's the issue.

Edit: I found a link to the successor of the old Supermicro FTP site: www.supermicro.com - /wftp/

IPMIView folder is here: www.supermicro.com - /wftp/utility/IPMIView/

Edit edit: Went from 2.16 to 2.17 and didn't get any better :(
 
Last edited:

Germini00

New Member
Feb 10, 2020
2
0
1
I am having the same issue with a Supermicro X9SCM-F since very short time I own it, first when trying to use webserver to use KVM didn't work didn't connect and I had security alerts which I couldn't bypass even after whitelisting the IP in java settings. I downloaded IPMI View 2.17 and worked but having the same color issues as OP. I upgraded IPMI/BMC to Firmware Revision : 03.52 before It was 1.86. Now I can use browser KVM and all working fine BUT IPMI View 2.17 has the same color issues. Tried IPMI View 2.16 same color issues.

I realized that when using in browser KVM it was using "JAVA iKVM Viewer v1.69.21" and using IPMI View it was using "JAVA iKVM Viewer v1.69.20".

So the question is how to change the IPMI View to use JAVA iKVM Viewer v1.69.21 instead of v1.69.20. When analyzing "launch.jnlp" file it uses iKVM__V1.69.21.0x0.jar but I couldn't download it when trying http://IP/iKVM__V1.69.21.0x0.jar I get 404 error

I think getting this file and replacing it in IPMI View folder would make it work fine. Maybe someone could help on this
 

Jiaxinxi

Member
Aug 23, 2017
73
35
18
50
I am having the same issue with a Supermicro X9SCM-F since very short time I own it, first when trying to use webserver to use KVM didn't work didn't connect and I had security alerts which I couldn't bypass even after whitelisting the IP in java settings. I downloaded IPMI View 2.17 and worked but having the same color issues as OP. I upgraded IPMI/BMC to Firmware Revision : 03.52 before It was 1.86. Now I can use browser KVM and all working fine BUT IPMI View 2.17 has the same color issues. Tried IPMI View 2.16 same color issues.

I realized that when using in browser KVM it was using "JAVA iKVM Viewer v1.69.21" and using IPMI View it was using "JAVA iKVM Viewer v1.69.20".

So the question is how to change the IPMI View to use JAVA iKVM Viewer v1.69.21 instead of v1.69.20. When analyzing "launch.jnlp" file it uses iKVM__V1.69.21.0x0.jar but I couldn't download it when trying http://IP/iKVM__V1.69.21.0x0.jar I get 404 error

I think getting this file and replacing it in IPMI View folder would make it work fine. Maybe someone could help on this
Thanks for your information!
 

acp

New Member
Mar 7, 2014
5
4
3
50
I am having the issue as well. With the X9 boards with Windows and XCP-NG. On the X10 it is running XCP-NG the colors look fine.

I realized that when using in browser KVM it was using "JAVA iKVM Viewer v1.69.21" and using IPMI View it was using "JAVA iKVM Viewer v1.69.20".
I noticed that as well. When I used 1.69.21 the issue went away on the X9 boards.

So the question is how to change the IPMI View to use JAVA iKVM Viewer v1.69.21 instead of v1.69.20. When analyzing "launch.jnlp" file it uses iKVM__V1.69.21.0x0.jar but I couldn't download it when trying http://IP/iKVM__V1.69.21.0x0.jar I get 404 error
Welcome to Java :)

To download the jar file you need to add a few things to the url.

http://[ip]/iKVM__V1.69.21.0x0.jar.pack.gz

And then you have to unpack it. IPMIView has unpack200 which will do that.

I think getting this file and replacing it in IPMI View folder would make it work fine. Maybe someone could help on this
I went down this path as well and well it didn't work. The file that has the iKVM is C:\Program Files (x86)\SUPERMICRO\IPMIView\iKVM.jar.

I don't know a lot about java, but the iKVM.jar file is much bigger than iKVM__V1.69.21.0x0.jar. Guess it will require a much further breakdown as to what is different between these jar files.


A
 

pgsengstock

New Member
Apr 28, 2020
1
0
1
I was able to use some of the steps here to extract the libiKVM64.jnilib and libSharedLibrary64.jnilib files downloaded from the web console. Putting these in place of the existing ones in my IPMIView directory got colors working correctly with the included iKVM.jar, at least on macOS 10.15.4.

I tried replacing the iKVM.jar as well, assuming that would give me V1.69.21, but no dice. It won't load at all. Haven't tried the scripts at the link above yet.

Edit: Also confirmed that virtual storage is borked in macOS with V1.69.20. V1.69.21 works great when launched via launch.jnlp.