Info on LSI SAS3408? Got myself a 530-8i on eBay...

Notice: Page may contain affiliate links for which we may earn a small commission through services like Amazon Affiliates or Skimlinks.

Boubou30

New Member
Feb 8, 2024
5
1
3
the jumper goes on J11 on these (the pins that are almost touching the heatsink on the PCIE bracket side of the card.
the SAS address is on the label on the SAS connector.

i have done a few of these lenovo 530 cards now and they all convert to LSI 9400 HBA correctly.
Thank you for your response, I have hope, can you give me more information on how to do it, because I followed his following explanation:
without success, I used:
1)STORCLI_SAS3.5_P10
2)9400_8i_Pkg_P24_SAS_SATA_NVMe_FW_BIOS_UEFI with HBA_9400-8i_SAS_SATA_Profile firmware.
but I still have an error: The image checksum is invalid
Thanks for your help
Edit: info on my lenovo raid 530-8i card

20240211_211808.jpg
 

Zedicus

Member
Jul 12, 2018
52
21
8
Thank you for your response, I have hope, can you give me more information on how to do it, because I followed his following explanation:
without success, I used:
1)STORCLI_SAS3.5_P10
2)9400_8i_Pkg_P24_SAS_SATA_NVMe_FW_BIOS_UEFI with HBA_9400-8i_SAS_SATA_Profile firmware.
but I still have an error: The image checksum is invalid
Thanks for your help
Edit: info on my lenovo raid 530-8i card

View attachment 34486
you need firmware file HBA_9405W-16i_SAS_SATA_Profile.bin

place a jumper on J11
place the card in your computer
boot to UEFI shell
use command:
storcli / c0 download firmware file = HBA_9405W-16i_SAS_SATA_Profile.bin
after complete turn off computer
remove jumper from J11
boot computer with card installed to UEFI shell again
run command:
storcli.efi / c0 set sasadd= (sas address from label)
 
  • Like
Reactions: Boubou30

Boubou30

New Member
Feb 8, 2024
5
1
3
you need firmware file HBA_9405W-16i_SAS_SATA_Profile.bin

place a jumper on J11
place the card in your computer
boot to UEFI shell
use command:
storcli / c0 download firmware file = HBA_9405W-16i_SAS_SATA_Profile.bin
after complete turn off computer
remove jumper from J11
boot computer with card installed to UEFI shell again
run command:
storcli.efi / c0 set sasadd= (sas address from label)
I can't do it, I put the errors that appear:
with jumper J11:

20240211_225423.jpg
and with the command to flash
20240211_225505.jpg
without the jumper the card is recognized by the bios
 

Zedicus

Member
Jul 12, 2018
52
21
8
I can't do it, I put the errors that appear:
with jumper J11:

View attachment 34488
and with the command to flash
View attachment 34489
without the jumper the card is recognized by the bios

the ONLY command you can run with the jumper on is the FLASH command. do
NOTHING else with the jumper on.

you need to be in the correct directory where the bin file is usually fs0: or some subdirectory.
 
  • Like
Reactions: Boubou30

Boubou30

New Member
Feb 8, 2024
5
1
3
you need to be in the correct directory where the bin file is usually fs0: or some subdirectory.
it works, my mistake is not selecting FS0 directory, Thank you very much for your help and your time, I've been racking my brain over this flash problem for 2 days, thank you
 
  • Like
Reactions: Zedicus

Zedicus

Member
Jul 12, 2018
52
21
8
NOTE for future flashers, i am uploading the image again with the jumper circled in RED as i just realized it seams to be marked slightly differently on different generations of cards, (or maybe it is a difference in clone cards ) either way, the RED CIRCLE indicates the jumper for the initial cross flash.
 

Attachments

  • Like
Reactions: Boubou30

MortenB

Member
Jul 3, 2017
79
21
8
42
you need firmware file HBA_9405W-16i_SAS_SATA_Profile.bin

place a jumper on J11
place the card in your computer
boot to UEFI shell
use command:
storcli / c0 download firmware file = HBA_9405W-16i_SAS_SATA_Profile.bin
after complete turn off computer
remove jumper from J11
boot computer with card installed to UEFI shell again
run command:
storcli.efi / c0 set sasadd= (sas address from label)

For my 530-16i I was getting error messages when trying to flash with HBA_9405W-16i_SAS_SATA_Profile.bin.
It worked straight away when I tried HBA_9400-16i_SAS_SATA_Profile.bin instead. Thanks for the help :)
 
  • Like
Reactions: Zedicus

Zedicus

Member
Jul 12, 2018
52
21
8
It worked straight away when I tried HBA_9400-16i_SAS_SATA_Profile.bin instead.

i think that is the more common one, but the naming and slight card variants seems to be even more than what the 93xx cards were. fun times.
 

snoopy78

New Member
Dec 24, 2023
4
2
3
got an Lenovo 530-8i too... when flashing with FW HBA_9405W-16i_SAS_SATA_Profile.bin i got token error in EFI....so i flashed HBA_9400-8i_SAS_SATA_Profile.bin...and all worked fine....greatest hassle was to find the firmware files @broadcom
 
  • Like
Reactions: Zedicus

sshanee

New Member
Jan 5, 2019
1
0
1
a little bit off topic but... i can't seem to make this card play nicely with aspm/low c-states. when i use this card (in cpu or pch pcie slots) i can't get my i5-14500 cpu below c2 pkg state. ive used "storcli /c0 show all" and noticed "Power Saving option = Enable" but nothing else regarding aspm. the card defaults to aspm: disabled in 'lspci -vvv -s <device id> | grep LnkCtl:' and i have forced it to L1 enabled using a script that also enables L1 on the pcie host above it... has anyone got past c2/c3 with this card??
 

e97

Active Member
Jun 3, 2015
327
199
43
See the 530-8i can be flashed to 9400-8i.

Can 430 be flashed to a 9400 with NVMe functionality?
 
Last edited: