IBM M1115 SAS9223-8i

Discussion in 'RAID Controllers and Host Bus Adapters' started by sapper6fd, Nov 1, 2013.

  1. sapper6fd

    sapper6fd Member

    Joined:
    May 21, 2013
    Messages:
    48
    Likes Received:
    1
    Does anyone have any info on these HBA's? I have the opportunity to get my hands on three of them for dirt cheap ($100 for all three) and am wondering if they can be flashed to IT Mode. They seem very similar if not identical to the M1015.
     
    #1
  2. sapper6fd

    sapper6fd Member

    Joined:
    May 21, 2013
    Messages:
    48
    Likes Received:
    1
    We'll I got my hands on three of them today for a smoking price of




    Wait for it











    Free. Can't beat that. I've managed to find some info saying it can be flashed to IT mode using the same firmware and process as the M1015 process. Just have to wait on some cables for them and I'll start flashing away. Hope all goes well with it and I don't end up with a few bricked cards.
     
    #2
  3. scobar

    scobar Member

    Joined:
    Nov 24, 2013
    Messages:
    84
    Likes Received:
    9
    Looking at the article here: http://www.servethehome.com/ibm-serveraid-m1015-part-4/

    In the comments:
    This looks encouraging as I just bought an M1115.
     
    #3
  4. scobar

    scobar Member

    Joined:
    Nov 24, 2013
    Messages:
    84
    Likes Received:
    9
    Ok so I flashed this card...

    I was not able to boot my spare pc with this so had to go with my server which has that goofy intel UEFI crap.

    Below is the results, I was able to hot-add a drive:
    #14 is off of the newly flashed controller.
     
    #4
  5. sapper6fd

    sapper6fd Member

    Joined:
    May 21, 2013
    Messages:
    48
    Likes Received:
    1
    So you got good results? Good to know. I have yet to flash any of the three cards I have. Not sure when I'm going to get a chance to do it, hopefully some time soon. Which flashing tutorial did you use?
     
    #5
  6. fiddletwix

    fiddletwix New Member

    Joined:
    Nov 25, 2013
    Messages:
    1
    Likes Received:
    0
    Just flashed mine the other day and connected 5 drives to it. Everything is going well so far. As far as what I did? I followed the same instructions as the ones to flash the M1015 to IT mode. Basically, wipe the firmware with megarec, reboot and flash with IT firmware using sas2flash (in my case, I have a UEFI supermicro board and used sas2flash.efi
     
    #6
  7. sapper6fd

    sapper6fd Member

    Joined:
    May 21, 2013
    Messages:
    48
    Likes Received:
    1
    I flashed all three of mine with the same instructions at the beginning of the month. All are working just fine with the exception of one which seems to have issues with one SATA connection. Doesn't connect to the drive for some reason. One dead port out of 8.
     
    #7
  8. mobilenvidia

    mobilenvidia Moderator

    Joined:
    Sep 25, 2011
    Messages:
    1,755
    Likes Received:
    51
    The M1115 is pretty well identical to the M1015, but I think the M1115 supports RAID5 in iMR mode making it a closer resemblance to a LSI 9240.
    You should be able to do anything Firmware wise for the M1015 with the M1115
     
    #8
  9. paradise regained

    paradise regained New Member

    Joined:
    Dec 29, 2013
    Messages:
    4
    Likes Received:
    1
    Hello,

    we are having weird issue with M1115 and Lenovo TS440 server combo:

    - M1015 and M5014 work perfectly in any configuration of memory
    - M1115: only 2 out of 4 DIMM slots can be used when M1115 is present. If 3rd or 3rd + 4th slots are used, server beeps and does not start

    We did not try to flash 9211-8i IR mode yet (we need RAID), so FW is original IBM.
    Any idea how to solve issue?

    P.S: Firmware / Bios of controller and server are up-to-date.
     
    #9
    Last edited: Dec 29, 2013
  10. mobilenvidia

    mobilenvidia Moderator

    Joined:
    Sep 25, 2011
    Messages:
    1,755
    Likes Received:
    51
    Thats a first I've come accross with this issue.
    Couple of things to possibly try.

    Can you try M1115 in another PCIe slot ?
    Wonder if DMA is an issue here.

    You running IBM Firmware or LSI ?
    Try LSI 9240 latest firmware if running IBM or Go back to IBM if running LSI
    You can chop and change FW between LSI and IBM your card remains a M1115 either way.

    I wonder if cross flashing to a M1015 would solve this issue (thinking aloud)
     
    #10
  11. paradise regained

    paradise regained New Member

    Joined:
    Dec 29, 2013
    Messages:
    4
    Likes Received:
    1
    TY for reply.

    Did, no difference :(

    Stock IBM (latest)

    Will try that. Funnily Lenovo certified plain LSI 9240-8i with this server ...

    No as they have same Firmware (it is M1015 / M1115 combo firmware).
     
    #11
  12. paradise regained

    paradise regained New Member

    Joined:
    Dec 29, 2013
    Messages:
    4
    Likes Received:
    1
    Flashing IBM SR M1115 to LSI 9211-8i IR mode successful, but symptom remain the same :( ie Lenovo ThinkServer TS440 only beeps if 3 or 4 memory sticks are inbuilt. Funily also Lenovo ThinkCentre M93 desktop PC behaves in same way. So we suspect that Lenovo must be doing to their BIOS/UEFI ...

    We did not suceed yet flashing M1115 to LSI 9240-8i.
     
    #12
  13. mobilenvidia

    mobilenvidia Moderator

    Joined:
    Sep 25, 2011
    Messages:
    1,755
    Likes Received:
    51
    #13
  14. sapper6fd

    sapper6fd Member

    Joined:
    May 21, 2013
    Messages:
    48
    Likes Received:
    1
    What would this process have to do with an M1115? THis is for Perc cards being run in desktop systems. I may be wrong, but I'm not sure if this will affect the outcome.
     
    #14
  15. mobilenvidia

    mobilenvidia Moderator

    Joined:
    Sep 25, 2011
    Messages:
    1,755
    Likes Received:
    51
    The link included is just an example of what the taping can do, there are other devices this works for, there is a very good chance it may not work, but it will only cost you about 10mm of Sellotape and 5min of your time, and zero chance of doing any damage.
    I'm not too concerned if you don't try all options available, I can but give advice to help solve an issue.
     
    #15
    Brazen likes this.
  16. paradise regained

    paradise regained New Member

    Joined:
    Dec 29, 2013
    Messages:
    4
    Likes Received:
    1
    #16
    Brazen likes this.
  17. mobilenvidia

    mobilenvidia Moderator

    Joined:
    Sep 25, 2011
    Messages:
    1,755
    Likes Received:
    51
    You forget all my advise comes with a full money back guarantee, another one to chalk up to Sellotape.
     
    #17
Similar Threads: M1115 SAS9223-8i
Forum Title Date
RAID Controllers and Host Bus Adapters IBM M1115 Flash To IT Mode Jul 12, 2019
RAID Controllers and Host Bus Adapters Powering fan - pinout or schematics of any LSI card (927x, 93xx, M5210, M1115...) needed May 2, 2018
RAID Controllers and Host Bus Adapters Horror story flashing m1115 to it May 2, 2018
RAID Controllers and Host Bus Adapters IBM M1115 HBA not detecting disks Dec 21, 2017
RAID Controllers and Host Bus Adapters m1115 and SAS expander beeping like crazy Dec 7, 2017

Share This Page