IBM M1015 Experiences

mobilenvidia

Moderator
Sep 25, 2011
1,812
124
63
New Zealand
MR 4.11

Firmware Version: 20.12.1-0150

************************************

LSI Corp. MegaRAID Firmware Release

************************************

Release date: 09/23/13

======================
Supported Controllers:
======================

MegaRAID SAS 9240-4i
MegaRAID SAS 9240-8i


Component:
=========
SAS MegaRAID Firmware Release for MegaRAID Controllers
Release date: 09/23/13


Version Numbers:
===============

Current Firmware Package: 20.12.1-0150 (4.11)
Firmware 2.130.394-2550
WebBIOS 4.0-60-e_49-Rel
ROMENV 1.08
BootBlock 2.02.00.00-0001
NVDATA 3.09.03-0052
PCLI 03.02.20
Hii 1.37.00
UEFI_Driver 0x05270000
FCODE 4.12.05.00
BIOS 4.36.00
 

fort

New Member
Oct 10, 2013
1
0
0
Hi all,
I purchased a m1015-8i in IR mode, and I'm unable to create more than two raid volumes. is anyone else having this issue, I thought it said on ibm's site it had a max of 16. would I need to go back to the default firmware to allow this? im trying to re-use drives I already have to set up a home file store and a esxi iscsi target. unfortunately I have all different size drives (2x 3tb, 2x 2tb, 2x 1tb, other misc too small to be worth wile) so I figured I would use the 6 largest in 3 raid 1 volumes and the stripe them with storage spaces. however after creating 2 volumes, the create option is no longer available.

thanks
 
Last edited:

JimPhreak

Active Member
Oct 10, 2013
553
55
28
I bought an M1015 that I believe came flashed in IT mode as it doesn't show any info about the card during bootup so I can't get into any RAID utility. The card just passes the drives through as JBOD in FreeNAS for example (shows all discs attached to it) but I want to flash it back into normal RAID mode to use in a Windows file server. I'm having some serious trouble determining the right step by step process. I can't even get my SuperMicro board to boot to a MS-DOS bootable USB drive. I think I'm having one of those brain cramp filled says.

EDIT: Ok I was able to figure out how to flash it back to normal mode and did so with the latest firmware from LSI. However upon reboot my machine is now hanging at the LSI MegaRAID initialization screen. I can't boot to a hard drive or USB because it just hangs at this screen if I choose the boot menu. What do I do now?

 
Last edited:

ocso

New Member
Dec 7, 2013
1
0
0
Hi All,

@Fort, I have the same question about creating more than two Raid1 virtual disks/volumes: "I'm unable to create more than two raid volumes...".
I have M1015 flashed with latest 9211-8i IR firmware. Is it possible two create two independent RAID1 volumes under one drive group with LSI firmware? - actually I have 2 drive groups with 1-1 RAID1 virtual disks (4 HDDs).

LSI site says: maximum of 2 RAID volumes but IBM M1015 site says: "Supports up to 16 logical volumes"
Should I flash back the IBM official firmware to support more than two RAID volumes?

When I bought the card with original IBM official firmware I tried it in Asrock Z68M ITX, and Asus Z77 motherboard with Windows7 x64 installed, it recognized but it could not start it (Device manager displayed yellow "!" (Device cannot start (Error code: 10))) - after flashed LSI IR firmware everything went fine.
Currently I have a MOBO ASUS P8Z77-M PRO (Windows 2012 x64) and I am not sure that IBM M1015 with official firmware will work with this MOBO with Z77 chipset without issues.

Does anyone have any experience with the above?

Thanks in advance!